summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-05-18 03:48:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-05-18 03:48:28 +0000
commit59b17cd4f80d30a51520202ceee17553012b632f (patch)
treee7308c6ab989262d439cd9319732f2fe00afaf09 /dev-lang/hy/hy-0.11.0.ebuild
parentBump (diff)
downloadgentoo-2-59b17cd4f80d30a51520202ceee17553012b632f.tar.gz
gentoo-2-59b17cd4f80d30a51520202ceee17553012b632f.tar.bz2
gentoo-2-59b17cd4f80d30a51520202ceee17553012b632f.zip
Bump
(Portage version: 2.2.19/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/hy/hy-0.11.0.ebuild')
-rw-r--r--dev-lang/hy/hy-0.11.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/hy/hy-0.11.0.ebuild b/dev-lang/hy/hy-0.11.0.ebuild
new file mode 100644
index 000000000000..a7015914b478
--- /dev/null
+++ b/dev-lang/hy/hy-0.11.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hy/hy-0.11.0.ebuild,v 1.1 2015/05/18 03:48:28 patrick Exp $
+
+EAPI=5
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python2_7 python3_3 python3_4)
+
+inherit distutils-r1
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/astor-0.5[${PYTHON_USEDEP}]
+ dev-python/clint[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? ( dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}