summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-09-30 10:34:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-09-30 10:34:45 +0000
commit61f4e0eb2610a62aa9a5193f9c16af5e67f847a0 (patch)
treec66097db5b0557190782a8b93c510940224b3649 /dev-lang/ifc
parentadded Intel Software Development Product license (diff)
downloadgentoo-2-61f4e0eb2610a62aa9a5193f9c16af5e67f847a0.tar.gz
gentoo-2-61f4e0eb2610a62aa9a5193f9c16af5e67f847a0.tar.bz2
gentoo-2-61f4e0eb2610a62aa9a5193f9c16af5e67f847a0.zip
Version bump. Refactored the ebuild. Install debugger with USE flag and
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lang/ifc')
-rw-r--r--dev-lang/ifc/ChangeLog10
-rw-r--r--dev-lang/ifc/files/digest-ifc-10.0.0269
-rw-r--r--dev-lang/ifc/ifc-10.0.026.ebuild126
-rw-r--r--dev-lang/ifc/metadata.xml10
4 files changed, 154 insertions, 1 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
index 6deeb11d76ab..052f4d5207f0 100644
--- a/dev-lang/ifc/ChangeLog
+++ b/dev-lang/ifc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/ifc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.26 2007/07/02 14:44:01 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.27 2007/09/30 10:34:44 bicatali Exp $
+
+*ifc-10.0.026 (30 Sep 2007)
+
+ 30 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +ifc-10.0.026.ebuild:
+ Version bump. Refactored the ebuild. Install debugger with USE flag and
+ extra deps. No more slotted until we have some utility to switch between
+ versions.
02 Jul 2007; Piotr Jaroszyński <peper@gentoo.org> ifc-9.1.040.ebuild:
(QA) RESTRICT clean up.
diff --git a/dev-lang/ifc/files/digest-ifc-10.0.026 b/dev-lang/ifc/files/digest-ifc-10.0.026
new file mode 100644
index 000000000000..1975e423c8b9
--- /dev/null
+++ b/dev-lang/ifc/files/digest-ifc-10.0.026
@@ -0,0 +1,9 @@
+MD5 588fdfc9d4324ca701d0bd3c0cbac41b l_fc_c_10.0.026_ia32.tar.gz 147618
+RMD160 571204333185201ad363d5465d020f3a6cfd59f4 l_fc_c_10.0.026_ia32.tar.gz 147618
+SHA256 7c2576f27b422d9ff2213adea6f26746760288baaad6a20abd589de20126c86b l_fc_c_10.0.026_ia32.tar.gz 147618
+MD5 a3fbba1da828e222445e24fe1aad2d0d l_fc_c_10.0.026_ia64.tar.gz 67048117
+RMD160 50ece4d17023a39d99522af2738a8a1885fef483 l_fc_c_10.0.026_ia64.tar.gz 67048117
+SHA256 d9a5938681bacabb5fbc612f23b0870b1d74375735a357c2e943aa8da04330dc l_fc_c_10.0.026_ia64.tar.gz 67048117
+MD5 9c65b85b17bfad349ad45318ef54f242 l_fc_c_10.0.026_intel64.tar.gz 41346217
+RMD160 207cdd1bc81357e3631c38c5609f37f73f585ab5 l_fc_c_10.0.026_intel64.tar.gz 41346217
+SHA256 f2f306334ce47c6a778e1da21256a958aeb8d285740f35630567f9dc2a49e7f9 l_fc_c_10.0.026_intel64.tar.gz 41346217
diff --git a/dev-lang/ifc/ifc-10.0.026.ebuild b/dev-lang/ifc/ifc-10.0.026.ebuild
new file mode 100644
index 000000000000..4701edc8b212
--- /dev/null
+++ b/dev-lang/ifc/ifc-10.0.026.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-10.0.026.ebuild,v 1.1 2007/09/30 10:34:44 bicatali Exp $
+
+inherit rpm elisp-common
+
+PID=787
+PB=fc
+PEXEC=ifort
+DESCRIPTION="Intel FORTRAN 77/95 optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/flin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKAGEID="l_${PB}_c_${PV}"
+KEYWORDS="~amd64 ~ia64 ~x86"
+SRC_URI="amd64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_intel64.tar.gz )
+ ia64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia64.tar.gz )
+ x86? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia32.tar.gz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+
+RESTRICT="test strip mirror"
+IUSE="emacs debugger"
+
+DEPEND=""
+RDEPEND="debugger? (
+ x11-libs/libXt
+ x11-libs/libXft
+ dev-libs/libxml2
+ virtual/libstdc++ )"
+
+if use x86; then
+ MY_P="${PACKAGEID}_ia32"
+elif use amd64; then
+ MY_P="${PACKAGEID}_intel64"
+elif use ia64; then
+ MY_P="${PACKAGEID}_ia64"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ local ext=
+ use amd64 && ext=e
+ INSTALL_DIR=/opt/intel/${PB}${ext}/${PV}
+
+ if use debugger && [[ ! -x /opt/intel/idb${ext}/${PV}/bin/idb ]]; then
+ INSTALL_IDB_DIR=/opt/intel/idb${ext}/${PV}
+ else
+ use debugger && einfo "Debugger already installed"
+ rm -f data/intel*idb*.rpm
+ fi
+
+ for x in data/intel*.rpm; do
+ einfo "Extracting $(basename ${x})..."
+ rpm_unpack "${S}/${x}" || die "rpm_unpack ${x} failed"
+ done
+
+ einfo "Fixing paths and tagging"
+ cd "${S}"/${INSTALL_DIR}/bin
+ sed -e "s|<INSTALLDIR>|${INSTALL_DIR}|g" \
+ -i ${PEXEC} ${PEXEC}*sh \
+ || die "sed fixing path failed"
+
+ cd "${S}"/${INSTALL_DIR}/doc
+ sed -e "s|\<installpackageid\>|${PACKAGEID}|g" \
+ -e "s|\<INSTALLTIMECOMBOPACKAGEID\>|${PACKAGEID}|g" \
+ -i *support \
+ || die "sed support file failed"
+ chmod 644 *support
+}
+
+src_install() {
+ einfo "Copying files"
+ dodir ${INSTALL_DIR}
+ cp -pPR \
+ "${S}"/${INSTALL_DIR}/* \
+ "${D}"/${INSTALL_DIR}/ \
+ || die "copying ${PN} failed"
+
+ local env_file=05${PN}
+ echo "PATH=${INSTALL_DIR}/bin" > ${env_file}
+ echo "ROOTPATH=${INSTALL_DIR}/bin" >> ${env_file}
+ echo "LDPATH=${INSTALL_DIR}/lib" >> ${env_file}
+ echo "MANPATH=${INSTALL_DIR}/man" >> ${env_file}
+ echo "INCLUDE=${INSTALL_DIR}/include" >> ${env_file}
+ echo "IA32ROOT=${INSTALL_DIR}" >> ${env_file}
+ doenvd ${env_file} || die "doenvd ${env_file} failed"
+
+ if [[ -n ${INSTALL_IDB_DIR} ]]; then
+ dodir ${INSTALL_IDB_DIR}
+ cp -pPR \
+ "${S}"/${INSTALL_IDB_DIR}/* \
+ "${D}"/${INSTALL_IDB_DIR}/ \
+ || die "copying debugger failed"
+ local idb_env_file=06idb
+ echo "PATH=${INSTALL_IDB_DIR}/bin" > ${idb_env_file}
+ echo "ROOTPATH=${INSTALL_IDB_DIR}/bin" >> ${idb_env_file}
+ echo "MANPATH=${INSTALL_IDB_DIR}/man" >> ${idb_env_file}
+ doenvd ${idb_env_file} || die "doenvd ${idb_env_file} failed"
+ use emacs && \
+ elisp-site-file-install "${S}"${INSTALL_IDB_DIR}/bin/*.el
+ fi
+}
+
+pkg_postinst () {
+ elog "Make sure you have recieved the restrictive"
+ elog "non-commercial license ${PN} by registering at:"
+ elog "http://www.intel.com/cd/software/products/asmo-na/eng/download/download/219771.htm"
+ elog "You cannot run ${PN} without this license file."
+ elog "Read the website for more information on this license."
+ elog "To use ${PN} now, issue first \n\tsource /etc/profile"
+ use emacs && elisp-site-regen
+ rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log}
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/ifc/metadata.xml b/dev-lang/ifc/metadata.xml
index e7dba3d5617a..7a5df05b4d4a 100644
--- a/dev-lang/ifc/metadata.xml
+++ b/dev-lang/ifc/metadata.xml
@@ -6,4 +6,14 @@
<email>kugelfang@gentoo.org</email>
<name>Danny van Dyk</name>
</maintainer>
+<longdescription lang="en">
+The Intel® Fortran Compiler is a full features FORTRAN 77/95 and
+substantial FORTRAN 2003 compiler for Intel based architectures.
+It is here offered as a non-commercial (please see web site to see
+terms of qualifications).
+The compiler supports multi-threading, and processor support that includes automatic
+processor dispatch, vectorization, auto-parallelization, OpenMP, data
+prefetching, loop unrolling. The package come with a debugger and
+large documentation.
+</longdescription>
</pkgmetadata>