summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-01-13 02:06:59 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-01-13 02:06:59 +0000
commitd6eeacc872669af33a61ff699a0935056a0d63c2 (patch)
tree5b4be0404b22ec3bcbc86308fea39399c41cc9c4 /dev-lang/ispc
parentRevbump fixing LICENSE and missing RDEPEND, bug #532618. (diff)
downloadgentoo-2-d6eeacc872669af33a61ff699a0935056a0d63c2.tar.gz
gentoo-2-d6eeacc872669af33a61ff699a0935056a0d63c2.tar.bz2
gentoo-2-d6eeacc872669af33a61ff699a0935056a0d63c2.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ChangeLog9
-rw-r--r--dev-lang/ispc/ispc-1.8.1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index f7858305c3bf..3ea47cced3c0 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ispc
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.18 2014/10/25 03:58:50 ottxor Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.19 2015/01/13 02:06:59 ottxor Exp $
+
+*ispc-1.8.1 (13 Jan 2015)
+
+ 13 Jan 2015; Christoph Junghans <ottxor@gentoo.org> +ispc-1.8.1.ebuild:
+ version bump
*ispc-1.8.0 (25 Oct 2014)
diff --git a/dev-lang/ispc/ispc-1.8.1.ebuild b/dev-lang/ispc/ispc-1.8.1.ebuild
new file mode 100644
index 000000000000..a19a89ef7090
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.8.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.8.1.ebuild,v 1.1 2015/01/13 02:06:59 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit toolchain-funcs python-any-r1
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="http://ispc.github.com/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
+ "
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_compile() {
+ sed -i '/^\t@/s/@//' Makefile || die #make all slient commands ("@") verbose
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+ dodoc README.rst
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}