summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-26 02:55:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-26 02:55:32 +0000
commit3aa5d68716bd6db426177711814e45fe0d3324db (patch)
tree9c4a489b20b3860d5efc38131b32ec3427677495 /dev-lang/moarvm/moarvm-2014.05.ebuild
parentInitial version (diff)
downloadgentoo-2-3aa5d68716bd6db426177711814e45fe0d3324db.tar.gz
gentoo-2-3aa5d68716bd6db426177711814e45fe0d3324db.tar.bz2
gentoo-2-3aa5d68716bd6db426177711814e45fe0d3324db.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/moarvm/moarvm-2014.05.ebuild')
-rw-r--r--dev-lang/moarvm/moarvm-2014.05.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/moarvm/moarvm-2014.05.ebuild b/dev-lang/moarvm/moarvm-2014.05.ebuild
new file mode 100644
index 000000000000..311ad4549aba
--- /dev/null
+++ b/dev-lang/moarvm/moarvm-2014.05.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/moarvm/moarvm-2014.05.ebuild,v 1.1 2014/05/26 02:55:32 patrick Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+MY_PN="MoarVM"
+
+DESCRIPTION="A 6model-based VM for NQP and Rakudo Perl 6"
+HOMEPAGE="http://moarvm.org"
+SRC_URI="http://moarvm.org/releases/${MY_PN}-${PV}.tar.gz"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libuv"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/MoarVM-${PV}"
+
+src_configure() {
+ perl Configure.pl --prefix="${D}/usr"|| die
+}
+
+src_install() {
+ emake install
+}