summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-03 22:10:12 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-03 22:10:12 +0000
commit5c074c11316eb75beb0834572a645b2c4719d6eb (patch)
tree4849afdd88be7e96228767be075612cf106115dd /dev-lang/mono
parentppc stable wrt #311725 (diff)
downloadgentoo-2-5c074c11316eb75beb0834572a645b2c4719d6eb.tar.gz
gentoo-2-5c074c11316eb75beb0834572a645b2c4719d6eb.tar.bz2
gentoo-2-5c074c11316eb75beb0834572a645b2c4719d6eb.zip
Fix bug 321139, remove old
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog10
-rw-r--r--dev-lang/mono/files/mono-2.6.4-require-glib.patch12
-rw-r--r--dev-lang/mono/mono-2.6.1.ebuild272
-rw-r--r--dev-lang/mono/mono-2.6.3.ebuild272
-rw-r--r--dev-lang/mono/mono-2.6.4-r1.ebuild (renamed from dev-lang/mono/mono-2.4.3.ebuild)3
-rw-r--r--dev-lang/mono/mono-2.6.4.ebuild272
6 files changed, 23 insertions, 818 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index ca865ee266c7..e62e1e0dd832 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/mono
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.189 2010/05/19 18:32:53 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.190 2010/07/03 22:10:12 pacho Exp $
+
+*mono-2.6.4-r1 (03 Jul 2010)
+
+ 03 Jul 2010; Pacho Ramos <pacho@gentoo.org> -mono-2.4.3.ebuild,
+ -mono-2.6.1.ebuild, -mono-2.6.3.ebuild, -mono-2.6.4.ebuild,
+ +mono-2.6.4-r1.ebuild, +files/mono-2.6.4-require-glib.patch:
+ Revision bump to fix openoffice building problem against mono-2.6.4 (bug
+ #321139 by Brian Beardall, Aaron Haviland and others). Remove old.
*mono-2.6.4 (19 May 2010)
diff --git a/dev-lang/mono/files/mono-2.6.4-require-glib.patch b/dev-lang/mono/files/mono-2.6.4-require-glib.patch
new file mode 100644
index 000000000000..abd703cb2ae9
--- /dev/null
+++ b/dev-lang/mono/files/mono-2.6.4-require-glib.patch
@@ -0,0 +1,12 @@
+--- data/mono.pc.in 2010-04-22 09:37:47.000000000 -0600
++++ data/mono.pc.in 2010-05-10 09:30:04.000000000 -0600
+@@ -7,8 +7,6 @@
+ Name: Mono
+ Description: Mono Runtime
+ Version: @VERSION@
+-## Commented out because SLE hides devel files in the SLE SDK,
+-## which not all customers will have.
+-#Requires: glib-2.0 gthread-2.0
++Requires: glib-2.0 gthread-2.0
+ Libs: -L${libdir} @export_ldflags@ -lmono @libmono_ldflags@
+ Cflags: -I${includedir} @libmono_cflags@
diff --git a/dev-lang/mono/mono-2.6.1.ebuild b/dev-lang/mono/mono-2.6.1.ebuild
deleted file mode 100644
index d0852bd81c7f..000000000000
--- a/dev-lang/mono/mono-2.6.1.ebuild
+++ /dev/null
@@ -1,272 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.6.1.ebuild,v 1.1 2010/02/20 10:34:29 patrick Exp $
-
-EAPI=2
-
-inherit linux-info mono eutils flag-o-matic multilib go-mono
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.go-mono.com"
-
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="xen moonlight minimal"
-
-#Bash requirement is for += operator
-COMMONDEPEND="!<dev-dotnet/pnet-0.6.12
- !dev-util/monodoc
- dev-libs/glib:2
- !minimal? ( =dev-dotnet/libgdiplus-${GO_MONO_REL_PV}* )
- ia64? (
- sys-libs/libunwind
- )"
-RDEPEND="${COMMONDEPEND}
- || ( www-client/links www-client/lynx )"
-
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- >=app-shells/bash-3.2"
-PDEPEND="dev-dotnet/pe-format"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-RESTRICT="test"
-
-PATCHES=(
- "${WORKDIR}/mono-2.2-libdir126.patch"
- "${FILESDIR}/mono-2.2-ppc-threading.patch"
- "${FILESDIR}/mono-2.2-uselibdir.patch"
-)
-
-pkg_setup() {
- if use kernel_linux
- then
- get_version
- if linux_config_exists
- then
- if linux_chkconfig_present SYSVIPC
- then
- einfo "CONFIG_SYSVIPC is set, looking good."
- else
- eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
- fi
- else
- ewarn "Was unable to determine your kernel .config"
- ewarn "Please note that if CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- ewarn "See http://bugs.gentoo.org/261869 for more info."
- fi
- fi
-}
-
-src_prepare() {
- sed -e "s:@MONOLIBDIR@:$(get_libdir):" \
- < "${FILESDIR}"/mono-2.2-libdir126.patch \
- > "${WORKDIR}"/mono-2.2-libdir126.patch ||
- die "Sedding patch file failed"
- go-mono_src_prepare
-}
-
-src_configure() {
- # mono's build system is finiky, strip the flags
- strip-flags
-
- #Remove this at your own peril. Mono will barf in unexpected ways.
- append-flags -fno-strict-aliasing
-
- #NOTE: We need the static libs for now so mono-debugger works.
- #See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
- go-mono_src_configure \
- --enable-static \
- --disable-quiet-build \
- --with-preview \
- --with-glib=system \
- $(use_with moonlight) \
- --with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
- $(use_with xen xen_opt) \
- --without-ikvm-native \
- --with-jit \
- --disable-dtrace
-
-}
-
-src_test() {
- echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
-
- export MONO_REGISTRY_PATH="${T}/registry"
- export XDG_DATA_HOME="${T}/data"
- export MONO_SHARED_DIR="${T}/shared"
- export XDG_CONFIG_HOME="${T}/config"
- export HOME="${T}/home"
-
- emake -j1 check
-}
-
-src_install() {
- go-mono_src_install
-
- #Bug 255610
- sed -i -e "s:mono/2.0/mod.exe:mono/1.0/mod.exe:" \
- "${D}"/usr/bin/mod || die "Failed to fix mod."
-
- find "${D}"/usr/ -name '*nunit-docs*' -exec rm -rf '{}' '+' || die "Removing nunit .docs failed"
-
- # Remove Jay to avoid colliding with dev-util/jay, the internal
- # version is only used to build mcs.
- rm -r "${D}"/usr/share/jay "${D}"/usr/bin/jay "${D}"/usr/share/man/man1/jay.1*
-}
-
-#THINK!!!! Before touching postrm and postinst
-#Reference phase order:
-#pkg_preinst
-#pkg_prerm
-#pkg_postrm
-#pkg_postinst
-
-pkg_preinst() {
- local symlink
- local NUNIT_DIR="/usr/$(get_libdir)/mono/nunit"
- local pv_atom
- if [[ "$(readlink "${ROOT}"/${NUNIT_DIR})" == *"mono-nunit"* ]]
- then
- for pv_atom in 2.2{,-r1,-r2,-r3,-r4} '2.4_pre*' '2.4_rc*' 2.4
- do
- if has_version "=dev-lang/mono-${pv_atom}"
- then
- einfo "If you just received a file collision warning message,"
- einfo "be advised that this is a known problem, which will now be fixed:"
- ebegin "Found broken symlinks created by $(best_version dev-lang/mono), fixing"
- for symlink in \
- "${ROOT}/${NUNIT_DIR}" \
- "${ROOT}/usr/$(get_libdir)/pkgconfig/nunit.pc" \
- "${ROOT}/usr/bin/nunit-console" \
- "${ROOT}/usr/bin/nunit-console2"
- do
- if [[ -L "${symlink}" ]]
- then
- rm -f "${symlink}" &> /dev/null
- fi
- done
- eend 0
- break
- fi
- done
- fi
-}
-
-pkg_postinst() {
- elog "PLEASE TAKE NOTE!"
- elog ""
- elog "Some of the namespaces supported by Mono require extra packages to be installed."
- elog "Below is a list of namespaces and the corresponding package you must install:"
- elog ""
- elog ">=x11-libs/cairo-1.6.4"
- elog " Mono.Cairo"
- elog "Also read:"
- elog "http://www.mono-project.com/Mono.Cairo"
- elog ""
- elog ">=dev-db/firebird-2.0.4.13130.1"
- elog " FirebirdSql.Data.Firebird"
- elog "Also read:"
- elog "http://www.mono-project.com/Firebird_Interbase"
- elog ""
- elog "=dev-dotnet/gluezilla-${GO_MONO_REL_PV}*"
- elog " Mono.Mozilla"
- elog " Mono.Mozilla.WebBrowser"
- elog " Mono.Mozilla.Widget"
- elog " Interop.SHDocVw"
- elog " AxInterop.SHDocVw"
- elog " Interop.mshtml.dll"
- elog " System.Windows.Forms.WebBrowser"
- elog " Microsoft.IE"
- elog "Also read:"
- elog "http://www.mono-project.com/WebBrowser"
- elog ""
- elog "dev-db/sqlite:3"
- elog " Mono.Data.Sqlite"
- elog " Mono.Data.SqliteClient"
- elog "Also read:"
- elog "http://www.mono-project.com/SQLite"
- elog ""
- elog ">=dev-db/oracle-instantclient-basic-10.2"
- elog " System.Data.OracleClient"
- elog "Also read:"
- elog "http://www.mono-project.com/Oracle"
- elog ""
- elog "Mono also has support for packages that are not included in portage:"
- elog ""
- elog "No ebuild available:"
- elog " IBM.Data.DB2"
- elog "Also read: http://www.mono-project.com/IBM_DB2"
- elog ""
- elog "No ebuild needed:"
- elog " Mono.Data.SybaseClient"
- elog "Also read: http://www.mono-project.com/Sybase"
-}
-
-# NOTICE: THE COPYRIGHT FILES IN THE TARBALL ARE UNCLEAR!
-# WHENEVER YOU THINK SOMETHING IS GPL-2+, IT'S ONLY GPL-2
-# UNLESS MIGUEL DE ICAZA HIMSELF SAYS OTHERWISE.
-
-# mono
-# The code we use is LGPL, but contributions must be made under the MIT/X11
-# license, so Novell can serve its paying customers. Exception is mono/man.
-# LICENSE="LGPL-2.1"
-
- # mono/man
- # LICENSE="MIT"
-
-# mcs/mcs
-# mcs/gmcs
-# LICENSE="GPL-2 MIT"
-
-# tests
-# LICENSE="MIT"
-
-# mcs/class
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/class/ByteFX.Data
- # mcs/class/Npgsql
- # LICENSE="LGPL-2.1"
-
- # mcs/class/FirebirdSql.Data.Firebird
- # LICENSE="IDPL"
-
- # mcs/class/ICSharpCode.SharpZipLib
- # LICENSE="GPL-2-with-linking-exception"
-
- # mcs/class/MicrosoftAjaxLibrary
- # LICENSE="Ms-Pl"
-
- # mcs/class/Microsoft.JScript/Microsoft.JScript/TokenStream.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Token.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Parser.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Decompiler.cs
- # LICENSE="|| ( NPL-1.1 GPL-2 )"
-
-# mcs/jay
-# LICENSE="BSD-4"
-
-# mcs/tools
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/tools/mdoc/Mono.Documentation/monodocs2html.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/sqlsharp/SqlSharpCli.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/csharp/repl.cs
- # LICENSE="|| ( MIT GPL-2 )"
-
- # mcs/tools/mono-win32-setup.nsi
- # LICENSE="GPL-2"
-
-# samples
-# LICENSE="MIT"
diff --git a/dev-lang/mono/mono-2.6.3.ebuild b/dev-lang/mono/mono-2.6.3.ebuild
deleted file mode 100644
index 6dffe848cd3e..000000000000
--- a/dev-lang/mono/mono-2.6.3.ebuild
+++ /dev/null
@@ -1,272 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.6.3.ebuild,v 1.1 2010/03/19 10:33:27 patrick Exp $
-
-EAPI=2
-
-inherit linux-info mono eutils flag-o-matic multilib go-mono
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.go-mono.com"
-
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="xen moonlight minimal"
-
-#Bash requirement is for += operator
-COMMONDEPEND="!<dev-dotnet/pnet-0.6.12
- !dev-util/monodoc
- dev-libs/glib:2
- !minimal? ( =dev-dotnet/libgdiplus-${GO_MONO_REL_PV}* )
- ia64? (
- sys-libs/libunwind
- )"
-RDEPEND="${COMMONDEPEND}
- || ( www-client/links www-client/lynx )"
-
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- >=app-shells/bash-3.2"
-PDEPEND="dev-dotnet/pe-format"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-RESTRICT="test"
-
-PATCHES=(
- "${WORKDIR}/mono-2.2-libdir126.patch"
- "${FILESDIR}/mono-2.2-ppc-threading.patch"
- "${FILESDIR}/mono-2.2-uselibdir.patch"
-)
-
-pkg_setup() {
- if use kernel_linux
- then
- get_version
- if linux_config_exists
- then
- if linux_chkconfig_present SYSVIPC
- then
- einfo "CONFIG_SYSVIPC is set, looking good."
- else
- eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
- fi
- else
- ewarn "Was unable to determine your kernel .config"
- ewarn "Please note that if CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- ewarn "See http://bugs.gentoo.org/261869 for more info."
- fi
- fi
-}
-
-src_prepare() {
- sed -e "s:@MONOLIBDIR@:$(get_libdir):" \
- < "${FILESDIR}"/mono-2.2-libdir126.patch \
- > "${WORKDIR}"/mono-2.2-libdir126.patch ||
- die "Sedding patch file failed"
- go-mono_src_prepare
-}
-
-src_configure() {
- # mono's build system is finiky, strip the flags
- strip-flags
-
- #Remove this at your own peril. Mono will barf in unexpected ways.
- append-flags -fno-strict-aliasing
-
- #NOTE: We need the static libs for now so mono-debugger works.
- #See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
- go-mono_src_configure \
- --enable-static \
- --disable-quiet-build \
- --with-preview \
- --with-glib=system \
- $(use_with moonlight) \
- --with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
- $(use_with xen xen_opt) \
- --without-ikvm-native \
- --with-jit \
- --disable-dtrace
-
-}
-
-src_test() {
- echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
-
- export MONO_REGISTRY_PATH="${T}/registry"
- export XDG_DATA_HOME="${T}/data"
- export MONO_SHARED_DIR="${T}/shared"
- export XDG_CONFIG_HOME="${T}/config"
- export HOME="${T}/home"
-
- emake -j1 check
-}
-
-src_install() {
- go-mono_src_install
-
- #Bug 255610
- sed -i -e "s:mono/2.0/mod.exe:mono/1.0/mod.exe:" \
- "${D}"/usr/bin/mod || die "Failed to fix mod."
-
- find "${D}"/usr/ -name '*nunit-docs*' -exec rm -rf '{}' '+' || die "Removing nunit .docs failed"
-
- # Remove Jay to avoid colliding with dev-util/jay, the internal
- # version is only used to build mcs.
- rm -r "${D}"/usr/share/jay "${D}"/usr/bin/jay "${D}"/usr/share/man/man1/jay.1*
-}
-
-#THINK!!!! Before touching postrm and postinst
-#Reference phase order:
-#pkg_preinst
-#pkg_prerm
-#pkg_postrm
-#pkg_postinst
-
-pkg_preinst() {
- local symlink
- local NUNIT_DIR="/usr/$(get_libdir)/mono/nunit"
- local pv_atom
- if [[ "$(readlink "${ROOT}"/${NUNIT_DIR})" == *"mono-nunit"* ]]
- then
- for pv_atom in 2.2{,-r1,-r2,-r3,-r4} '2.4_pre*' '2.4_rc*' 2.4
- do
- if has_version "=dev-lang/mono-${pv_atom}"
- then
- einfo "If you just received a file collision warning message,"
- einfo "be advised that this is a known problem, which will now be fixed:"
- ebegin "Found broken symlinks created by $(best_version dev-lang/mono), fixing"
- for symlink in \
- "${ROOT}/${NUNIT_DIR}" \
- "${ROOT}/usr/$(get_libdir)/pkgconfig/nunit.pc" \
- "${ROOT}/usr/bin/nunit-console" \
- "${ROOT}/usr/bin/nunit-console2"
- do
- if [[ -L "${symlink}" ]]
- then
- rm -f "${symlink}" &> /dev/null
- fi
- done
- eend 0
- break
- fi
- done
- fi
-}
-
-pkg_postinst() {
- elog "PLEASE TAKE NOTE!"
- elog ""
- elog "Some of the namespaces supported by Mono require extra packages to be installed."
- elog "Below is a list of namespaces and the corresponding package you must install:"
- elog ""
- elog ">=x11-libs/cairo-1.6.4"
- elog " Mono.Cairo"
- elog "Also read:"
- elog "http://www.mono-project.com/Mono.Cairo"
- elog ""
- elog ">=dev-db/firebird-2.0.4.13130.1"
- elog " FirebirdSql.Data.Firebird"
- elog "Also read:"
- elog "http://www.mono-project.com/Firebird_Interbase"
- elog ""
- elog "=dev-dotnet/gluezilla-${GO_MONO_REL_PV}*"
- elog " Mono.Mozilla"
- elog " Mono.Mozilla.WebBrowser"
- elog " Mono.Mozilla.Widget"
- elog " Interop.SHDocVw"
- elog " AxInterop.SHDocVw"
- elog " Interop.mshtml.dll"
- elog " System.Windows.Forms.WebBrowser"
- elog " Microsoft.IE"
- elog "Also read:"
- elog "http://www.mono-project.com/WebBrowser"
- elog ""
- elog "dev-db/sqlite:3"
- elog " Mono.Data.Sqlite"
- elog " Mono.Data.SqliteClient"
- elog "Also read:"
- elog "http://www.mono-project.com/SQLite"
- elog ""
- elog ">=dev-db/oracle-instantclient-basic-10.2"
- elog " System.Data.OracleClient"
- elog "Also read:"
- elog "http://www.mono-project.com/Oracle"
- elog ""
- elog "Mono also has support for packages that are not included in portage:"
- elog ""
- elog "No ebuild available:"
- elog " IBM.Data.DB2"
- elog "Also read: http://www.mono-project.com/IBM_DB2"
- elog ""
- elog "No ebuild needed:"
- elog " Mono.Data.SybaseClient"
- elog "Also read: http://www.mono-project.com/Sybase"
-}
-
-# NOTICE: THE COPYRIGHT FILES IN THE TARBALL ARE UNCLEAR!
-# WHENEVER YOU THINK SOMETHING IS GPL-2+, IT'S ONLY GPL-2
-# UNLESS MIGUEL DE ICAZA HIMSELF SAYS OTHERWISE.
-
-# mono
-# The code we use is LGPL, but contributions must be made under the MIT/X11
-# license, so Novell can serve its paying customers. Exception is mono/man.
-# LICENSE="LGPL-2.1"
-
- # mono/man
- # LICENSE="MIT"
-
-# mcs/mcs
-# mcs/gmcs
-# LICENSE="GPL-2 MIT"
-
-# tests
-# LICENSE="MIT"
-
-# mcs/class
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/class/ByteFX.Data
- # mcs/class/Npgsql
- # LICENSE="LGPL-2.1"
-
- # mcs/class/FirebirdSql.Data.Firebird
- # LICENSE="IDPL"
-
- # mcs/class/ICSharpCode.SharpZipLib
- # LICENSE="GPL-2-with-linking-exception"
-
- # mcs/class/MicrosoftAjaxLibrary
- # LICENSE="Ms-Pl"
-
- # mcs/class/Microsoft.JScript/Microsoft.JScript/TokenStream.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Token.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Parser.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Decompiler.cs
- # LICENSE="|| ( NPL-1.1 GPL-2 )"
-
-# mcs/jay
-# LICENSE="BSD-4"
-
-# mcs/tools
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/tools/mdoc/Mono.Documentation/monodocs2html.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/sqlsharp/SqlSharpCli.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/csharp/repl.cs
- # LICENSE="|| ( MIT GPL-2 )"
-
- # mcs/tools/mono-win32-setup.nsi
- # LICENSE="GPL-2"
-
-# samples
-# LICENSE="MIT"
diff --git a/dev-lang/mono/mono-2.4.3.ebuild b/dev-lang/mono/mono-2.6.4-r1.ebuild
index 9b2a72d9d53d..7542f4870744 100644
--- a/dev-lang/mono/mono-2.4.3.ebuild
+++ b/dev-lang/mono/mono-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.4.3.ebuild,v 1.1 2010/02/06 16:42:18 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.6.4-r1.ebuild,v 1.1 2010/07/03 22:10:12 pacho Exp $
EAPI=2
@@ -38,6 +38,7 @@ PATCHES=(
"${WORKDIR}/mono-2.2-libdir126.patch"
"${FILESDIR}/mono-2.2-ppc-threading.patch"
"${FILESDIR}/mono-2.2-uselibdir.patch"
+ "${FILESDIR}/mono-2.6.4-require-glib.patch"
)
pkg_setup() {
diff --git a/dev-lang/mono/mono-2.6.4.ebuild b/dev-lang/mono/mono-2.6.4.ebuild
deleted file mode 100644
index c39376df548b..000000000000
--- a/dev-lang/mono/mono-2.6.4.ebuild
+++ /dev/null
@@ -1,272 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.6.4.ebuild,v 1.1 2010/05/19 18:32:53 patrick Exp $
-
-EAPI=2
-
-inherit linux-info mono eutils flag-o-matic multilib go-mono
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="http://www.go-mono.com"
-
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="xen moonlight minimal"
-
-#Bash requirement is for += operator
-COMMONDEPEND="!<dev-dotnet/pnet-0.6.12
- !dev-util/monodoc
- dev-libs/glib:2
- !minimal? ( =dev-dotnet/libgdiplus-${GO_MONO_REL_PV}* )
- ia64? (
- sys-libs/libunwind
- )"
-RDEPEND="${COMMONDEPEND}
- || ( www-client/links www-client/lynx )"
-
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- >=app-shells/bash-3.2"
-PDEPEND="dev-dotnet/pe-format"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-RESTRICT="test"
-
-PATCHES=(
- "${WORKDIR}/mono-2.2-libdir126.patch"
- "${FILESDIR}/mono-2.2-ppc-threading.patch"
- "${FILESDIR}/mono-2.2-uselibdir.patch"
-)
-
-pkg_setup() {
- if use kernel_linux
- then
- get_version
- if linux_config_exists
- then
- if linux_chkconfig_present SYSVIPC
- then
- einfo "CONFIG_SYSVIPC is set, looking good."
- else
- eerror "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- eerror "See http://bugs.gentoo.org/261869 for more info."
- die "Please set CONFIG_SYSVIPC in your kernel .config"
- fi
- else
- ewarn "Was unable to determine your kernel .config"
- ewarn "Please note that if CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- ewarn "See http://bugs.gentoo.org/261869 for more info."
- fi
- fi
-}
-
-src_prepare() {
- sed -e "s:@MONOLIBDIR@:$(get_libdir):" \
- < "${FILESDIR}"/mono-2.2-libdir126.patch \
- > "${WORKDIR}"/mono-2.2-libdir126.patch ||
- die "Sedding patch file failed"
- go-mono_src_prepare
-}
-
-src_configure() {
- # mono's build system is finiky, strip the flags
- strip-flags
-
- #Remove this at your own peril. Mono will barf in unexpected ways.
- append-flags -fno-strict-aliasing
-
- #NOTE: We need the static libs for now so mono-debugger works.
- #See http://bugs.gentoo.org/show_bug.cgi?id=256264 for details
- go-mono_src_configure \
- --enable-static \
- --disable-quiet-build \
- --with-preview \
- --with-glib=system \
- $(use_with moonlight) \
- --with-libgdiplus=$(use minimal && printf "no" || printf "installed" ) \
- $(use_with xen xen_opt) \
- --without-ikvm-native \
- --with-jit \
- --disable-dtrace
-
-}
-
-src_test() {
- echo ">>> Test phase [check]: ${CATEGORY}/${PF}"
-
- export MONO_REGISTRY_PATH="${T}/registry"
- export XDG_DATA_HOME="${T}/data"
- export MONO_SHARED_DIR="${T}/shared"
- export XDG_CONFIG_HOME="${T}/config"
- export HOME="${T}/home"
-
- emake -j1 check
-}
-
-src_install() {
- go-mono_src_install
-
- #Bug 255610
- sed -i -e "s:mono/2.0/mod.exe:mono/1.0/mod.exe:" \
- "${D}"/usr/bin/mod || die "Failed to fix mod."
-
- find "${D}"/usr/ -name '*nunit-docs*' -exec rm -rf '{}' '+' || die "Removing nunit .docs failed"
-
- # Remove Jay to avoid colliding with dev-util/jay, the internal
- # version is only used to build mcs.
- rm -r "${D}"/usr/share/jay "${D}"/usr/bin/jay "${D}"/usr/share/man/man1/jay.1*
-}
-
-#THINK!!!! Before touching postrm and postinst
-#Reference phase order:
-#pkg_preinst
-#pkg_prerm
-#pkg_postrm
-#pkg_postinst
-
-pkg_preinst() {
- local symlink
- local NUNIT_DIR="/usr/$(get_libdir)/mono/nunit"
- local pv_atom
- if [[ "$(readlink "${ROOT}"/${NUNIT_DIR})" == *"mono-nunit"* ]]
- then
- for pv_atom in 2.2{,-r1,-r2,-r3,-r4} '2.4_pre*' '2.4_rc*' 2.4
- do
- if has_version "=dev-lang/mono-${pv_atom}"
- then
- einfo "If you just received a file collision warning message,"
- einfo "be advised that this is a known problem, which will now be fixed:"
- ebegin "Found broken symlinks created by $(best_version dev-lang/mono), fixing"
- for symlink in \
- "${ROOT}/${NUNIT_DIR}" \
- "${ROOT}/usr/$(get_libdir)/pkgconfig/nunit.pc" \
- "${ROOT}/usr/bin/nunit-console" \
- "${ROOT}/usr/bin/nunit-console2"
- do
- if [[ -L "${symlink}" ]]
- then
- rm -f "${symlink}" &> /dev/null
- fi
- done
- eend 0
- break
- fi
- done
- fi
-}
-
-pkg_postinst() {
- elog "PLEASE TAKE NOTE!"
- elog ""
- elog "Some of the namespaces supported by Mono require extra packages to be installed."
- elog "Below is a list of namespaces and the corresponding package you must install:"
- elog ""
- elog ">=x11-libs/cairo-1.6.4"
- elog " Mono.Cairo"
- elog "Also read:"
- elog "http://www.mono-project.com/Mono.Cairo"
- elog ""
- elog ">=dev-db/firebird-2.0.4.13130.1"
- elog " FirebirdSql.Data.Firebird"
- elog "Also read:"
- elog "http://www.mono-project.com/Firebird_Interbase"
- elog ""
- elog "=dev-dotnet/gluezilla-${GO_MONO_REL_PV}*"
- elog " Mono.Mozilla"
- elog " Mono.Mozilla.WebBrowser"
- elog " Mono.Mozilla.Widget"
- elog " Interop.SHDocVw"
- elog " AxInterop.SHDocVw"
- elog " Interop.mshtml.dll"
- elog " System.Windows.Forms.WebBrowser"
- elog " Microsoft.IE"
- elog "Also read:"
- elog "http://www.mono-project.com/WebBrowser"
- elog ""
- elog "dev-db/sqlite:3"
- elog " Mono.Data.Sqlite"
- elog " Mono.Data.SqliteClient"
- elog "Also read:"
- elog "http://www.mono-project.com/SQLite"
- elog ""
- elog ">=dev-db/oracle-instantclient-basic-10.2"
- elog " System.Data.OracleClient"
- elog "Also read:"
- elog "http://www.mono-project.com/Oracle"
- elog ""
- elog "Mono also has support for packages that are not included in portage:"
- elog ""
- elog "No ebuild available:"
- elog " IBM.Data.DB2"
- elog "Also read: http://www.mono-project.com/IBM_DB2"
- elog ""
- elog "No ebuild needed:"
- elog " Mono.Data.SybaseClient"
- elog "Also read: http://www.mono-project.com/Sybase"
-}
-
-# NOTICE: THE COPYRIGHT FILES IN THE TARBALL ARE UNCLEAR!
-# WHENEVER YOU THINK SOMETHING IS GPL-2+, IT'S ONLY GPL-2
-# UNLESS MIGUEL DE ICAZA HIMSELF SAYS OTHERWISE.
-
-# mono
-# The code we use is LGPL, but contributions must be made under the MIT/X11
-# license, so Novell can serve its paying customers. Exception is mono/man.
-# LICENSE="LGPL-2.1"
-
- # mono/man
- # LICENSE="MIT"
-
-# mcs/mcs
-# mcs/gmcs
-# LICENSE="GPL-2 MIT"
-
-# tests
-# LICENSE="MIT"
-
-# mcs/class
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/class/ByteFX.Data
- # mcs/class/Npgsql
- # LICENSE="LGPL-2.1"
-
- # mcs/class/FirebirdSql.Data.Firebird
- # LICENSE="IDPL"
-
- # mcs/class/ICSharpCode.SharpZipLib
- # LICENSE="GPL-2-with-linking-exception"
-
- # mcs/class/MicrosoftAjaxLibrary
- # LICENSE="Ms-Pl"
-
- # mcs/class/Microsoft.JScript/Microsoft.JScript/TokenStream.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Token.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Parser.cs
- # mcs/class/Microsoft.JScript/Microsoft.JScript/Decompiler.cs
- # LICENSE="|| ( NPL-1.1 GPL-2 )"
-
-# mcs/jay
-# LICENSE="BSD-4"
-
-# mcs/tools
-# Except the listed exceptions:
-# LICENSE="MIT"
-
- # mcs/tools/mdoc/Mono.Documentation/monodocs2html.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/sqlsharp/SqlSharpCli.cs
- # LICENSE="GPL-2"
-
- # mcs/tools/csharp/repl.cs
- # LICENSE="|| ( MIT GPL-2 )"
-
- # mcs/tools/mono-win32-setup.nsi
- # LICENSE="GPL-2"
-
-# samples
-# LICENSE="MIT"