summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2007-09-29 05:49:54 +0000
committerKeri Harris <keri@gentoo.org>2007-09-29 05:49:54 +0000
commitcc7519904184836dd009c78878c014a314d39038 (patch)
tree6772bf9998488e2cf8bf8f47060288eabd98f7ca /dev-lang/mozart/files
parentStable for HPPA (bug #194113). (diff)
downloadgentoo-2-cc7519904184836dd009c78878c014a314d39038.tar.gz
gentoo-2-cc7519904184836dd009c78878c014a314d39038.tar.bz2
gentoo-2-cc7519904184836dd009c78878c014a314d39038.zip
Handle fpe in ri contrib package. Closes #193683
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lang/mozart/files')
-rw-r--r--dev-lang/mozart/files/mozart-1.3.2-ri-fpe.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/mozart/files/mozart-1.3.2-ri-fpe.patch b/dev-lang/mozart/files/mozart-1.3.2-ri-fpe.patch
new file mode 100644
index 000000000000..0080caf8dd81
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.3.2-ri-fpe.patch
@@ -0,0 +1,34 @@
+diff -ur mozart-1.3.2.20060615.orig/contrib/ri/Makefile.in mozart-1.3.2.20060615/contrib/ri/Makefile.in
+--- mozart-1.3.2.20060615.orig/contrib/ri/Makefile.in 2002-07-07 01:05:36.000000000 +1200
++++ mozart-1.3.2.20060615/contrib/ri/Makefile.in 2007-09-29 17:41:45.000000000 +1200
+@@ -60,8 +60,8 @@
+ modRI.spec
+
+ ifeq ($(PLATFORM), linux-i486)
+-CSRCS = fpgetset.c sigfpe.c
+-CFLAGS += -DLINUX_IEEE
++CSRCS =
++CFLAGS +=
+ endif
+
+ OZSRCS = RI.oz
+diff -ur mozart-1.3.2.20060615.orig/contrib/ri/sigfpe.h mozart-1.3.2.20060615/contrib/ri/sigfpe.h
+--- mozart-1.3.2.20060615.orig/contrib/ri/sigfpe.h 2006-03-21 20:36:08.000000000 +1200
++++ mozart-1.3.2.20060615/contrib/ri/sigfpe.h 2007-09-29 17:33:04.000000000 +1200
+@@ -6,7 +6,6 @@
+ #include <fpu_control.h>
+ #include <signal.h>
+ #include <unistd.h>
+-#include <linux/user.h> /* for user_i387_struct */
+
+ #ifdef __cplusplus
+ extern "C" {
+@@ -19,7 +18,7 @@
+ };
+ typedef struct siginfo siginfo_t;
+ */
+-typedef struct user_i387_struct ucontext_mozart_t;
++typedef void ucontext_mozart_t;
+ typedef int sigfpe_code_type;
+ typedef void (*sigfpe_handler_type)(int, siginfo_t * , ucontext_mozart_t *);
+