summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-29 00:22:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-29 00:22:59 +0000
commitbbe87c3e13d9fc649ab95f3c207fac57d588d612 (patch)
tree77f12e50c724d8f93a32b8963772b9029d962240 /dev-lang/nasm
parentVersion bump & revision bump (for .52 release), both include the fix for bug ... (diff)
downloadgentoo-2-bbe87c3e13d9fc649ab95f3c207fac57d588d612.tar.gz
gentoo-2-bbe87c3e13d9fc649ab95f3c207fac57d588d612.tar.bz2
gentoo-2-bbe87c3e13d9fc649ab95f3c207fac57d588d612.zip
version bump
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/ChangeLog7
-rw-r--r--dev-lang/nasm/nasm-2.09.04.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-lang/nasm/ChangeLog b/dev-lang/nasm/ChangeLog
index 574055f0a982..2212783b0a64 100644
--- a/dev-lang/nasm/ChangeLog
+++ b/dev-lang/nasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nasm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.73 2010/10/28 20:07:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.74 2010/11/29 00:22:59 mr_bones_ Exp $
+
+*nasm-2.09.04 (29 Nov 2010)
+
+ 29 Nov 2010; Michael Sterrett <mr_bones_@gentoo.org> +nasm-2.09.04.ebuild:
+ version bump
28 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org> -nasm-2.09.02.ebuild:
clean older, buggy version
diff --git a/dev-lang/nasm/nasm-2.09.04.ebuild b/dev-lang/nasm/nasm-2.09.04.ebuild
new file mode 100644
index 000000000000..7c97e0e02456
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.09.04.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.09.04.ebuild,v 1.1 2010/11/29 00:22:59 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="http://nasm.sourceforge.net/"
+SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
+RDEPEND=""
+
+S=${WORKDIR}/${P/_}
+
+src_configure() {
+ strip-flags
+ econf
+}
+
+src_compile() {
+ emake nasmlib.o || die
+ emake all || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install install_rdf || die
+ dodoc AUTHORS CHANGES ChangeLog README TODO
+ if use doc ; then
+ doinfo doc/info/*
+ dohtml doc/html/*
+ dodoc doc/nasmdoc.*
+ fi
+}