summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-09-25 04:50:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-09-25 04:50:16 +0000
commitca070443dfe7184f02e5566383c189c5ed06806b (patch)
tree5bbe6413bef65aa21c77066ef92c2aee406f02c3 /dev-lang/nasm
parentAdd live git ebuild #435838 by Alphat-PC. (diff)
downloadgentoo-2-ca070443dfe7184f02e5566383c189c5ed06806b.tar.gz
gentoo-2-ca070443dfe7184f02e5566383c189c5ed06806b.tar.bz2
gentoo-2-ca070443dfe7184f02e5566383c189c5ed06806b.zip
version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/ChangeLog7
-rw-r--r--dev-lang/nasm/nasm-2.10.05.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-lang/nasm/ChangeLog b/dev-lang/nasm/ChangeLog
index 4eb1eb6c5757..9e7368f88c92 100644
--- a/dev-lang/nasm/ChangeLog
+++ b/dev-lang/nasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nasm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.98 2012/09/06 15:24:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.99 2012/09/25 04:50:16 mr_bones_ Exp $
+
+*nasm-2.10.05 (25 Sep 2012)
+
+ 25 Sep 2012; Michael Sterrett <mr_bones_@gentoo.org> +nasm-2.10.05.ebuild:
+ version bump
*nasm-2.10.04 (06 Sep 2012)
diff --git a/dev-lang/nasm/nasm-2.10.05.ebuild b/dev-lang/nasm/nasm-2.10.05.ebuild
new file mode 100644
index 000000000000..e4b9278f3788
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.10.05.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.10.05.ebuild,v 1.1 2012/09/25 04:50:16 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="http://nasm.sourceforge.net/"
+SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
+RDEPEND=""
+
+S=${WORKDIR}/${P/_}
+
+src_configure() {
+ strip-flags
+ econf
+}
+
+src_compile() {
+ emake nasmlib.o || die
+ emake all || die
+ if use doc ; then
+ emake doc || die
+ fi
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install install_rdf || die
+ dodoc AUTHORS CHANGES ChangeLog README TODO
+ if use doc ; then
+ doinfo doc/info/*
+ dohtml doc/html/*
+ dodoc doc/nasmdoc.*
+ fi
+}