summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-09-11 23:43:35 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-09-11 23:43:35 +0000
commitfcf2f73ce3c5a43588469a3be9bf0705c4cc3b88 (patch)
treedf26bcfe98415dc05c6ab31a48f65fd20e29005f /dev-lang/ocaml
parentrepoman: whitespace cleanup (diff)
downloadgentoo-2-fcf2f73ce3c5a43588469a3be9bf0705c4cc3b88.tar.gz
gentoo-2-fcf2f73ce3c5a43588469a3be9bf0705c4cc3b88.tar.bz2
gentoo-2-fcf2f73ce3c5a43588469a3be9bf0705c4cc3b88.zip
added new beta that seems to fix a rare problem as in #28025
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/Manifest4
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.07_beta21
-rw-r--r--dev-lang/ocaml/ocaml-3.07_beta2.ebuild64
4 files changed, 74 insertions, 2 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index f9af3aed460b..32c6a7ad277c 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.13 2003/09/09 17:56:01 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.14 2003/09/11 23:43:27 george Exp $
+
+*ocaml-3.07_beta2 (11 Sep 2003)
+
+ 11 Sep 2003; George Shapovalov <george@gentoo.org> ocaml-3.07_beta2.ebuild :
+ added new beta as it seems to fix some rare problem in #28025
*ocaml-3.06-r2 (09 Sep 2003)
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index 847b6ceaaeda..0b57934698b6 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,10 +1,12 @@
MD5 8143dd48dfed3a4e3213352b958c77af ocaml-3.06-r1.ebuild 1444
MD5 e85fd8053cc693729f0740b2ac855a44 ocaml-3.06.ebuild 1377
+MD5 acc9a221af76499ae2727acc200213bc ocaml-3.07_beta2.ebuild 1557
MD5 4df63628c2b4562b4333746826f47355 ocaml-3.06-r2.ebuild 1548
-MD5 6b8e2b212adb9a6c891e56cbce1326ef ChangeLog 3120
+MD5 344e4affa4c0b0e431c3da74d3993906 ChangeLog 3295
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 4df214d6cd74b3c5955d868879dd6cc7 files/ocaml-3.06-tcltk-8.4compat-patch.bz2 639
MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r2 63
+MD5 775d7436073205d935d3979a326b0729 files/digest-ocaml-3.07_beta2 68
MD5 30ac0d14e37ff0be57927d84e4e7e1c6 files/digest-ocaml-3.06 197
MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.07_beta2 b/dev-lang/ocaml/files/digest-ocaml-3.07_beta2
new file mode 100644
index 000000000000..aa4552b22bb9
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.07_beta2
@@ -0,0 +1 @@
+MD5 ecc68d67871aeae91bd807f3a3e388cb ocaml-3.07beta2.tar.gz 2533946
diff --git a/dev-lang/ocaml/ocaml-3.07_beta2.ebuild b/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
new file mode 100644
index 000000000000..5ed3b967b8a1
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.07_beta2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07_beta2.ebuild,v 1.1 2003/09/11 23:43:27 george Exp $
+
+inherit flag-o-matic eutils
+filter-flags "-fstack-protector"
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+
+MyPV="${PV/_/}"
+SRC_URI="http://caml.inria.fr/distrib/${PN}-${MyPV}/${PN}-${MyPV}.tar.gz"
+S="${WORKDIR}/${PN}-${MyPV}"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="tcltk"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ grep -rle "head -1" . | xargs sed -i "s:head -1:head -n 1:g"
+
+ # Fix for bug #23767
+ if [ "${ARCH}" = "sparc" ]
+ then
+ # We need a patch and to make sure it builds
+ # for the right host type
+ epatch ${FILESDIR}/ocaml-3.06-sparc-configure.patch
+ myconf="${myconfg} -host sparc-unknown-linux-gnu"
+ fi
+}
+
+src_compile() {
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}