summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-08 09:21:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-08 09:21:39 +0000
commitc47bd462f44edfac68eb52e8b5d8187353c5343a (patch)
treee05875925c3214b62e35ae91e1508dcfc09d8d1f /dev-lang/opendylan
parentsci-libs/scikits_learn: Move to new python eclasses (diff)
downloadgentoo-2-c47bd462f44edfac68eb52e8b5d8187353c5343a.tar.gz
gentoo-2-c47bd462f44edfac68eb52e8b5d8187353c5343a.tar.bz2
gentoo-2-c47bd462f44edfac68eb52e8b5d8187353c5343a.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/opendylan')
-rw-r--r--dev-lang/opendylan/ChangeLog10
-rw-r--r--dev-lang/opendylan/opendylan-2011.1-r1.ebuild6
-rw-r--r--dev-lang/opendylan/opendylan-2012.1.ebuild101
3 files changed, 112 insertions, 5 deletions
diff --git a/dev-lang/opendylan/ChangeLog b/dev-lang/opendylan/ChangeLog
index 15fef74544ca..dbdf3350aed3 100644
--- a/dev-lang/opendylan/ChangeLog
+++ b/dev-lang/opendylan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/opendylan
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/ChangeLog,v 1.6 2012/10/22 05:18:32 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/ChangeLog,v 1.7 2013/02/08 09:21:39 patrick Exp $
+
+*opendylan-2012.1 (08 Feb 2013)
+
+ 08 Feb 2013; Patrick Lauer <patrick@gentoo.org> +opendylan-2012.1.ebuild,
+ opendylan-2011.1-r1.ebuild:
+ Bump
22 Oct 2012; Patrick Lauer <patrick@gentoo.org> opendylan-2011.1-r1.ebuild:
Restricting mps dep
diff --git a/dev-lang/opendylan/opendylan-2011.1-r1.ebuild b/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
index 5027fd955391..2d3e3cd3acc1 100644
--- a/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
+++ b/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2011.1-r1.ebuild,v 1.5 2012/10/22 05:18:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2011.1-r1.ebuild,v 1.6 2013/02/08 09:21:39 patrick Exp $
EAPI=4
inherit autotools
@@ -27,7 +27,7 @@ DEPEND="app-arch/unzip
dev-libs/boehm-gc
dev-lang/perl
dev-perl/XML-Parser
- || ( dev-lang/opendylan-bin dev-lang/opendylan )
+ || ( =dev-lang/opendylan-bin-2011.1 dev-lang/opendylan )
x86? ( <dev-libs/mps-1.108 )"
RDEPEND="${DEPEND}"
diff --git a/dev-lang/opendylan/opendylan-2012.1.ebuild b/dev-lang/opendylan/opendylan-2012.1.ebuild
new file mode 100644
index 000000000000..38185a5dfdf3
--- /dev/null
+++ b/dev-lang/opendylan/opendylan-2012.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2012.1.ebuild,v 1.1 2013/02/08 09:21:39 patrick Exp $
+EAPI=4
+
+inherit autotools
+
+RESTRICT="test"
+
+DESCRIPTION="OpenDylan language runtime environment"
+
+HOMEPAGE="http://opendylan.org"
+# stupid ... submodules don't get tarballed in? Thanks github.
+SRC_URI="http://dev.gentooexperimental.org/~dreeevil/opendylan-2012.1.tar.bz2"
+
+LICENSE="Opendylan"
+SLOT="0"
+
+# not tested on x86
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+# the boehm-gc check is "wrong" and reported upstream
+# but for now static-libs useflag is needed
+DEPEND="app-arch/unzip
+ dev-libs/boehm-gc[static-libs]
+ dev-lang/perl
+ dev-perl/XML-Parser
+ || ( dev-lang/opendylan-bin dev-lang/opendylan )
+ x86? ( <dev-libs/mps-1.108 )"
+RDEPEND="${DEPEND}"
+
+# on x86 there's a dependency on mps, but the build system is a bit ... hmm ...
+# let's give it more of a chance to survive then
+NAUGHTY_FILES=(
+ sources/lib/run-time/collector.c.malloc
+ sources/lib/run-time/collector.c
+ sources/lib/run-time/pentium-win32/buffalo-collector.c
+ sources/lib/run-time/pentium-win32/heap-stats.c
+ sources/lib/run-time/heap-utils.h
+ )
+
+NAUGHTY_HEADERS=(
+ mps.h
+ mpscmv.h
+ mpscamc.h
+ mpsavm.h
+ )
+
+src_prepare() {
+ mkdir -p build-aux
+ elibtoolize && eaclocal || die "Fail"
+ automake --foreign --add-missing # this one dies wrongfully
+ eautoconf || die "Fail"
+ # mps headers, included wrong
+ if use x86; then
+ for i in ${NAUGHTY_FILES[@]}; do
+ for header in ${NAUGHTY_HEADERS[@]}; do
+ sed -i -e "s:\"${header}\":<${header}>:" $i
+ done
+ done
+ fi
+}
+
+src_configure() {
+ if has_version =dev-lang/opendylan-bin-2012.1; then
+ PATH=/opt/opendylan-2012.1/bin/:$PATH
+ elif has_version =dev-lang/opendylan-bin-2011.1; then
+ PATH=/opt/opendylan-2011.1/bin/:$PATH
+ else
+ PATH=/opt/opendylan/bin:$PATH
+ fi
+ if use amd64; then
+ econf --prefix=/opt/opendylan || die
+ else
+ econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
+ fi
+ if use x86; then
+ # Includedir, pointing at something wrong
+ sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
+ sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mmdw.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
+ sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mpsplan.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
+ sed -i -e 's~$(MPS_LIB)/mpsplan.a~/usr/lib/mpsplan.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
+ sed -i -e 's~$(MPS_LIB)/mmdw.a~/usr/lib/mmdw.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
+ fi
+}
+
+src_compile() {
+ ulimit -s 32000 # this is naughty build system
+ emake DESTDIR=${D} -j1 3-stage-bootstrap || die
+}
+
+src_install() {
+ ulimit -s 32000 # this is naughty build system
+ # because of Makefile weirdness it rebuilds quite a bit here
+ # upstream has been notified
+ emake -j1 DESTDIR=${D} install
+ mkdir -p "${D}/etc/env.d/opendylan/"
+ echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
+}