summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2010-02-28 20:42:07 +0000
committerLuca Barbato <lu_zero@gentoo.org>2010-02-28 20:42:07 +0000
commitef3c89d168055cdde8471c55c6e77082e998dce8 (patch)
treeb7f0ea39b5276ac47f75c572759b0eb1b94a1558 /dev-lang/parrot
parentVersion bump to add prefix support (diff)
downloadgentoo-2-ef3c89d168055cdde8471c55c6e77082e998dce8.tar.gz
gentoo-2-ef3c89d168055cdde8471c55c6e77082e998dce8.tar.bz2
gentoo-2-ef3c89d168055cdde8471c55c6e77082e998dce8.zip
New version
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog7
-rw-r--r--dev-lang/parrot/parrot-2.1.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index e0ec1e9bdbdb..46c4281f66fa 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.28 2010/01/08 20:33:23 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.29 2010/02/28 20:42:07 lu_zero Exp $
+
+*parrot-2.1.1 (28 Feb 2010)
+
+ 28 Feb 2010; Luca Barbato <lu_zero@gentoo.org> +parrot-2.1.1.ebuild:
+ New version
*parrot-1.9.0 (08 Jan 2010)
diff --git a/dev-lang/parrot/parrot-2.1.1.ebuild b/dev-lang/parrot/parrot-2.1.1.ebuild
new file mode 100644
index 000000000000..f452ea7acd57
--- /dev/null
+++ b/dev-lang/parrot/parrot-2.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.1.1.ebuild,v 1.1 2010/02/28 20:42:07 lu_zero Exp $
+
+EAPI=2
+
+inherit eutils multilib
+
+DESCRIPTION="Parrot is a virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
+HOMEPAGE="http://www.parrot.org/"
+SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl nls doc examples gdbm gmp ssl unicode pcre"
+
+RDEPEND="opengl? ( virtual/glut )
+ nls? ( sys-devel/gettext )
+ unicode? ( >=dev-libs/icu-2.6 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
+ gmp? ( >=dev-libs/gmp-4.1.4 )
+ ssl? ( dev-libs/openssl )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="dev-lang/perl[doc?]
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:/lib/:/$(get_libdir)/:" -i "${S}/tools/dev/install_files.pl"
+}
+
+src_configure() {
+ myconf="--disable-rpath"
+ use unicode || myconf="$myconf --without-icu"
+ use ssl || myconf="$myconf --without-crypto"
+ use gdbm || myconf="$myconf --without-gdbm"
+ use nls || myconf="$myconf --without-gettext"
+ use gmp || myconf="$myconf --without-gmp"
+ use opengl || myconf="$myconf --without-opengl"
+ use pcre || myconf="$myconf --without-pcre"
+
+ perl Configure.pl --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --sysconfdir=/etc \
+ --sharedstatedir=/var/lib/parrot \
+ $myconf
+}
+
+src_compile() {
+ export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
+ emake || die
+ use doc && make html
+}
+
+src_install() {
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="/usr/share/doc/${P}" || die
+}