summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-06-15 06:18:26 +0000
committerNed Ludd <solar@gentoo.org>2004-06-15 06:18:26 +0000
commit1454cdc1344caab1739de95453c62ff7211b0272 (patch)
treed86174a6e2e2f60d7518712ac59259e9960512bd /dev-lang/perl
parentVersion bump, see bug #53859 (Manifest recommit) (diff)
downloadgentoo-2-1454cdc1344caab1739de95453c62ff7211b0272.tar.gz
gentoo-2-1454cdc1344caab1739de95453c62ff7211b0272.tar.bz2
gentoo-2-1454cdc1344caab1739de95453c62ff7211b0272.zip
basic initial uclibc support needed for bootstrapping
Diffstat (limited to 'dev-lang/perl')
-rw-r--r--dev-lang/perl/ChangeLog6
-rw-r--r--dev-lang/perl/files/perl-5.8.2-uclibc.patch15
-rw-r--r--dev-lang/perl/perl-5.8.2-r1.ebuild13
3 files changed, 28 insertions, 6 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index c14b8ce468d1..bebce6c7ec95 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.64 2004/06/09 20:20:34 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.65 2004/06/15 06:18:26 solar Exp $
+
+ 15 Jun 2004; <solar@gentoo.org> perl-5.8.2-r1.ebuild,
+ files/perl-5.8.2-uclibc.patch:
+ basic initial uclibc support needed for bootstrapping
09 Jun 2004; Robert Coie <rac@gentoo.org> +files/perl-5.8.4-noksh.patch,
perl-5.8.4.ebuild:
diff --git a/dev-lang/perl/files/perl-5.8.2-uclibc.patch b/dev-lang/perl/files/perl-5.8.2-uclibc.patch
new file mode 100644
index 000000000000..1e086d73879a
--- /dev/null
+++ b/dev-lang/perl/files/perl-5.8.2-uclibc.patch
@@ -0,0 +1,15 @@
+--- perl-5.8.2/perlio.c-dist 2003-12-03 14:30:24.000000000 -0700
++++ perl-5.8.2/perlio.c 2003-12-03 14:32:10.000000000 -0700
+@@ -2824,7 +2824,11 @@
+ /* XXX this could use PerlIO_canset_fileno() and
+ * PerlIO_set_fileno() support from Configure
+ */
+-# if defined(__GLIBC__)
++# if defined(__UCLIBC__)
++ /* uClibc must come before glibc because it defines __GLIBC__ as well. */
++ f->__filedes = -1;
++ return 1;
++# elif defined(__GLIBC__)
+ /* There may be a better way for GLIBC:
+ - libio.h defines a flag to not close() on cleanup
+ */
diff --git a/dev-lang/perl/perl-5.8.2-r1.ebuild b/dev-lang/perl/perl-5.8.2-r1.ebuild
index 6fb5037edbce..8ca815788857 100644
--- a/dev-lang/perl/perl-5.8.2-r1.ebuild
+++ b/dev-lang/perl/perl-5.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.13 2004/06/03 15:39:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.14 2004/06/15 06:18:26 solar Exp $
inherit eutils flag-o-matic gcc
@@ -20,9 +20,9 @@ SLOT="0"
LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
KEYWORDS="x86 amd64 sparc ppc alpha mips hppa ia64 ppc64"
-IUSE="berkdb doc gdbm threads"
+IUSE="berkdb doc gdbm threads uclibc"
-DEPEND="sys-apps/groff
+DEPEND="!uclibc? ( sys-apps/groff )
berkdb? ( sys-libs/db )
gdbm? ( >=sys-libs/gdbm-1.8.0 )
>=sys-apps/portage-2.0.48-r4
@@ -94,11 +94,14 @@ src_unpack() {
# counterproductive on a Gentoo system which has both a shared
# and static libperl, so effectively revert this here.
cd ${S}; epatch ${FILESDIR}/${P}-picdl.patch
+
+ # uclibc support
+ epatch ${FILESDIR}/perl-5.8.2-uclibc.patch
}
src_compile() {
- # Perl has problems compiling with -Os in your flags
- replace-flags "-Os" "-O2"
+ # Perl has problems compiling with -Os in your flags with glibc
+ use uclibc || replace-flags "-Os" "-O2"
# This flag makes compiling crash in interesting ways
filter-flags -malign-double