summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-09-16 07:02:57 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-09-16 07:02:57 +0000
commitc7cbe7c86441c920970e710775414adcd3f9e5b4 (patch)
tree51186a41805cb36d2579ab7e0700890e00e920f9 /dev-lang/php
parentDon't build examples (fixes bug #383115). (diff)
downloadgentoo-2-c7cbe7c86441c920970e710775414adcd3f9e5b4.tar.gz
gentoo-2-c7cbe7c86441c920970e710775414adcd3f9e5b4.tar.bz2
gentoo-2-c7cbe7c86441c920970e710775414adcd3f9e5b4.zip
Remove deps on phpconfutils and php-common-r1
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/files/eblits/src_configure-v3.eblit6
-rw-r--r--dev-lang/php/files/eblits/src_install-v3.eblit5
-rw-r--r--dev-lang/php/php-5.4.0_alpha3.ebuild4
4 files changed, 13 insertions, 9 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index fe0e3e94bf76..2ac0a2f600b8 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.511 2011/09/03 17:20:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.512 2011/09/16 07:02:56 olemarkus Exp $
+
+ 16 Sep 2011; Ole Markus With <olemarkus@gentoo.org>
+ files/eblits/src_configure-v3.eblit, files/eblits/src_install-v3.eblit,
+ php-5.4.0_alpha3.ebuild:
+ Remove deps on phpconfutils and php-common-r1
03 Sep 2011; Raúl Porcel <armin76@gentoo.org> php-5.3.8.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #372745
diff --git a/dev-lang/php/files/eblits/src_configure-v3.eblit b/dev-lang/php/files/eblits/src_configure-v3.eblit
index c99ed8888f68..a08d83955515 100644
--- a/dev-lang/php/files/eblits/src_configure-v3.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v3.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v3.eblit,v 1.4 2011/08/22 13:32:38 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v3.eblit,v 1.5 2011/09/16 07:02:57 olemarkus Exp $
eblit-php-src_configure() {
addpredict /usr/share/snmp/mibs/.index
@@ -214,7 +214,9 @@ eblit-php-src_configure() {
my_conf="${my_conf} --with-pcre-regex=/usr --with-pcre-dir=/usr"
# Catch CFLAGS problems
- php_check_cflags
+ # Fixes bug #14067.
+ # Changed order to run it in reverse for bug #32022 and #12021.
+ replace-cpu-flags "k6*" "i586"
# Support user-passed configuration parameters
my_conf="${my_conf} ${EXTRA_ECONF:-}"
diff --git a/dev-lang/php/files/eblits/src_install-v3.eblit b/dev-lang/php/files/eblits/src_install-v3.eblit
index 19e4b89a359f..316d42b4cf41 100644
--- a/dev-lang/php/files/eblits/src_install-v3.eblit
+++ b/dev-lang/php/files/eblits/src_install-v3.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_install-v3.eblit,v 1.2 2011/07/20 12:41:38 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_install-v3.eblit,v 1.3 2011/09/16 07:02:57 olemarkus Exp $
eblit-php-src_install() {
# see bug #324739 for what happens when we don't have that
@@ -26,9 +26,6 @@ eblit-php-src_install() {
local extension_dir="$("${D}/${PHP_DESTDIR}/bin/php-config" --extension-dir)"
- # Generate the USE file for PHP
- phpconfutils_generate_usefile
-
# Create the directory where we'll put version-specific php scripts
keepdir /usr/share/php${PHP_MV}
diff --git a/dev-lang/php/php-5.4.0_alpha3.ebuild b/dev-lang/php/php-5.4.0_alpha3.ebuild
index a3deba1c4eaa..fd54a561102e 100644
--- a/dev-lang/php/php-5.4.0_alpha3.ebuild
+++ b/dev-lang/php/php-5.4.0_alpha3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_alpha3.ebuild,v 1.1 2011/08/08 16:15:47 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_alpha3.ebuild,v 1.2 2011/09/16 07:02:56 olemarkus Exp $
EAPI=4
-inherit eutils autotools flag-o-matic versionator depend.apache apache-module db-use phpconfutils php-common-r1 libtool
+inherit eutils autotools flag-o-matic versionator depend.apache apache-module db-use libtool
SUHOSIN_VERSION=""
FPM_VERSION="builtin"