summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-11-16 23:02:59 +0000
committerMichał Górny <mgorny@gentoo.org>2013-11-16 23:02:59 +0000
commitc664bf1b815d560c35417fb54959e4a179529b89 (patch)
tree3a034717f54f1f2e1821bbdefe211564998e57cf /dev-lang/python-exec
parentFix sed in pkg_preinst, bug 491448. (diff)
downloadgentoo-2-c664bf1b815d560c35417fb54959e4a179529b89.tar.gz
gentoo-2-c664bf1b815d560c35417fb54959e4a179529b89.tar.bz2
gentoo-2-c664bf1b815d560c35417fb54959e4a179529b89.zip
Version bump. Fix unitialized memory access, bug #491410.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/ChangeLog7
-rw-r--r--dev-lang/python-exec/python-exec-2.0.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-lang/python-exec/ChangeLog b/dev-lang/python-exec/ChangeLog
index 50582b7dac01..d4f77a644d5f 100644
--- a/dev-lang/python-exec/ChangeLog
+++ b/dev-lang/python-exec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python-exec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/ChangeLog,v 1.3 2013/11/15 22:12:48 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/ChangeLog,v 1.4 2013/11/16 23:02:59 mgorny Exp $
+
+*python-exec-2.0.1 (16 Nov 2013)
+
+ 16 Nov 2013; Michał Górny <mgorny@gentoo.org> +python-exec-2.0.1.ebuild:
+ Version bump. Fix unitialized memory access, bug #491410.
15 Nov 2013; Robin H. Johnson <robbat2@gentoo.org> python-exec-0.3.1.ebuild,
python-exec-0.9999.ebuild, python-exec-2.0.ebuild, python-exec-2.9999.ebuild:
diff --git a/dev-lang/python-exec/python-exec-2.0.1.ebuild b/dev-lang/python-exec/python-exec-2.0.1.ebuild
new file mode 100644
index 000000000000..f5d196444bec
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.0.1.ebuild,v 1.1 2013/11/16 23:02:59 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<dev-python/python-exec-10000"
+PDEPEND=">=dev-python/python-exec-10000:$SLOT"
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}