summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-27 00:13:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-27 00:13:46 +0000
commit02f2b00596498307fcd0471a6ad9e4b81f25c52e (patch)
tree0ca178958ffa2b8e1d90c6af31b98d342edb57cb /dev-lang/python/python-2.4.2.ebuild
parentredo how we enable protoize so it works with cross-compiling/bsd/etc... #130962 (diff)
downloadgentoo-2-02f2b00596498307fcd0471a6ad9e4b81f25c52e.tar.gz
gentoo-2-02f2b00596498307fcd0471a6ad9e4b81f25c52e.tar.bz2
gentoo-2-02f2b00596498307fcd0471a6ad9e4b81f25c52e.zip
disable CFLAGS when cross-compiling
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'dev-lang/python/python-2.4.2.ebuild')
-rw-r--r--dev-lang/python/python-2.4.2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-lang/python/python-2.4.2.ebuild b/dev-lang/python/python-2.4.2.ebuild
index 2607ada852cd..929c403a06be 100644
--- a/dev-lang/python/python-2.4.2.ebuild
+++ b/dev-lang/python/python-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.2.ebuild,v 1.17 2006/02/16 21:34:33 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.2.ebuild,v 1.18 2006/04/27 00:13:46 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -156,7 +156,7 @@ src_compile() {
src_configure
if tc-is-cross-compiler ; then
- OPT="-O1" LDFLAGS="" \
+ OPT="-O1" CFLAGS="" LDFLAGS="" \
./configure --with-cxx=no || die "cross-configure failed"
emake python Parser/pgen || die "cross-make failed"
mv python hostpython