summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-25 17:09:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-25 17:09:38 +0000
commit62fc045b9f0baf7a1275c44c6da0454bf970a228 (patch)
treebc11f14716d5a2a5a892303b14b7e4375bc1baa5 /dev-lang/python/python-2.4.6.ebuild
parentRevision bump. Add a patch to fix bug #304153. Thanks Matthew Turnbull for re... (diff)
downloadgentoo-2-62fc045b9f0baf7a1275c44c6da0454bf970a228.tar.gz
gentoo-2-62fc045b9f0baf7a1275c44c6da0454bf970a228.tar.bz2
gentoo-2-62fc045b9f0baf7a1275c44c6da0454bf970a228.zip
Work around bug #321145.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python/python-2.4.6.ebuild')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 709685c6e9b2..b3e16894f21e 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.38 2010/05/23 20:13:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.39 2010/05/25 17:09:38 arfrever Exp $
EAPI="1"
@@ -18,6 +18,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
+PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline +ssl +threads tk +wide-unicode wininst +xml"
@@ -47,8 +48,7 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
- python_set_active_version ${SLOT}
- # python_pkg_setup
+ python_pkg_setup
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
@@ -284,7 +284,7 @@ pkg_postinst() {
eselect_python_update
# Python 2.4 partially doesn't respect $(get_libdir).
- python_mod_optimize -x "/(site-packages|test|tests)/" /usr/lib/python${SLOT}
+ python_mod_optimize -f -x "/(site-packages|test|tests)/" /usr/lib/python${SLOT}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn