summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-10-12 20:40:50 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-10-12 20:40:50 +0000
commit202737e02c989848754a0e419a579d6755f80b7d (patch)
treeaaa3db9dc1c34556d1b089c97b17955dd4c48c60 /dev-lang/python
parentAdd dependency on app-crypt/qca-ossl:2, fixing bug 327691 (diff)
downloadgentoo-2-202737e02c989848754a0e419a579d6755f80b7d.tar.gz
gentoo-2-202737e02c989848754a0e419a579d6755f80b7d.tar.bz2
gentoo-2-202737e02c989848754a0e419a579d6755f80b7d.zip
Fix up broken python-2.6.6.
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog11
-rw-r--r--dev-lang/python/python-2.6.6-r1.ebuild (renamed from dev-lang/python/python-2.6.6.ebuild)10
2 files changed, 16 insertions, 5 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index f2b4b106c3a6..c5ea755cd9fc 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.496 2010/10/08 17:17:43 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.497 2010/10/12 20:40:50 djc Exp $
+
+*python-2.6.6-r1 (12 Oct 2010)
+
+ 12 Oct 2010; Dirkjan Ochtman <djc@gentoo.org> -python-2.6.6.ebuild,
+ +python-2.6.6-r1.ebuild:
+ 2.6.6-r1 actually has the rwx-mmap patch and the portage blocker.
+
+ 11 Oct 2010; Dirkjan Ochtman <djc@gentoo.org> python-2.6.6.ebuild:
+ Block 2.6.6 on portage-2.1.9 (earlier portage suffers from bug 330937).
*python-2.6.6 (08 Oct 2010)
diff --git a/dev-lang/python/python-2.6.6.ebuild b/dev-lang/python/python-2.6.6-r1.ebuild
index 5cd0fb2616f6..7f35bb532a17 100644
--- a/dev-lang/python/python-2.6.6.ebuild
+++ b/dev-lang/python/python-2.6.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6.ebuild,v 1.1 2010/10/08 17:17:43 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.6-r1.ebuild,v 1.1 2010/10/12 20:40:50 djc Exp $
EAPI="2"
@@ -8,12 +8,13 @@ inherit autotools eutils flag-o-matic multilib pax-utils python toolchain-funcs
MY_P="Python-${PV}"
-PATCHSET_REVISION="0"
+PATCHSET_REVISION="1"
DESCRIPTION="Python is an interpreted, interactive, object-oriented programming language."
HOMEPAGE="http://www.python.org/"
SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
- mirror://gentoo/python-gentoo-patches-${PV}$([[ "${PATCHSET_REVISION}" != "0" ]] && echo "-r${PATCHSET_REVISION}").tar.bz2"
+ http://dev.gentoo.org/~djc/python-gentoo-patches-${PV}$([[ "${PATCHSET_REVISION}" != "0" ]] && echo "-r${PATCHSET_REVISION}").tar.bz2"
+# mirror://gentoo/python-gentoo-patches-${PV}$([[ "${PATCHSET_REVISION}" != "0" ]] && echo "-r${PATCHSET_REVISION}").tar.bz2"
LICENSE="PSF-2.2"
SLOT="2.6"
@@ -21,7 +22,8 @@ PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
-RDEPEND=">=app-admin/eselect-python-20091230
+RDEPEND="!!<sys-apps/portage-2.1.9
+ >=app-admin/eselect-python-20091230
>=sys-libs/zlib-1.1.3
virtual/libffi
virtual/libintl