summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-07-02 04:11:12 +0000
committerJon Nelson <jnelson@gentoo.org>2002-07-02 04:11:12 +0000
commit7a47a8fda7fc60e22c162b8aaa0c88996a07ae54 (patch)
treee08adb494710682cedf8f2312bc37956985f00be /dev-lang/python
parentadd python 2.1.3 (diff)
downloadgentoo-2-7a47a8fda7fc60e22c162b8aaa0c88996a07ae54.tar.gz
gentoo-2-7a47a8fda7fc60e22c162b8aaa0c88996a07ae54.tar.bz2
gentoo-2-7a47a8fda7fc60e22c162b8aaa0c88996a07ae54.zip
remove old python ebuilds
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.0-r5.ebuild150
-rw-r--r--dev-lang/python/python-2.0-r6.ebuild162
-rw-r--r--dev-lang/python/python-2.0-r7.ebuild162
-rw-r--r--dev-lang/python/python-2.1.1-r3.ebuild126
-rw-r--r--dev-lang/python/python-2.1.1-r4.ebuild130
5 files changed, 0 insertions, 730 deletions
diff --git a/dev-lang/python/python-2.0-r5.ebuild b/dev-lang/python/python-2.0-r5.ebuild
deleted file mode 100644
index d1a8b24691f6..000000000000
--- a/dev-lang/python/python-2.0-r5.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# Modified Tod M. Neidt <tneidt@fidnet.com>
-# /home/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r4.ebuild,v 1.1 2001/06/04 19:49:02 drobbins Exp
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r5.ebuild,v 1.3 2002/06/11 18:19:22 drobbins Exp $
-
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-#tcltk depends is = becasue need to automate tcltk version number below
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python-2.0"
-
-SLOT="2"
-
-src_unpack() {
- local mylibs
- unpack BeOpen-Python-2.0.tar.bz2
- cd ${S}/Modules
- if [ "`use readline`" ]
- then
- sed -e 's/#readline/readline/' -e 's/-lreadline -ltermcap/-lreadline/' \
- -e 's/#_curses _cursesmodule.c -lcurses -ltermcap/_curses _cursesmodule.c -lncurses/' \
- -e 's/#crypt/crypt/' -e 's/# -lcrypt/-lcrypt/' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="-lreadline -lncurses -lcrypt"
- fi
-
-#Added check for tcltk USE variable, if set build _tkinter
-#Need to automate tk and tcl version determination
- if [ "`use tcltk`" ]
- then
- sed -e 's:# _tkinter:_tkinter:' \
- -e 's:#[[:blank:]]*-I/usr/local/include:-I/usr/include:' \
- -e 's:#[[:blank:]]*-I/usr/X11R6/include:-I/usr/X11R6/include:' \
- -e 's:#[[:blank:]]*-L/usr/local/lib:-L/usr/lib:' \
- -e 's:#[[:blank:]]*-ltk8.0 -ltcl8.0:-ltk8.4 -ltcl8.4:' \
- -e 's:#[[:blank:]]*-L/usr/X11R6/lib:-L/usr/X11R6/lib:' \
- -e 's:#[[:blank:]]-lX11:-lX11:' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="$mylibs -ltk8.4 -ltcl8.4 -L/usr/X11R6/lib -lX11"
- fi
-
- if [ "`use berkdb`" ]
- then
- sed -e 's:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="$mylibs -ldb-3.2"
- fi
-
-#Removed the commenting out of TKPATH
- sed -e 's/#_locale/_locale/' \
- -e 's/#syslog/syslog/' \
- -e 's:#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz:zlib zlibmodule.c -lz:' \
- -e 's:^#termios:termios:' -e 's:^#resource:resource:' \
- Setup.in > Setup
- echo "fchksum fchksum.c md5_2.c" >> Setup
- mylibs="-lpython2.0 $mylibs -lz -lutil"
- cd ${S}/Modules
-
- if [ "`use berkdb`" ]
- then
- #patch the dbmmodule to use db3's dbm compatibility code. That way, we're depending on db3 rather than
- #old db1. We'll link with db3, of course.
- cp dbmmodule.c dbmmodule.c.orig
- sed -e '10,25d' -e '26i\' -e '#define DB_DBM_HSEARCH 1\' -e 'static char *which_dbm = "BSD db";\' -e '#include <db3/db.h>' dbmmodule.c.orig > dbmmodule.c
- fi
-
- cp ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- cd python-fchksum-1.1
- mv md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
- #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
- cd ${S}/Python
- cp pythonrun.c pythonrun.c.orig
- sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
-
- cat <<END > ${S}/python-config
-#!/bin/sh
-echo -lm $mylibs
-END
-
-}
-
-
-src_compile() {
- cd ${S}
- try ./configure --prefix=/usr --without-libdb
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-}
-
-src_install() {
- dodir /usr
- try make install prefix=${D}/usr
- rm ${D}/usr/bin/python
- dosym python2.0 /usr/bin/python
- exeinto /usr/bin
- doexe python-config
- dodoc README
-
-#Change OPT setting in /usr/lib/python2.0/config/Makefile
-#to CFLAG from /etc/make.conf so optimaization is set for
-#subsequent module installs using distutil.
-#There is probably a better way :)
- cd ${D}/usr/lib/python2.0/config
- sed -e "s/OPT=[[:blank:]]*-g -O2 -Wall -Wstrict-prototypes/OPT= ${CFLAGS}/" \ Makefile > Makefile.new
- mv Makefile.new Makefile
-
-#If USE tcltk lets install idle
-#Need to script the python version in the path
- if [ "`use tcltk`" ]
- then
- mkdir ${D}/usr/lib/python2.0/tools
- cd ${S}
- mv Tools/idle ${D}/usr/lib/python2.0/tools/
-#don't quit understand dosym; put idle in PATH
- ln -s /usr/lib/python2.0/tools/idle/idle.py ${D}/usr/bin/idle.py
- fi
-}
-
diff --git a/dev-lang/python/python-2.0-r6.ebuild b/dev-lang/python/python-2.0-r6.ebuild
deleted file mode 100644
index 23edc25ed346..000000000000
--- a/dev-lang/python/python-2.0-r6.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# Modified Tod M. Neidt <tneidt@fidnet.com>
-# /home/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r4.ebuild,v 1.1 2001/06/04 19:49:02 drobbins Exp
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r6.ebuild,v 1.5 2002/06/11 18:19:22 drobbins Exp $
-
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-#tcltk depends is = becasue need to automate tcltk version number below
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python-2.0"
-
-SLOT="2"
-
-src_unpack() {
- local mylibs
- unpack BeOpen-Python-2.0.tar.bz2
- cd ${S}/Modules
- if [ "`use readline`" ]
- then
- sed -e 's/#readline/readline/' -e 's/-lreadline -ltermcap/-lreadline/' \
- -e 's/#_curses _cursesmodule.c -lcurses -ltermcap/_curses _cursesmodule.c -lncurses/' \
- -e 's/#crypt/crypt/' -e 's/# -lcrypt/-lcrypt/' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="-lreadline -lncurses -lcrypt"
- fi
-
-#Added check for tcltk USE variable, if set build _tkinter
-#Need to automate tk and tcl version determination
- if [ "`use tcltk`" ]
- then
-
-#Determine tcl version by greping tcl.h
-#Probably don't need same for tk, but play it safe
- local tcl_version
- local tk_version
-
- tcl_version=$(grep TCL_VERSION /usr/include/tcl.h | \
- sed -e 's/.*\([0-9]\.[0-9]\).*/\1/')
-
- tk_version=$(grep TK_VERSION /usr/include/tk.h | \
- sed -e 's/.*\([0-9]\.[0-9]\).*/\1/')
-
- sed -e 's:# _tkinter:_tkinter:' \
- -e 's:#[[:blank:]]*-I/usr/local/include:-I/usr/include:' \
- -e 's:#[[:blank:]]*-I/usr/X11R6/include:-I/usr/X11R6/include:' \
- -e 's:#[[:blank:]]*-L/usr/local/lib:-L/usr/lib:' \
- -e 's:#[[:blank:]]*-ltk8.0 -ltcl8.0:-ltk'${tk_version}' -ltcl'${tcl_version}':' \
- -e 's:#[[:blank:]]*-L/usr/X11R6/lib:-L/usr/X11R6/lib:' \
- -e 's:#[[:blank:]]-lX11:-lX11:' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="$mylibs -ltk${tk_version} -ltcl${tcl_version} -L/usr/X11R6/lib -lX11"
- fi
-
- if [ "`use berkdb`" ]
- then
- sed -e 's:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="$mylibs -ldb-3.2"
- fi
-
-#Removed the commenting out of TKPATH
- sed -e 's/#_locale/_locale/' \
- -e 's/#syslog/syslog/' \
- -e 's:#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz:zlib zlibmodule.c -lz:' \
- -e 's:^#termios:termios:' -e 's:^#resource:resource:' \
- Setup.in > Setup
- echo "fchksum fchksum.c md5_2.c" >> Setup
- mylibs="-lpython2.0 $mylibs -lz -lutil"
- cd ${S}/Modules
-
- if [ "`use berkdb`" ]
- then
- #patch the dbmmodule to use db3's dbm compatibility code. That way, we're depending on db3 rather than
- #old db1. We'll link with db3, of course.
- cp dbmmodule.c dbmmodule.c.orig
- sed -e '10,25d' -e '26i\' -e '#define DB_DBM_HSEARCH 1\' -e 'static char *which_dbm = "BSD db";\' -e '#include <db3/db.h>' dbmmodule.c.orig > dbmmodule.c
- fi
-
- cp ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- cd python-fchksum-1.1
- mv md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
- #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
- cd ${S}/Python
- cp pythonrun.c pythonrun.c.orig
- sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
-
- cat <<END > ${S}/python-config
-#!/bin/sh
-echo -lm $mylibs
-END
-
-}
-
-
-src_compile() {
- cd ${S}
- try ./configure --prefix=/usr --without-libdb
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-}
-
-src_install() {
- dodir /usr
- try make install prefix=${D}/usr
- rm ${D}/usr/bin/python
- dosym python2.0 /usr/bin/python
- exeinto /usr/bin
- doexe python-config
- dodoc README
-
-#Change OPT setting in /usr/lib/python2.0/config/Makefile
-#to CFLAG from /etc/make.conf so optimaization is set for
-#subsequent module installs using distutil.
-#There is probably a better way :)
- cd ${D}/usr/lib/python2.0/config
- sed -e "s/OPT=[[:blank:]]*-g -O2 -Wall -Wstrict-prototypes/OPT= ${CFLAGS}/" \ Makefile > Makefile.new
- mv Makefile.new Makefile
-
-#If USE tcltk lets install idle
-#Need to script the python version in the path
- if [ "`use tcltk`" ]
- then
- mkdir ${D}/usr/lib/python2.0/tools
- cd ${S}
- mv Tools/idle ${D}/usr/lib/python2.0/tools/
-#don't quit understand dosym; put idle in PATH
- ln -s /usr/lib/python2.0/tools/idle/idle.py ${D}/usr/bin/idle.py
- fi
-}
-
diff --git a/dev-lang/python/python-2.0-r7.ebuild b/dev-lang/python/python-2.0-r7.ebuild
deleted file mode 100644
index 4332fb4bac5e..000000000000
--- a/dev-lang/python/python-2.0-r7.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# Modified Tod M. Neidt <tneidt@fidnet.com>
-# /home/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r4.ebuild,v 1.1 2001/06/04 19:49:02 drobbins Exp
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r7.ebuild,v 1.2 2002/04/07 13:32:59 gbevin Exp $
-
-
-S=${WORKDIR}/Python-2.0
-S2=${WORKDIR}/python-fchksum-1.1
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
- http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-#tcltk depends is = becasue need to automate tcltk version number below
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python-2.0"
-
-SLOT="2"
-
-src_unpack() {
- local mylibs
- unpack BeOpen-Python-2.0.tar.bz2
- cd ${S}/Modules
- if [ "`use readline`" ]
- then
- sed -e 's/#readline/readline/' -e 's/-lreadline -ltermcap/-lreadline/' \
- -e 's/#_curses _cursesmodule.c -lcurses -ltermcap/_curses _cursesmodule.c -lncurses/' \
- -e 's/#crypt/crypt/' -e 's/# -lcrypt/-lcrypt/' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="-lreadline -lncurses -lcrypt"
- fi
-
-#Added check for tcltk USE variable, if set build _tkinter
-#Need to automate tk and tcl version determination
- if [ "`use tcltk`" ]
- then
-
-#Determine tcl version by greping tcl.h
-#Probably don't need same for tk, but play it safe
- local tcl_version
- local tk_version
-
- tcl_version=$(grep TCL_VERSION /usr/include/tcl.h | \
- sed -e 's/.*\([0-9]\.[0-9]\).*/\1/')
-
- tk_version=$(grep TK_VERSION /usr/include/tk.h | \
- sed -e 's/.*\([0-9]\.[0-9]\).*/\1/')
-
- sed -e 's:# _tkinter:_tkinter:' \
- -e 's:#[[:blank:]]*-I/usr/local/include:-I/usr/include:' \
- -e 's:#[[:blank:]]*-I/usr/X11R6/include:-I/usr/X11R6/include:' \
- -e 's:#[[:blank:]]*-L/usr/local/lib:-L/usr/lib:' \
- -e 's:#[[:blank:]]*-ltk8.0 -ltcl8.0:-ltk'${tk_version}' -ltcl'${tcl_version}':' \
- -e 's:#[[:blank:]]*-L/usr/X11R6/lib:-L/usr/X11R6/lib:' \
- -e 's:#[[:blank:]]-lX11:-lX11:' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="$mylibs -ltk${tk_version} -ltcl${tcl_version} -L/usr/X11R6/lib -lX11"
- fi
-
- if [ "`use berkdb`" ]
- then
- sed -e 's:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:' \
- Setup.in > Setup.new
- mv Setup.new Setup.in
- mylibs="$mylibs -ldb-3.2"
- fi
-
-#Removed the commenting out of TKPATH
- sed -e 's/#_locale/_locale/' \
- -e 's/#syslog/syslog/' \
- -e 's:#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz:zlib zlibmodule.c -lz:' \
- -e 's:^#termios:termios:' -e 's:^#resource:resource:' \
- Setup.in > Setup
- echo "fchksum fchksum.c md5_2.c" >> Setup
- mylibs="-lpython2.0 $mylibs -lz -lutil"
- cd ${S}/Modules
-
- if [ "`use berkdb`" ]
- then
- #patch the dbmmodule to use db3's dbm compatibility code. That way, we're depending on db3 rather than
- #old db1. We'll link with db3, of course.
- cp dbmmodule.c dbmmodule.c.orig
- sed -e '10,25d' -e '26i\' -e '#define DB_DBM_HSEARCH 1\' -e 'static char *which_dbm = "BSD db";\' -e '#include <db3/db.h>' dbmmodule.c.orig > dbmmodule.c
- fi
-
- cp ${FILESDIR}/pfconfig.h .
- unpack python-fchksum-1.1.tar.gz
-
- cd python-fchksum-1.1
- mv md5.h ../md5_2.h
- sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
-
- #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
- cd ${S}/Python
- cp pythonrun.c pythonrun.c.orig
- sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
-
- cat <<END > ${S}/python-config
-#!/bin/sh
-echo -lm $mylibs
-END
-
-}
-
-
-src_compile() {
- cd ${S}
- try ./configure --prefix=/usr --without-libdb
- #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
- #included with python is for db 1.85 only.
- cp Makefile Makefile.orig
- sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/Modules
- cp Makefile.pre Makefile.orig
- sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
- Makefile.orig > Makefile.pre
-
- # Parallel make does not work
- cd ${S}
- try make
-}
-
-src_install() {
- dodir /usr
- try make install prefix=${D}/usr
- rm ${D}/usr/bin/python
- dosym python2.0 /usr/bin/python
- exeinto /usr/bin
- doexe python-config
- dodoc README
-
-#Change OPT setting in /usr/lib/python2.0/config/Makefile
-#to CFLAG from /etc/make.conf so optimaization is set for
-#subsequent module installs using distutil.
-#There is probably a better way :)
- cd ${D}/usr/lib/python2.0/config
- sed -e "s/OPT=[[:blank:]]*-g -O2 -Wall -Wstrict-prototypes/OPT= ${CFLAGS}/" \ Makefile > Makefile.new
- mv Makefile.new Makefile
-
-#If USE tcltk lets install idle
-#Need to script the python version in the path
- if [ "`use tcltk`" ]
- then
- mkdir ${D}/usr/lib/python2.0/tools
- cd ${S}
- mv Tools/idle ${D}/usr/lib/python2.0/tools/
-#don't quit understand dosym; put idle in PATH
- ln -s /usr/lib/python2.0/tools/idle/idle.py ${D}/usr/bin/idle.py
- fi
-}
-
diff --git a/dev-lang/python/python-2.1.1-r3.ebuild b/dev-lang/python/python-2.1.1-r3.ebuild
deleted file mode 100644
index 561c7b387faa..000000000000
--- a/dev-lang/python/python-2.1.1-r3.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.1-r3.ebuild,v 1.3 2002/06/11 18:19:22 drobbins Exp $
-
-S=${WORKDIR}/Python-${PV}
-FCHKSUM="python-fchksum-1.6"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUM}.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python-2.1"
-
-SLOT="2.1"
-
-src_unpack() {
- # unpack python
- unpack Python-${PV}.tgz
- # unpack fchksum and move pieces into Modules subdir
- cd ${S}/Modules
- unpack ${FCHKSUM}.tar.gz
- cd ${FCHKSUM}
- cp md5.h ../md5_2.h
- cp cksum.[ch] sum.[ch] fchksum.h ..
- sed 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
- # add fchksum configuration to Setup
- cd ${S}
- echo "fchksum fchksum.c md5_2.c cksum.c sum.c" >> Modules/Setup.dist
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-}
-
-src_compile() {
- # python's config seems to ignore CFLAGS
- export OPT=$CFLAGS
-
- # configure fchksum
- cd ${S}/Modules/${FCHKSUM}
- ./configure
- cp pfconfig.h ..
-
- # adjust Setup to include the various modules we need
- cd ${S}
- scmd=""
- # adjust for USE readline
- if use readline; then
- scmd="$scmd s:#\(readline .*\) -ltermcap:\1:;"
- scmd="$scmd s:#\(_curses .*\) -lcurses -ltermcap:\1 -lncurses:;"
- fi
- # adjust for USE tcltk
- if use tcltk; then
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- # adjust Setup to match
- scmd="$scmd s:# \(_tkinter \):\1:;"
- scmd="$scmd s:#\(\t-ltk[0-9.]* -ltcl[0-9.]*\):\t-ltk$tkv -ltcl$tclv:;"
- scmd="$scmd s:#\(\t-L/usr/X11R6/lib\):\1:;"
- scmd="$scmd s:#\(\t-lX11.*\):\1:;"
- fi
- # adjust for USE berkdb
- if use berkdb; then
- # patch the dbmmodule to use db3's dbm compatibility code. That way,
- # we're depending on db3 rather than old db1.
- t=Modules/dbmmodule.c
- cp $t $t.orig || die
- sed \
- -e '10,25d' \
- -e '26i\' \
- -e '#define DB_DBM_HSEARCH 1\' \
- -e 'static char *which_dbm = "BSD db";\' \
- -e '#include <db3/db.h>' \
- $t.orig > $t
- # now fix Setup
- scmd="$scmd s:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:;"
- fi
- # no USE vars to switch off these adjustments:
- scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
- scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
- scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
- scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
- sed "$scmd" Modules/Setup.dist > Modules/Setup
-
- ./configure \
- --prefix=/usr \
- --without-libdb \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man
- assert "Configure failed"
- emake || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python2.1 /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- doexe ${FILESDIR}/python-config
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- mkdir "${D}/usr/lib/python2.1/tools"
- mv "${S}/Tools/idle" "${D}/usr/lib/python2.1/tools/"
- dosym /usr/lib/python2.1/tools/idle/idle.py /usr/bin/idle.py
- fi
-}
diff --git a/dev-lang/python/python-2.1.1-r4.ebuild b/dev-lang/python/python-2.1.1-r4.ebuild
deleted file mode 100644
index 35084776f9ef..000000000000
--- a/dev-lang/python/python-2.1.1-r4.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.1-r4.ebuild,v 1.4 2002/04/30 10:31:08 seemant Exp $
-
-S=${WORKDIR}/Python-${PV}
-FCHKSUM="python-fchksum-1.6"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz
- http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUM}.tar.gz"
-
-HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-LICENSE="PSF-2.1.1"
-
-DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
- readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
- berkdb? ( >=sys-libs/db-3 )
- tcltk? ( >=dev-lang/tk-8.0 )"
-
-RDEPEND="$DEPEND"
-PROVIDE="virtual/python-2.1"
-
-SLOT="2.1"
-
-src_unpack() {
- # unpack python
- unpack Python-${PV}.tgz
- # unpack fchksum and move pieces into Modules subdir
- cd ${S}/Modules
- unpack ${FCHKSUM}.tar.gz
- cd ${FCHKSUM}
- cp md5.h ../md5_2.h
- cp cksum.[ch] sum.[ch] fchksum.h ..
- sed 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
- sed 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
- # add fchksum configuration to Setup
- cd ${S}
- echo "fchksum fchksum.c md5_2.c cksum.c sum.c" >> Modules/Setup.dist
-
- # adjust makefile to install pydoc into ${D} correctly
- t=${S}/Makefile.pre.in
- cp $t $t.orig || die
- sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
-}
-
-src_compile() {
- # python's config seems to ignore CFLAGS
- export OPT=$CFLAGS
-
- # configure fchksum
- cd ${S}/Modules/${FCHKSUM}
- ./configure
- cp pfconfig.h ..
-
- # adjust Setup to include the various modules we need
- cd ${S}
- scmd=""
- # adjust for USE readline
- if use readline; then
- scmd="$scmd s:#\(readline .*\) -ltermcap:\1:;"
- scmd="$scmd s:#\(_curses .*\) -lcurses -ltermcap:\1 -lncurses:;"
- fi
- # adjust for USE tcltk
- if use tcltk; then
- # Find the version of tcl/tk that has headers installed.
- # This will be the most recently merged, not necessarily the highest
- # version number.
- tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
- tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
- # adjust Setup to match
- scmd="$scmd s:# \(_tkinter \):\1:;"
- scmd="$scmd s:#\(\t-ltk[0-9.]* -ltcl[0-9.]*\):\t-ltk$tkv -ltcl$tclv:;"
- scmd="$scmd s:#\(\t-L/usr/X11R6/lib\):\1:;"
- scmd="$scmd s:#\(\t-lX11.*\):\1:;"
- fi
- # adjust for USE berkdb
- if use berkdb; then
- # patch the dbmmodule to use db3's dbm compatibility code. That way,
- # we're depending on db3 rather than old db1.
- t=Modules/dbmmodule.c
- cp $t $t.orig || die
- sed \
- -e '10,25d' \
- -e '26i\' \
- -e '#define DB_DBM_HSEARCH 1\' \
- -e 'static char *which_dbm = "BSD db";\' \
- -e '#include <db3/db.h>' \
- $t.orig > $t
- # now fix Setup
- scmd="$scmd s:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:;"
- fi
- # no USE vars to switch off these adjustments:
- scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
- scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
- scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
- scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
- scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
- sed "$scmd" Modules/Setup.dist > Modules/Setup
-
- ./configure \
- --prefix=/usr \
- --without-libdb \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man
- assert "Configure failed"
- emake || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- make install prefix=${D}/usr || die
- rm "${D}/usr/bin/python"
- dosym python2.1 /usr/bin/python
- dodoc README
-
- # install our own custom python-config
- exeinto /usr/bin
- doexe ${FILESDIR}/python-config
-
- # If USE tcltk lets install idle
- # Need to script the python version in the path
- if use tcltk; then
- mkdir "${D}/usr/lib/python2.1/tools"
- mv "${S}/Tools/idle" "${D}/usr/lib/python2.1/tools/"
- dosym /usr/lib/python2.1/tools/idle/idle.py /usr/bin/idle.py
- fi
-
- # man pages wind up in /usr/man for some reason
- mv ${D}/usr/man ${D}/usr/share
-}