summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-09-24 12:49:03 +0000
committerRichard Brown <rbrown@gentoo.org>2007-09-24 12:49:03 +0000
commit2e3c2efd6fd4f468192562cb07215118307780d0 (patch)
tree3038eeb041b84ab9f49a82d54c5ae2a136086260 /dev-lang/ruby
parentbump 3.0b-2, minor bugfix version (diff)
downloadgentoo-2-2e3c2efd6fd4f468192562cb07215118307780d0.tar.gz
gentoo-2-2e3c2efd6fd4f468192562cb07215118307780d0.tar.bz2
gentoo-2-2e3c2efd6fd4f468192562cb07215118307780d0.zip
More fixes from gentoo-dev and graaff
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog5
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p110.ebuild11
2 files changed, 7 insertions, 9 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 22197af9b51c..76557cf75bf9 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.296 2007/09/24 11:56:11 rbrown Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.297 2007/09/24 12:49:03 rbrown Exp $
+
+ 24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
+ More fixes from gentoo-dev and graaff
24 Sep 2007; Richard Brown <rbrown@gentoo.org> ruby-1.8.6_p110.ebuild:
Implement suggestions from http://archives.gentoo.org/gentoo-dev/msg_147875.xml
diff --git a/dev-lang/ruby/ruby-1.8.6_p110.ebuild b/dev-lang/ruby/ruby-1.8.6_p110.ebuild
index dc15849cc56f..ed1cd9d3b1e9 100644
--- a/dev-lang/ruby/ruby-1.8.6_p110.ebuild
+++ b/dev-lang/ruby/ruby-1.8.6_p110.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p110.ebuild,v 1.2 2007/09/24 11:56:11 rbrown Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p110.ebuild,v 1.3 2007/09/24 12:49:03 rbrown Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -43,7 +43,7 @@ src_unpack() {
einfo "Applying ${ONIGURUMA}"
pushd ${WORKDIR}/oniguruma
econf --with-rubydir="${S}" || die "econf failed"
- make $MY_SUFFIX
+ emake $MY_SUFFIX
popd
fi
@@ -117,7 +117,7 @@ src_install() {
done
export LD_LIBRARY_PATH RUBYLIB
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
@@ -144,11 +144,6 @@ src_install() {
}
pkg_postinst() {
- ewarn
- ewarn "Warning: Vim won't work if you've just updated ruby from"
- ewarn "1.6.x to 1.8.x due to the library version change."
- ewarn "In that case, you will need to remerge vim."
- ewarn
ewarn "If you upgrade to >=sys-apps/coreutils-6.7-r1,"
ewarn "you should re-emerge ruby again."