summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-04-06 12:11:00 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-04-06 12:11:00 +0000
commit6a768bc26b088843ed829dcc94daf281522bcf47 (patch)
tree19217e79ed6e9013459e4032db16763182b9179a /dev-lang/snobol
parentUse pkg-config for iodbc dependencies. Bug 464300 (diff)
downloadgentoo-2-6a768bc26b088843ed829dcc94daf281522bcf47.tar.gz
gentoo-2-6a768bc26b088843ed829dcc94daf281522bcf47.tar.bz2
gentoo-2-6a768bc26b088843ed829dcc94daf281522bcf47.zip
Gentoo Bug Day bump and fixes bug 299429 and bug 336397.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-lang/snobol')
-rw-r--r--dev-lang/snobol/ChangeLog9
-rw-r--r--dev-lang/snobol/snobol-1.4.1.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-lang/snobol/ChangeLog b/dev-lang/snobol/ChangeLog
index 49720d488240..be924f90340f 100644
--- a/dev-lang/snobol/ChangeLog
+++ b/dev-lang/snobol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/snobol
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/ChangeLog,v 1.13 2012/11/27 19:41:40 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/ChangeLog,v 1.14 2013/04/06 12:11:00 titanofold Exp $
+
+*snobol-1.4.1 (06 Apr 2013)
+
+ 06 Apr 2013; Aaron W. Swenson <titanofold@gentoo.org> +snobol-1.4.1.ebuild:
+ Gentoo Bug Day bump and fixes bug 299429 and bug 336397.
27 Nov 2012; Ulrich Müller <ulm@gentoo.org> snobol-0.99.4.ebuild,
snobol-0.99.44.ebuild, snobol-1.1.ebuild:
diff --git a/dev-lang/snobol/snobol-1.4.1.ebuild b/dev-lang/snobol/snobol-1.4.1.ebuild
new file mode 100644
index 000000000000..5b3bf0d8bd19
--- /dev/null
+++ b/dev-lang/snobol/snobol-1.4.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/snobol-1.4.1.ebuild,v 1.1 2013/04/06 12:11:00 titanofold Exp $
+
+EAPI=5
+
+MY_P="${PN}4-${PV}"
+
+DESCRIPTION="Phil Budne's port of Macro SNOBOL4 in C, for modern machines"
+HOMEPAGE="http://www.snobol4.org/csnobol4/"
+SRC_URI="mirror://snobol4/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ sys-devel/gcc
+ sys-devel/m4
+ sys-libs/gdbm[berkdb]
+"
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e '/autoconf/s:autoconf:./autoconf:g' \
+ -i configure || die 'autoconf sed failed'
+ sed -e 's/$(INSTALL) -s/$(INSTALL)/' \
+ -i Makefile2.m4 || die 'strip sed failed'
+ echo "ADD_OPT([${CFLAGS}])" >>${S}/local-config
+ echo "ADD_CPPFLAGS([-DUSE_STDARG_H])" >>${S}/local-config
+ echo "ADD_CPPFLAGS([-DHAVE_STDARG_H])" >>${S}/local-config
+}
+
+src_configure() {
+ ./configure --prefix="${EPREFIX%/}/usr" \
+ --snolibdir="${EPREFIX%/}/usr/lib/snobol4" \
+ --mandir="${EPREFIX%/}/usr/share/man" \
+ --add-cflags="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ rm "${ED%/}"/usr/lib/snobol4/{load.txt,README}
+
+ dodoc doc/*txt
+
+ use doc && dohtml doc/*html
+}