summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2011-11-14 21:01:07 +0000
committerJory Pratt <anarchy@gentoo.org>2011-11-14 21:01:07 +0000
commita48ba89937c70fb47244616f5a99ff7e36cc3129 (patch)
tree1387dbceb6489df977de10e0efbb4b0417d022a8 /dev-lang/spidermonkey
parentReverse order of gcc deps to prevent unnecessary gcc rebuild. (diff)
downloadgentoo-2-a48ba89937c70fb47244616f5a99ff7e36cc3129.tar.gz
gentoo-2-a48ba89937c70fb47244616f5a99ff7e36cc3129.tar.bz2
gentoo-2-a48ba89937c70fb47244616f5a99ff7e36cc3129.zip
Multiple bug fixes, bug #377025,377291,388217,375685
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/spidermonkey')
-rw-r--r--dev-lang/spidermonkey/ChangeLog8
-rw-r--r--dev-lang/spidermonkey/files/spidermonkey-1.8.5-fix-ppc64.patch31
-rw-r--r--dev-lang/spidermonkey/spidermonkey-1.8.5-r1.ebuild (renamed from dev-lang/spidermonkey/spidermonkey-1.8.5.ebuild)14
3 files changed, 49 insertions, 4 deletions
diff --git a/dev-lang/spidermonkey/ChangeLog b/dev-lang/spidermonkey/ChangeLog
index a9bd8e3b4998..d98d92b4d931 100644
--- a/dev-lang/spidermonkey/ChangeLog
+++ b/dev-lang/spidermonkey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/spidermonkey
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.62 2011/09/24 16:57:47 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/ChangeLog,v 1.63 2011/11/14 21:01:07 anarchy Exp $
+
+*spidermonkey-1.8.5-r1 (14 Nov 2011)
+
+ 14 Nov 2011; Jory A. Pratt <anarchy@gentoo.org> -spidermonkey-1.8.5.ebuild,
+ +spidermonkey-1.8.5-r1.ebuild, +files/spidermonkey-1.8.5-fix-ppc64.patch:
+ Multiple bug fixes, bug #377025,377291,388217,375685
24 Sep 2011; Fabian Groffen <grobian@gentoo.org>
spidermonkey-1.8.2.15.ebuild:
diff --git a/dev-lang/spidermonkey/files/spidermonkey-1.8.5-fix-ppc64.patch b/dev-lang/spidermonkey/files/spidermonkey-1.8.5-fix-ppc64.patch
new file mode 100644
index 000000000000..d7a2b9e9af0f
--- /dev/null
+++ b/dev-lang/spidermonkey/files/spidermonkey-1.8.5-fix-ppc64.patch
@@ -0,0 +1,31 @@
+# HG changeset patch
+# User Mike Hommey <mh+mozilla@glandium.org>
+# Date 1303461188 -7200
+# Node ID 59771590e9203d48ef8cbcd7eaf2f8ae45dbb1c1
+# Parent c4b82ec27d6d6e1c02ef0abb3b6e805bfdd092ec
+Bug 638056 - Avoid "The cacheFlush support is missing on this platform" error on exotic platforms. r=cdleary
+
+diff --git a/js/src/Makefile.in b/js/src/Makefile.in
+--- a/js/src/Makefile.in
++++ b/js/src/Makefile.in
+@@ -383,17 +383,17 @@ CPPSRCS += checks.cc \
+ platform.cc \
+ utils.cc \
+ $(NONE)
+
+ #
+ # END enclude sources for V8 dtoa
+ #############################################
+
+-ifeq (,$(filter-out powerpc sparc,$(TARGET_CPU)))
++ifeq (,$(filter arm %86 x86_64,$(TARGET_CPU)))
+
+ VPATH += $(srcdir)/assembler \
+ $(srcdir)/assembler/wtf \
+ $(srcdir)/yarr/pcre \
+ $(NULL)
+
+ CPPSRCS += pcre_compile.cpp \
+ pcre_exec.cpp \
+
+
diff --git a/dev-lang/spidermonkey/spidermonkey-1.8.5.ebuild b/dev-lang/spidermonkey/spidermonkey-1.8.5-r1.ebuild
index b19b37a80d4d..e78b8947b577 100644
--- a/dev-lang/spidermonkey/spidermonkey-1.8.5.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-1.8.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.8.5.ebuild,v 1.2 2011/07/03 05:36:21 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.8.5-r1.ebuild,v 1.1 2011/11/14 21:01:07 anarchy Exp $
EAPI="3"
-inherit eutils toolchain-funcs multilib python versionator
+inherit eutils toolchain-funcs multilib python versionator pax-utils
MY_PN="js"
TARBALL_PV="$(replace_all_version_separators '' $(get_version_component_range 1-3))"
@@ -16,7 +16,7 @@ SRC_URI="https://ftp.mozilla.org/pub/mozilla.org/js/${TARBALL_P}.tar.gz"
LICENSE="NPL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="static-libs test"
+IUSE="debug static-libs test"
S="${WORKDIR}/${MY_P}"
BUILDDIR="${S}/js/src"
@@ -29,11 +29,15 @@ DEPEND="${RDEPEND}
pkg_setup(){
python_set_active_version 2
+
+ export LC_ALL="C"
}
src_prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=628723#c43
epatch "${FILESDIR}/${P}-fix-install-symlinks.patch"
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=638056#c9
+ epatch "${FILESDIR}/${P}-fix-ppc64.patch"
epatch_user
@@ -48,10 +52,12 @@ src_configure() {
CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" \
econf \
+ ${myopts} \
--enable-jemalloc \
--enable-readline \
--enable-threadsafe \
--with-system-nspr \
+ $(use enable debug) \
$(use_enable static-libs static) \
$(use_enable test tests)
}
@@ -69,6 +75,8 @@ src_test() {
src_install() {
cd "${BUILDDIR}"
emake DESTDIR="${D}" install || die
+ dobin shell/js ||die
+ pax-mark m "${ED}/usr/bin/js"
dodoc ../../README || die
dohtml README.html || die