summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-04-08 11:10:24 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-04-08 11:10:24 +0000
commit24908f029926363ab9b156ce29ed0c4cde458ed5 (patch)
tree2e005f91ea9ecb5665ffc7848c53926b2b311515 /dev-lang/swig
parentbump, adds octave support (diff)
downloadgentoo-2-24908f029926363ab9b156ce29ed0c4cde458ed5.tar.gz
gentoo-2-24908f029926363ab9b156ce29ed0c4cde458ed5.tar.bz2
gentoo-2-24908f029926363ab9b156ce29ed0c4cde458ed5.zip
remove old cruft
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-lang/swig')
-rw-r--r--dev-lang/swig/ChangeLog7
-rw-r--r--dev-lang/swig/swig-1.3.21.ebuild72
-rw-r--r--dev-lang/swig/swig-1.3.25.ebuild60
-rw-r--r--dev-lang/swig/swig-1.3.27.ebuild62
-rw-r--r--dev-lang/swig/swig-1.3.29-r1.ebuild70
-rw-r--r--dev-lang/swig/swig-1.3.29.ebuild62
6 files changed, 6 insertions, 327 deletions
diff --git a/dev-lang/swig/ChangeLog b/dev-lang/swig/ChangeLog
index e97a1a79580c..1dab6336a67d 100644
--- a/dev-lang/swig/ChangeLog
+++ b/dev-lang/swig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/swig
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.108 2008/04/08 11:03:40 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.109 2008/04/08 11:10:24 hkbst Exp $
+
+ 08 Apr 2008; Marijn Schouten <hkBst@gentoo.org> -swig-1.3.21.ebuild,
+ -swig-1.3.25.ebuild, -swig-1.3.27.ebuild, -swig-1.3.29.ebuild,
+ -swig-1.3.29-r1.ebuild:
+ remove old cruft
*swig-1.3.35 (08 Apr 2008)
diff --git a/dev-lang/swig/swig-1.3.21.ebuild b/dev-lang/swig/swig-1.3.21.ebuild
deleted file mode 100644
index bb5d76627c13..000000000000
--- a/dev-lang/swig/swig-1.3.21.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.21.ebuild,v 1.35 2008/03/11 05:10:55 ricmm Exp $
-
-inherit flag-o-matic mono #48511
-
-DESCRIPTION="Simplified Wrapper and Interface Generator"
-HOMEPAGE="http://www.swig.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="doc java guile python tcl tk ruby perl php"
-
-DEPEND="virtual/libc
- python? ( >=dev-lang/python-2.0 )
- java? ( virtual/jdk )
- ruby? ( virtual/ruby )
- guile? ( >=dev-scheme/guile-1.4 )
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )
- perl? ( >=dev-lang/perl-5.6.1 )
- php? ( virtual/php )"
-
-S=${WORKDIR}/SWIG-${PV}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i 's:$(M4_INSTALL_DIR):$(DESTDIR)$(M4_INSTALL_DIR):g' Makefile.in
-}
-
-src_compile() {
- strip-flags
-
- local myconf
- if use ruby ; then
- local rubyver="`ruby --version | cut -d '.' -f 1,2`"
- export RUBY="/usr/lib/ruby/${rubyver/ruby /}/"
- fi
-
- econf \
- `use_with python py` \
- `use_with java java "${JAVA_HOME}"` \
- `use_with java javaincl "${JAVA_HOME}/include"` \
- `use_with ruby ruby /usr/bin/ruby` \
- `use_with guile` \
- `use_with tcl` \
- `use_with perl perl5 /usr/bin/perl` \
- `use_with php php4` \
- || die
-
- # fix the broken configure script
- use tcl || sed -i -e "s:am__append_1 =:#am__append_1 =:" Runtime/Makefile
-
- `has_version dev-lisp/plt` && PLT=/usr/share/plt/collects
- `has_version dev-lisp/mzscheme` && PLT=/usr/share/mzscheme/collects
-
- emake || die
- emake runtime PLTCOLLECTS=$PLT || die
-}
-
-src_install() {
- make install install-runtime DESTDIR=${D} || die
- dodoc ANNOUNCE CHANGES FUTURE NEW README TODO
- use doc && dohtml -r Doc/{Devel,Manual}
-}
-
-src_test() {
- einfo "FEATURES=\"maketest\" has been disabled for dev-lang/swig"
-}
diff --git a/dev-lang/swig/swig-1.3.25.ebuild b/dev-lang/swig/swig-1.3.25.ebuild
deleted file mode 100644
index 6897b7c76e62..000000000000
--- a/dev-lang/swig/swig-1.3.25.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.25.ebuild,v 1.18 2008/03/11 05:10:55 ricmm Exp $
-
-inherit flag-o-matic mono eutils #48511
-
-DESCRIPTION="Simplified Wrapper and Interface Generator"
-HOMEPAGE="http://www.swig.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="doc guile java perl php python ruby tcl tk"
-
-DEPEND="virtual/libc
- guile? ( >=dev-scheme/guile-1.4 )
- java? ( virtual/jdk )
- perl? ( >=dev-lang/perl-5.6.1 )
- php? ( virtual/php )
- python? ( virtual/python )
- ruby? ( virtual/ruby )
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )"
-
-src_compile() {
- strip-flags
-
- local myconf
- if use ruby ; then
- local rubyver="`ruby --version | cut -d '.' -f 1,2`"
- export RUBY="/usr/$(get_libdir)/ruby/${rubyver/ruby /}/"
- fi
-
- econf \
- $(use_with guile) \
- $(use_with java java "${JAVA_HOME}") \
- $(use_with java javaincl "${JAVA_HOME}/include") \
- $(use_with perl perl5 /usr/bin/perl) \
- $(use_with php php4) \
- $(use_with python python python) \
- $(use_with ruby ruby /usr/bin/ruby) \
- $(use_with tcl) \
- || die
-
- has_version dev-scheme/mzscheme && PLT=/usr/share/mzscheme/collects
- has_version dev-lisp/plt && PLT=/usr/share/plt/collects
-
- emake || die
-}
-
-src_install() {
- make install DESTDIR=${D} || die
- dodoc ANNOUNCE CHANGES CHANGES.current FUTURE NEW README TODO
- use doc && dohtml -r Doc/{Devel,Manual}
-}
-
-src_test() {
- einfo "FEATURES=\"maketest\" has been disabled for dev-lang/swig"
-}
diff --git a/dev-lang/swig/swig-1.3.27.ebuild b/dev-lang/swig/swig-1.3.27.ebuild
deleted file mode 100644
index 8f28c05e4421..000000000000
--- a/dev-lang/swig/swig-1.3.27.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.27.ebuild,v 1.8 2007/02/11 14:23:10 grobian Exp $
-
-inherit flag-o-matic mono eutils #48511
-
-DESCRIPTION="Simplified Wrapper and Interface Generator"
-HOMEPAGE="http://www.swig.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
-RESTRICT="test"
-
-DEPEND="lua? ( dev-lang/lua )
- guile? ( >=dev-scheme/guile-1.4 )
- java? ( virtual/jdk )
- mono? ( dev-lang/mono )
- perl? ( >=dev-lang/perl-5.6.1 )
- php? ( virtual/php )
- pike? ( dev-lang/pike )
- python? ( virtual/python )
- ocaml? ( dev-lang/ocaml )
- ruby? ( virtual/ruby )
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )"
-
-src_compile() {
- strip-flags
-
- local myconf
- if use ruby ; then
- local rubyver=$(ruby --version | cut -d '.' -f 1,2)
- export RUBY="/usr/$(get_libdir)/ruby/${rubyver/ruby /}/"
- fi
-
- econf \
- $(use_with tk x) \
- $(use_with tcl) \
- $(use_with python python python) \
- $(use_with perl perl5 /usr/bin/perl) \
- $(use_with java java "${JAVA_HOME}") \
- $(use_with java javaincl "${JAVA_HOME}/include") \
- $(use_with guile) \
- $(use_with ruby ruby /usr/bin/ruby) \
- $(use_with php php4) \
- $(use_with ocaml) \
- $(use_with pike) \
- $(use_with mono csharp) \
- $(use_with lua) \
- || die
-
- emake || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc ANNOUNCE CHANGES CHANGES.current FUTURE NEW README TODO
- use doc && dohtml -r Doc/{Devel,Manual}
-}
diff --git a/dev-lang/swig/swig-1.3.29-r1.ebuild b/dev-lang/swig/swig-1.3.29-r1.ebuild
deleted file mode 100644
index 4280efa4c26b..000000000000
--- a/dev-lang/swig/swig-1.3.29-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.29-r1.ebuild,v 1.5 2007/02/11 14:23:10 grobian Exp $
-
-inherit flag-o-matic mono eutils #48511
-
-DESCRIPTION="Simplified Wrapper and Interface Generator"
-HOMEPAGE="http://www.swig.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
-RESTRICT="test"
-
-DEPEND="lua? ( dev-lang/lua )
- guile? ( >=dev-scheme/guile-1.4 )
- java? ( virtual/jdk )
- mono? ( dev-lang/mono )
- perl? ( >=dev-lang/perl-5.6.1 )
- php? ( virtual/php )
- pike? ( dev-lang/pike )
- python? ( virtual/python )
- ocaml? ( dev-lang/ocaml )
- ruby? ( virtual/ruby )
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )"
-
-src_unpack() {
- unpack "${A}"
- cd "${S}"
-
- # const char type casting issue prevention
- epatch "${FILESDIR}"/swig-const.patch
-}
-
-src_compile() {
- strip-flags
-
- local myconf
- if use ruby ; then
- local rubyver=$(ruby --version | cut -d '.' -f 1,2)
- export RUBY="/usr/$(get_libdir)/ruby/${rubyver/ruby /}/"
- fi
-
- econf \
- $(use_with tk x) \
- $(use_with tcl) \
- $(use_with python python python) \
- $(use_with perl perl5 /usr/bin/perl) \
- $(use_with java java "${JAVA_HOME}") \
- $(use_with java javaincl "${JAVA_HOME}/include") \
- $(use_with guile) \
- $(use_with ruby ruby /usr/bin/ruby) \
- $(use_with php php4) \
- $(use_with ocaml) \
- $(use_with pike) \
- $(use_with mono csharp) \
- $(use_with lua) \
- || die
-
- emake || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc ANNOUNCE CHANGES CHANGES.current FUTURE NEW README TODO
- use doc && dohtml -r Doc/{Devel,Manual}
-}
diff --git a/dev-lang/swig/swig-1.3.29.ebuild b/dev-lang/swig/swig-1.3.29.ebuild
deleted file mode 100644
index ac9f882c6499..000000000000
--- a/dev-lang/swig/swig-1.3.29.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.29.ebuild,v 1.6 2007/02/11 14:23:10 grobian Exp $
-
-inherit flag-o-matic mono eutils #48511
-
-DESCRIPTION="Simplified Wrapper and Interface Generator"
-HOMEPAGE="http://www.swig.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
-RESTRICT="test"
-
-DEPEND="lua? ( dev-lang/lua )
- guile? ( >=dev-scheme/guile-1.4 )
- java? ( virtual/jdk )
- mono? ( dev-lang/mono )
- perl? ( >=dev-lang/perl-5.6.1 )
- php? ( virtual/php )
- pike? ( dev-lang/pike )
- python? ( virtual/python )
- ocaml? ( dev-lang/ocaml )
- ruby? ( virtual/ruby )
- tcl? ( dev-lang/tcl )
- tk? ( dev-lang/tk )"
-
-src_compile() {
- strip-flags
-
- local myconf
- if use ruby ; then
- local rubyver=$(ruby --version | cut -d '.' -f 1,2)
- export RUBY="/usr/$(get_libdir)/ruby/${rubyver/ruby /}/"
- fi
-
- econf \
- $(use_with tk x) \
- $(use_with tcl) \
- $(use_with python python python) \
- $(use_with perl perl5 /usr/bin/perl) \
- $(use_with java java "${JAVA_HOME}") \
- $(use_with java javaincl "${JAVA_HOME}/include") \
- $(use_with guile) \
- $(use_with ruby ruby /usr/bin/ruby) \
- $(use_with php php4) \
- $(use_with ocaml) \
- $(use_with pike) \
- $(use_with mono csharp) \
- $(use_with lua) \
- || die
-
- emake || die
-}
-
-src_install() {
- make install DESTDIR="${D}" || die
- dodoc ANNOUNCE CHANGES CHANGES.current FUTURE NEW README TODO
- use doc && dohtml -r Doc/{Devel,Manual}
-}