summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-12-12 10:42:06 +0000
committerMark Wright <gienah@gentoo.org>2012-12-12 10:42:06 +0000
commit54e2880db021b9662afd225d3021f7f8602886d1 (patch)
tree5d1613bb159f983cfe8276077ade0c1edec37a04 /dev-lang/teyjus
parentVersion bump wrt bug #446936. (diff)
downloadgentoo-2-54e2880db021b9662afd225d3021f7f8602886d1.tar.gz
gentoo-2-54e2880db021b9662afd225d3021f7f8602886d1.tar.bz2
gentoo-2-54e2880db021b9662afd225d3021f7f8602886d1.zip
Fix sigsegv dereferencing argv = 0 by removing -shared. Also remove -fPIC. sed OMakefile to use CFLAGS and LDFLAGS. Place in subslot in case any future ebuild depends on teyjus.
(Portage version: 2.1.11.36/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-lang/teyjus')
-rw-r--r--dev-lang/teyjus/ChangeLog8
-rw-r--r--dev-lang/teyjus/files/teyjus-2.0.2-flags.patch10
-rw-r--r--dev-lang/teyjus/teyjus-2.0.2.ebuild25
3 files changed, 35 insertions, 8 deletions
diff --git a/dev-lang/teyjus/ChangeLog b/dev-lang/teyjus/ChangeLog
index cb1b6e620d7b..fd690ed3e395 100644
--- a/dev-lang/teyjus/ChangeLog
+++ b/dev-lang/teyjus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/teyjus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/teyjus/ChangeLog,v 1.1 2012/12/09 21:57:06 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/teyjus/ChangeLog,v 1.2 2012/12/12 10:42:06 gienah Exp $
+
+ 12 Dec 2012; Mark Wright <gienah@gentoo.org> files/teyjus-2.0.2-flags.patch,
+ teyjus-2.0.2.ebuild:
+ Fix sigsegv dereferencing argv = 0 by removing -shared. Also remove -fPIC. sed
+ OMakefile to use CFLAGS and LDFLAGS. Place in subslot in case any future
+ ebuild depends on teyjus.
*teyjus-2.0.2 (09 Dec 2012)
diff --git a/dev-lang/teyjus/files/teyjus-2.0.2-flags.patch b/dev-lang/teyjus/files/teyjus-2.0.2-flags.patch
index 86c67e7f52b0..dcccd25f9fe4 100644
--- a/dev-lang/teyjus/files/teyjus-2.0.2-flags.patch
+++ b/dev-lang/teyjus/files/teyjus-2.0.2-flags.patch
@@ -1,12 +1,14 @@
--- teyjus-orig/source/OMakefile 2008-11-17 07:52:31.000000000 +1100
-+++ teyjus/source/OMakefile 2012-03-24 00:27:22.431627679 +1100
-@@ -19,7 +19,8 @@
++++ teyjus/source/OMakefile 2012-12-12 21:24:24.318557107 +1100
+@@ -19,7 +19,10 @@
#
OCAMLINCLUDES += $(CMP) $(DIS) $(SIM) $(LOD)
-CFLAGS += -g
-+CFLAGS += -g -fPIC
-+OCAML_LINK_FLAGS += -shared
++CFLAGS +=
++LDFLAGS +=
++OCAMLFLAGS += -g
++OCAML_LINK_FLAGS +=
############################################################
# Compilation files
diff --git a/dev-lang/teyjus/teyjus-2.0.2.ebuild b/dev-lang/teyjus/teyjus-2.0.2.ebuild
index 8546b985ed00..65ed9826237c 100644
--- a/dev-lang/teyjus/teyjus-2.0.2.ebuild
+++ b/dev-lang/teyjus/teyjus-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/teyjus/teyjus-2.0.2.ebuild,v 1.1 2012/12/09 21:57:06 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/teyjus/teyjus-2.0.2.ebuild,v 1.2 2012/12/12 10:42:06 gienah Exp $
EAPI="5"
@@ -13,7 +13,7 @@ DESCRIPTION="Higher-order logic programming language Lambda Prolog"
HOMEPAGE="http://teyjus.cs.umn.edu/"
SRC_URI="http://teyjus.googlecode.com/files/${MY_P}.tar.gz"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
LICENSE="GPL-3"
IUSE="emacs examples +ocamlopt"
@@ -31,13 +31,32 @@ PATCHES=("${FILESDIR}/${PN}-2.0.2-flags.patch")
SITEFILE=50${PN}-gentoo.el
+src_prepare() {
+ base_src_prepare
+ local cflags=""
+ for i in ${CFLAGS}
+ do
+ cflags="${cflags} -ccopt ${i}"
+ done
+ local lflags=""
+ for i in ${LDFLAGS}
+ do
+ lflags="${lflags} -cclib ${i}"
+ done
+ sed -e "s@CFLAGS +=@CFLAGS += ${CFLAGS}@" \
+ -e "s@LDFLAGS +=@LDFLAGS += ${LDFLAGS}@" \
+ -e "s@OCAMLFLAGS +=@OCAMLFLAGS +=${cflags}${lflags}@" \
+ -i "${S}/source/OMakefile" \
+ || die "Could not set flags in ${S}/teyjus/source/OMakefile"
+}
+
src_compile() {
addpredict "/usr/$(get_libdir)/omake/Pervasives.omc"
addpredict "/usr/$(get_libdir)/omake/build/C.omc"
addpredict "/usr/$(get_libdir)/omake/build/Common.omc"
addpredict "/usr/$(get_libdir)/omake/configure/Configure.omc"
addpredict "/usr/$(get_libdir)/omake/build/OCaml.omc"
- omake all || die "omake all failed"
+ omake --verbose all || die "omake all failed"
if use emacs ; then
pushd "${S}/emacs" || die "Could change directory to emacs"
elisp-compile *.el || die "emacs elisp compile failed"