summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2008-12-08 22:54:43 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2008-12-08 22:54:43 +0000
commitf70aa90c33b585415a31af7ac36343378cffc7d3 (patch)
tree5d56e836e972b215c52500171c61bcf0b67fc1df /dev-lang/tinycobol
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-f70aa90c33b585415a31af7ac36343378cffc7d3.tar.gz
gentoo-2-f70aa90c33b585415a31af7ac36343378cffc7d3.tar.bz2
gentoo-2-f70aa90c33b585415a31af7ac36343378cffc7d3.zip
Version bump + a few hacks to get the paths the way we want them and to eliminate pre-stripping. This should solve bugs #243894, #246658, #240236 and #240218.
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-lang/tinycobol')
-rw-r--r--dev-lang/tinycobol/ChangeLog12
-rw-r--r--dev-lang/tinycobol/files/tinycobol-0.64.patch108
-rw-r--r--dev-lang/tinycobol/tinycobol-0.61.ebuild10
-rw-r--r--dev-lang/tinycobol/tinycobol-0.63.ebuild10
-rw-r--r--dev-lang/tinycobol/tinycobol-0.64.ebuild44
5 files changed, 172 insertions, 12 deletions
diff --git a/dev-lang/tinycobol/ChangeLog b/dev-lang/tinycobol/ChangeLog
index 3be244074492..6ae0903be9fe 100644
--- a/dev-lang/tinycobol/ChangeLog
+++ b/dev-lang/tinycobol/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/tinycobol
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/ChangeLog,v 1.12 2007/02/26 12:57:20 phosphan Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/ChangeLog,v 1.13 2008/12/08 22:54:43 phosphan Exp $
+
+*tinycobol-0.64 (08 Dec 2008)
+
+ 08 Dec 2008; Patrick Kursawe <phosphan@gentoo.org>
+ +files/tinycobol-0.64.patch, +tinycobol-0.64.ebuild:
+ Version bump + a few hacks to get the paths the way we want them and to
+ eliminate pre-stripping. This should solve bugs #243894, #246658, #240236
+ and #240218.
*tinycobol-0.63 (26 Feb 2007)
diff --git a/dev-lang/tinycobol/files/tinycobol-0.64.patch b/dev-lang/tinycobol/files/tinycobol-0.64.patch
new file mode 100644
index 000000000000..99734e162b53
--- /dev/null
+++ b/dev-lang/tinycobol/files/tinycobol-0.64.patch
@@ -0,0 +1,108 @@
+diff -Nru tinycobol-0.64/cobrun/Makefile.in tinycobol-0.64.new/cobrun/Makefile.in
+--- tinycobol-0.64/cobrun/Makefile.in 2008-10-30 08:52:49.000000000 +0100
++++ tinycobol-0.64.new/cobrun/Makefile.in 2008-12-08 23:08:00.000000000 +0100
+@@ -11,12 +11,12 @@
+ datarootdir = ${prefix}/share
+ pkgdatadir = ${datarootdir}/htcobol
+ #cobdir_docdir=@cobdir_docdir@
+-cobdir_docdir=${prefix}/doc/@cobdir_docdir@
++cobdir_docdir=${prefix}/share/doc/@cobdir_docdir@
+
+ INSTALL=@INSTALL@
+ INSTALL_DATA=@INSTALL_DATA@
+ INSTALL_DIR=$(INSTALL) -d -m 755
+-INSTALL_PROGRAM=$(INSTALL) -s -m 755
++INSTALL_PROGRAM=$(INSTALL) -m 755
+
+ INSTBIN=@cobbin_default@
+ INSTRC=@cobdir_default@
+@@ -37,7 +37,7 @@
+ LIBS1=@htg_ld_args_defaults@
+ LIBS2=-L../lib -lhtcobol @htg_ld_args_defaults@
+ LDFLAGS=@LDFLAGS@
+-CCXFLAGS=${INCLUDES}
++CCXFLAGS=${CFLAGS} ${INCLUDES}
+
+ SRC01 = htcobrun.c
+
+diff -Nru tinycobol-0.64/compiler/Makefile.in tinycobol-0.64.new/compiler/Makefile.in
+--- tinycobol-0.64/compiler/Makefile.in 2008-10-30 08:52:49.000000000 +0100
++++ tinycobol-0.64.new/compiler/Makefile.in 2008-12-08 23:08:00.000000000 +0100
+@@ -13,12 +13,12 @@
+ datarootdir = ${prefix}/share
+ pkgdatadir = ${datarootdir}/htcobol
+ #cobdir_docdir=@cobdir_docdir@
+-cobdir_docdir=${prefix}/doc/@cobdir_docdir@
++cobdir_docdir=${prefix}/share/doc/@cobdir_docdir@
+
+ INSTALL=@INSTALL@
+ INSTALL_DATA=@INSTALL_DATA@
+ INSTALL_DIR=$(INSTALL) -d -m 755
+-INSTALL_PROGRAM=$(INSTALL) -s -m 755
++INSTALL_PROGRAM=$(INSTALL) -m 755
+
+ RM= rm -f
+ MKDIR=mkdir -p
+@@ -38,7 +38,7 @@
+ # -DDEBUG_COMPILER -DDEBUG_SCANNER
+ #
+ INCLUDES=@INCLUDES@
+-CCXFLAGS=${INCLUDES} @CCXFLAGS@ -Wall -pedantic -Wno-long-long
++CCXFLAGS=${INCLUDES} ${CFLAGS} @CCXFLAGS@ -Wall -pedantic -Wno-long-long
+ #CCXFLAGS1=${INCLUDES} @CCXFLAGS@
+ CCXFLAGS1=${INCLUDES}
+ LIBS=@LIBS@
+diff -Nru tinycobol-0.64/info/Makefile.in tinycobol-0.64.new/info/Makefile.in
+--- tinycobol-0.64/info/Makefile.in 2008-10-30 08:52:49.000000000 +0100
++++ tinycobol-0.64.new/info/Makefile.in 2008-12-08 23:08:00.000000000 +0100
+@@ -16,15 +16,15 @@
+ #datadir = ${datarootdir}
+ datarootdir = ${prefix}/share
+ pkgdatadir = ${datarootdir}/htcobol
+-mandir = $(prefix)/man/man1
++mandir = $(prefix)/share/man/man1
+
+ #cobdir_docdir=@cobdir_docdir@
+-cobdir_docdir=${prefix}/doc/@cobdir_docdir@
++cobdir_docdir=${prefix}/share/doc/@cobdir_docdir@
+
+ INSTALL=@INSTALL@
+ INSTALL_DATA=@INSTALL_DATA@
+ INSTALL_DIR=$(INSTALL) -d -m 755
+-INSTALL_PROGRAM=$(INSTALL) -s -m 755
++INSTALL_PROGRAM=$(INSTALL) -m 755
+
+ #mandir=@mandir@
+ #docdir=@docdir@
+diff -Nru tinycobol-0.64/lib/Makefile.in tinycobol-0.64.new/lib/Makefile.in
+--- tinycobol-0.64/lib/Makefile.in 2008-10-30 08:52:50.000000000 +0100
++++ tinycobol-0.64.new/lib/Makefile.in 2008-12-08 23:08:00.000000000 +0100
+@@ -9,7 +9,7 @@
+ datarootdir = ${prefix}/share
+ pkgdatadir = ${datarootdir}/htcobol
+ #cobdir_docdir=@cobdir_docdir@
+-cobdir_docdir=${prefix}/doc/@cobdir_docdir@
++cobdir_docdir=${prefix}/share/doc/@cobdir_docdir@
+ lib_dir=${exec_prefix}/lib
+
+ INSTRC=@cobdir_default@
+@@ -18,7 +18,7 @@
+ INSTALL=@INSTALL@
+ INSTALL_DATA=@INSTALL_DATA@
+ INSTALL_DIR=$(INSTALL) -d -m 755
+-INSTALL_PROGRAM=$(INSTALL) -s -m 755
++INSTALL_PROGRAM=$(INSTALL) -m 755
+
+ RANLIB=@RANLIB@
+ AR=@AR@
+@@ -36,8 +36,8 @@
+ INCLUDES=@INCLUDES@
+ LIBS=@htg_ld_args_defaults@
+ LDFLAGS=@LDFLAGS@
+-CCXFLAGS=${INCLUDES} @CCXFLAGS@ -Wall
+-CCXFLAGS1=${INCLUDES} @CCXFLAGS@ -Wall -fPIC -DPIC
++CCXFLAGS=${INCLUDES} ${CFLAGS} @CCXFLAGS@ -Wall
++CCXFLAGS1=${INCLUDES} ${CFLAGS} @CCXFLAGS@ -Wall -fPIC -DPIC
+ ACXFLAGS=@ACXFLAGS@
+
+ #
diff --git a/dev-lang/tinycobol/tinycobol-0.61.ebuild b/dev-lang/tinycobol/tinycobol-0.61.ebuild
index ff3a1f98fbd4..44c7822f2908 100644
--- a/dev-lang/tinycobol/tinycobol-0.61.ebuild
+++ b/dev-lang/tinycobol/tinycobol-0.61.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.61.ebuild,v 1.7 2005/04/24 12:35:36 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.61.ebuild,v 1.8 2008/12/08 22:54:43 phosphan Exp $
inherit eutils
@@ -18,8 +18,8 @@ DEPEND=">=dev-libs/glib-2.0
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
}
src_compile() {
@@ -34,7 +34,7 @@ src_install() {
dodir /usr/share/htcobol
make prefix="${D}/usr" install
dodoc AUTHORS ChangeLog README STATUS
- cd ${D}/usr/lib
+ cd "${D}"/usr/lib
rm libhtcobol.so libhtcobol.so.0
ln -s libhtcobol.so.0.* libhtcobol.so.0
ln -s libhtcobol.so.0 libhtcobol.so
diff --git a/dev-lang/tinycobol/tinycobol-0.63.ebuild b/dev-lang/tinycobol/tinycobol-0.63.ebuild
index c3f2c9e04b78..eefb455e5b25 100644
--- a/dev-lang/tinycobol/tinycobol-0.63.ebuild
+++ b/dev-lang/tinycobol/tinycobol-0.63.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.63.ebuild,v 1.1 2007/02/26 12:57:20 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.63.ebuild,v 1.2 2008/12/08 22:54:43 phosphan Exp $
inherit eutils
@@ -21,8 +21,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
}
src_compile() {
@@ -37,7 +37,7 @@ src_install() {
dodir /usr/share/htcobol
make prefix="${D}/usr" install
dodoc AUTHORS ChangeLog README STATUS
- cd ${D}/usr/lib
+ cd "${D}"/usr/lib
rm libhtcobol.so libhtcobol.so.0
ln -s libhtcobol.so.0.* libhtcobol.so.0
ln -s libhtcobol.so.0 libhtcobol.so
diff --git a/dev-lang/tinycobol/tinycobol-0.64.ebuild b/dev-lang/tinycobol/tinycobol-0.64.ebuild
new file mode 100644
index 000000000000..ab4411d82bcb
--- /dev/null
+++ b/dev-lang/tinycobol/tinycobol-0.64.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.64.ebuild,v 1.1 2008/12/08 22:54:43 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="COBOL for linux"
+HOMEPAGE="http://tiny-cobol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tiny-cobol/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND=">=dev-libs/glib-2.0
+ sys-libs/db"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_compile() {
+ econf || die
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodir /usr/lib
+ dodir /usr/share/htcobol
+ dodir /usr/share/doc
+ emake DESTDIR="${D}" cobdir_docdir="/usr/share/doc/htcobol-${PV}" \
+ pkgdatadir="/usr/share/htcobol/" install
+ cd lib
+ emake DESTDIR="${D}" pkgdatadir="/usr/share/htcobol/" install \
+ install-shared-libs install-static-libs
+}