summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2009-06-07 13:11:30 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2009-06-07 13:11:30 +0000
commitd7c75be7c2c5600325bd1be5612002a29ad5b428 (patch)
tree642e62b0980d165223bd506ce3e060195cef4932 /dev-lang/yasm
parentamd64/x86 stable, bug #272544 (diff)
downloadgentoo-2-d7c75be7c2c5600325bd1be5612002a29ad5b428.tar.gz
gentoo-2-d7c75be7c2c5600325bd1be5612002a29ad5b428.tar.bz2
gentoo-2-d7c75be7c2c5600325bd1be5612002a29ad5b428.zip
stable amd64 as requested by Samuli Suominen to fix bug #273008. General QA cleanup by myself and Samuli. Convert to EAPI 2 for simplicity.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/ChangeLog6
-rw-r--r--dev-lang/yasm/yasm-0.8.0.ebuild23
2 files changed, 12 insertions, 17 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index 21a189a758a8..c0e3cc5f1bc7 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.32 2009/04/19 14:01:33 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.33 2009/06/07 13:11:30 gentoofan23 Exp $
+
+ 07 Jun 2009; Thomas Anderson <gentoofan23@gentoo.org> yasm-0.8.0.ebuild:
+ stable amd64 as requested by Samuli Suominen to fix bug #273008. General QA
+ cleanup by myself and Samuli. Convert to EAPI 2 for simplicity.
19 Apr 2009; Markus Meier <maekke@gentoo.org> yasm-0.7.2:
x86 stable, bug #266057
diff --git a/dev-lang/yasm/yasm-0.8.0.ebuild b/dev-lang/yasm/yasm-0.8.0.ebuild
index ca9311408c2a..1150ebf96a1c 100644
--- a/dev-lang/yasm/yasm-0.8.0.ebuild
+++ b/dev-lang/yasm/yasm-0.8.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.8.0.ebuild,v 1.1 2009/04/13 22:38:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.8.0.ebuild,v 1.2 2009/06/07 13:11:30 gentoofan23 Exp $
+
+EAPI="2"
DESCRIPTION="Assembler that supports amd64"
HOMEPAGE="http://www.tortall.net/projects/yasm/"
@@ -8,28 +10,17 @@ SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+KEYWORDS="-* amd64 ~x86 ~x86-fbsd"
IUSE="nls"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Remove macho tests (gas{32,64},nasm{32,64}) until fixed upstream.
- # Necessary to pass test phase on at least amd64 with gcc-4.1.2.
- sed -i \
- -e '/modules\/objfmts\/macho\/tests\/.*\/.*macho.*_test.sh/d' \
- Makefile.in
-}
-
-src_compile() {
- econf $(use_enable nls) || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf $(use_enable nls)
}
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS INSTALL
+ dodoc AUTHORS
}