summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-09 20:22:40 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-09 20:22:40 +0000
commit0b86b0e051e94fb52ba4c096342cfd1fdfaf91e6 (patch)
tree95995016f1bb9acad03bee3545b82495a0ab4fd3 /dev-lang
parentCompile fix for ppc-macos. (Manifest recommit) (diff)
downloadgentoo-2-0b86b0e051e94fb52ba4c096342cfd1fdfaf91e6.tar.gz
gentoo-2-0b86b0e051e94fb52ba4c096342cfd1fdfaf91e6.tar.bz2
gentoo-2-0b86b0e051e94fb52ba4c096342cfd1fdfaf91e6.zip
Apply oniguruma fix patch on all arches.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ChangeLog8
-rw-r--r--dev-lang/ruby/files/oniguruma-2.3.1-gentoo.patch (renamed from dev-lang/ruby/files/oniguruma-2.3.1-fix-ppc.patch)0
-rw-r--r--dev-lang/ruby/ruby-1.6.8-r11.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.6.8-r12.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.8.0-r7.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.8.1-r7.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.8.2_pre2.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.8.2_pre3.ebuild6
8 files changed, 19 insertions, 25 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 1fb6eac07144..fc3e493bd875 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.101 2004/11/08 05:20:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.102 2004/11/09 20:22:40 usata Exp $
+
+ 10 Nov 2004; Mamoru KOMACHI <usata@gentoo.org>
+ -files/oniguruma-2.3.1-fix-ppc.patch, +files/oniguruma-2.3.1-gentoo.patch,
+ ruby-1.6.8-r11.ebuild, ruby-1.6.8-r12.ebuild, ruby-1.8.0-r7.ebuild,
+ ruby-1.8.1-r7.ebuild, ruby-1.8.2_pre2.ebuild, ruby-1.8.2_pre3.ebuild:
+ Apply oniguruma fix patch on all arches.
09 Nov 2004; Aron Griffis <agriffis@gentoo.org> ruby-1.8.2_pre3.ebuild:
On ia64 we need to build without optimization #48824. Add ~ia64
diff --git a/dev-lang/ruby/files/oniguruma-2.3.1-fix-ppc.patch b/dev-lang/ruby/files/oniguruma-2.3.1-gentoo.patch
index bba6a5a25113..bba6a5a25113 100644
--- a/dev-lang/ruby/files/oniguruma-2.3.1-fix-ppc.patch
+++ b/dev-lang/ruby/files/oniguruma-2.3.1-gentoo.patch
diff --git a/dev-lang/ruby/ruby-1.6.8-r11.ebuild b/dev-lang/ruby/ruby-1.6.8-r11.ebuild
index b1dfeb631673..17db79bdfcdf 100644
--- a/dev-lang/ruby/ruby-1.6.8-r11.ebuild
+++ b/dev-lang/ruby/ruby-1.6.8-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r11.ebuild,v 1.11 2004/10/19 20:22:53 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r11.ebuild,v 1.12 2004/11/09 20:22:40 usata Exp $
IUSE="cjk"
@@ -41,9 +41,7 @@ src_unpack() {
if use cjk ; then
einfo "Applying ${ONIGURUMA}"
cd ${WORKDIR}/oniguruma
- if use ppc || use ppc64 ; then
- epatch ${FILESDIR}/oniguruma-2.3.1-fix-ppc.patch
- fi
+ epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
fi
diff --git a/dev-lang/ruby/ruby-1.6.8-r12.ebuild b/dev-lang/ruby/ruby-1.6.8-r12.ebuild
index 3a2269c5c002..2e78f7079ca5 100644
--- a/dev-lang/ruby/ruby-1.6.8-r12.ebuild
+++ b/dev-lang/ruby/ruby-1.6.8-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r12.ebuild,v 1.1 2004/11/04 16:25:59 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r12.ebuild,v 1.2 2004/11/09 20:22:40 usata Exp $
IUSE="cjk"
@@ -38,9 +38,7 @@ src_unpack() {
if use cjk ; then
einfo "Applying ${ONIGURUMA}"
cd ${WORKDIR}/oniguruma
- if use ppc || use ppc64 || use alpha ; then
- epatch ${FILESDIR}/oniguruma-2.3.1-fix-ppc.patch
- fi
+ epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
fi
diff --git a/dev-lang/ruby/ruby-1.8.0-r7.ebuild b/dev-lang/ruby/ruby-1.8.0-r7.ebuild
index cafc9cea0d2d..72eff4e31008 100644
--- a/dev-lang/ruby/ruby-1.8.0-r7.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0-r7.ebuild,v 1.6 2004/10/10 09:06:17 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0-r7.ebuild,v 1.7 2004/11/09 20:22:40 usata Exp $
ONIGURUMA="onigd2_3_2"
MY_P=${P/_pre/-preview}
@@ -38,9 +38,7 @@ src_unpack() {
if use cjk ; then
einfo "Applying ${ONIGURUMA}"
pushd oniguruma
- if use ppc || use ppc64 ; then
- epatch ${FILESDIR}/oniguruma-2.3.1-fix-ppc.patch
- fi
+ epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
popd
diff --git a/dev-lang/ruby/ruby-1.8.1-r7.ebuild b/dev-lang/ruby/ruby-1.8.1-r7.ebuild
index 85746bb55031..b1493d86abff 100644
--- a/dev-lang/ruby/ruby-1.8.1-r7.ebuild
+++ b/dev-lang/ruby/ruby-1.8.1-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r7.ebuild,v 1.10 2004/10/10 09:06:17 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r7.ebuild,v 1.11 2004/11/09 20:22:40 usata Exp $
ONIGURUMA="onigd2_3_2"
SNAP_DATE="2004.05.02"
@@ -40,9 +40,7 @@ src_unpack() {
if use cjk ; then
einfo "Applying ${ONIGURUMA}"
pushd ${WORKDIR}/oniguruma
- if use ppc || use ppc64 ; then
- epatch ${FILESDIR}/oniguruma-2.3.1-fix-ppc.patch
- fi
+ epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
popd
diff --git a/dev-lang/ruby/ruby-1.8.2_pre2.ebuild b/dev-lang/ruby/ruby-1.8.2_pre2.ebuild
index 59a77eec0604..77dbc0879bb3 100644
--- a/dev-lang/ruby/ruby-1.8.2_pre2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.2_pre2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre2.ebuild,v 1.19 2004/10/27 08:12:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre2.ebuild,v 1.20 2004/11/09 20:22:40 usata Exp $
ONIGURUMA="onigd2_3_2"
MY_P=${P/_pre/-preview}
@@ -40,9 +40,7 @@ src_unpack() {
if use cjk ; then
einfo "Applying ${ONIGURUMA}"
pushd ${WORKDIR}/oniguruma
- if use ppc || use ppc64 || use alpha ; then
- epatch ${FILESDIR}/oniguruma-2.3.1-fix-ppc.patch
- fi
+ epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
popd
diff --git a/dev-lang/ruby/ruby-1.8.2_pre3.ebuild b/dev-lang/ruby/ruby-1.8.2_pre3.ebuild
index 49a1530626fe..ad7044b208be 100644
--- a/dev-lang/ruby/ruby-1.8.2_pre3.ebuild
+++ b/dev-lang/ruby/ruby-1.8.2_pre3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre3.ebuild,v 1.2 2004/11/08 05:20:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre3.ebuild,v 1.3 2004/11/09 20:22:40 usata Exp $
ONIGURUMA="onigd2_3_2"
@@ -38,9 +38,7 @@ src_unpack() {
if use cjk ; then
einfo "Applying ${ONIGURUMA}"
pushd ${WORKDIR}/oniguruma
- if use ppc || use ppc64 || use alpha ; then
- epatch ${FILESDIR}/oniguruma-2.3.1-fix-ppc.patch
- fi
+ epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
popd