summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-18 12:27:44 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-18 12:27:44 +0000
commit102229e2bce84d19c99560e9a3acfcf42aa96438 (patch)
tree8b3e762ca3a4cc81cfeae2b570d7e06d09e0da8c /dev-lang
parent*** empty log message *** (diff)
downloadgentoo-2-102229e2bce84d19c99560e9a3acfcf42aa96438.tar.gz
gentoo-2-102229e2bce84d19c99560e9a3acfcf42aa96438.tar.bz2
gentoo-2-102229e2bce84d19c99560e9a3acfcf42aa96438.zip
*** empty log message ***
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/entity/entity-pre-0.7.0.ebuild42
-rw-r--r--dev-lang/entity/files/digest-entity-pre-0.7.01
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-lang/entity/entity-pre-0.7.0.ebuild b/dev-lang/entity/entity-pre-0.7.0.ebuild
new file mode 100644
index 000000000000..11dca3ea3d34
--- /dev/null
+++ b/dev-lang/entity/entity-pre-0.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/entity/entity-pre-0.7.0.ebuild,v 1.1 2000/11/18 12:27:44 achim Exp $
+
+P=entity-pre0.7.0
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="An XML Framework"
+SRC_URI="http://entity.evilplan.org/Download/files/${A}"
+HOMEPAGE="http://entity.evilplan.org"
+
+DEPEND=">=media-libs/imlib-1.9.8.1
+ >=dev-libs/libpcre-3.2
+ >=dev-lang/tcl-tk-8.1.1
+ >=sys-devel/perl-5.6"
+
+RDEPEND="$DEPEND
+ sys-apps/bash"
+
+src_compile() {
+
+ cd ${S}
+ try DEBIAN_ENTITY_MAGIC=voodoo ./configure --prefix=/usr --host=${CHOST} \
+ --enable-exec-class=yes \
+ --enable-gtk=module \
+ --enable-perl=static --enable-python=no \
+ --enable-tcl=module --with-tcl=/usr/lib \
+ --enable-c=module \
+ --enable-javascript=yes --with-included-njs
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ export LD_LIBRARY_PATH=${D}/usr/lib
+ try make DESTDIR=${D} install
+
+}
+
diff --git a/dev-lang/entity/files/digest-entity-pre-0.7.0 b/dev-lang/entity/files/digest-entity-pre-0.7.0
new file mode 100644
index 000000000000..1e22137cad54
--- /dev/null
+++ b/dev-lang/entity/files/digest-entity-pre-0.7.0
@@ -0,0 +1 @@
+MD5 9d863556a6c5a594bb35dbf2b47cb4a4 entity-pre0.7.0.tar.gz