summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-10 16:04:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-10 16:04:59 +0000
commit1909bc6c6232ff36e38fa8e47d13919644c7b628 (patch)
treeee05059290e14a035c27af4b9d3e2ff02b7118ef /dev-lang
parentmodernize and go multilib (diff)
downloadgentoo-2-1909bc6c6232ff36e38fa8e47d13919644c7b628.tar.gz
gentoo-2-1909bc6c6232ff36e38fa8e47d13919644c7b628.tar.bz2
gentoo-2-1909bc6c6232ff36e38fa8e47d13919644c7b628.zip
convert to multilib, bug #479936
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/orc/ChangeLog7
-rw-r--r--dev-lang/orc/orc-0.4.17-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-lang/orc/ChangeLog b/dev-lang/orc/ChangeLog
index c21047014b97..8e77c72b2f7a 100644
--- a/dev-lang/orc/ChangeLog
+++ b/dev-lang/orc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/orc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.31 2013/04/29 13:49:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.32 2013/08/10 16:04:59 aballier Exp $
+
+*orc-0.4.17-r1 (10 Aug 2013)
+
+ 10 Aug 2013; Alexis Ballier <aballier@gentoo.org> +orc-0.4.17-r1.ebuild:
+ convert to multilib, bug #479936
*orc-0.4.17 (29 Apr 2013)
diff --git a/dev-lang/orc/orc-0.4.17-r1.ebuild b/dev-lang/orc/orc-0.4.17-r1.ebuild
new file mode 100644
index 000000000000..0fa66fb04c63
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.17-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/orc-0.4.17-r1.ebuild,v 1.1 2013/08/10 16:04:59 aballier Exp $
+
+EAPI="5"
+inherit autotools eutils flag-o-matic autotools-multilib
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="http://code.entropywave.com/projects/orc/"
+SRC_URI="http://code.entropywave.com/download/orc/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am"
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' Makefile.am || die
+ epatch "${FILESDIR}/${P}-AM_CONFIG_HEADER.patch" # in 0.4.18
+ AT_M4DIR="m4" eautoreconf
+ fi
+}
+
+src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+ autotools-multilib_src_configure
+}