summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-29 10:45:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-29 10:45:01 +0000
commit1b7f76692960619b1761d027e73b39a8b4e19cda (patch)
tree89c24ece4c746fbac97792cd1551278de50e955e /dev-lang
parentAdded qt-svg dependency, switch to eapi 2 (diff)
downloadgentoo-2-1b7f76692960619b1761d027e73b39a8b4e19cda.tar.gz
gentoo-2-1b7f76692960619b1761d027e73b39a8b4e19cda.tar.bz2
gentoo-2-1b7f76692960619b1761d027e73b39a8b4e19cda.zip
Move 2.7.2 to EAPI=2 and close bug #252661
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-2.7.2.ebuild35
-rw-r--r--dev-lang/R/R-2.8.0.ebuild162
-rw-r--r--dev-lang/R/R-2.8.1.ebuild5
-rw-r--r--dev-lang/R/files/R-2.8.0-without-X.patch14
5 files changed, 20 insertions, 203 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 49a293146e9a..d13cde670a7d 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.143 2009/01/02 21:15:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.144 2009/01/29 10:45:01 bicatali Exp $
+
+ 29 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/R-2.8.0-without-X.patch, R-2.7.2.ebuild, -R-2.8.0.ebuild,
+ R-2.8.1.ebuild:
+ Move 2.7.2 to EAPI=2 and close bug #252661
*R-2.8.1 (02 Jan 2009)
diff --git a/dev-lang/R/R-2.7.2.ebuild b/dev-lang/R/R-2.7.2.ebuild
index 5ae8209f04a4..6e291a9f0d9c 100644
--- a/dev-lang/R/R-2.7.2.ebuild
+++ b/dev-lang/R/R-2.7.2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.7.2.ebuild,v 1.8 2008/11/09 13:20:56 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.7.2.ebuild,v 1.9 2009/01/29 10:45:01 bicatali Exp $
+EAPI=2
inherit fortran flag-o-matic bash-completion versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
@@ -21,7 +22,8 @@ CDEPEND="dev-lang/perl
app-arch/bzip2
virtual/blas
virtual/ghostscript
- cairo? ( x11-libs/cairo x11-libs/pango )
+ cairo? ( x11-libs/cairo[X]
+ || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
readline? ( sys-libs/readline )
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )
@@ -49,27 +51,10 @@ pkg_setup() {
export FFLAGS="${FFLAGS:--O2}"
[[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
-
- # make sure cairo and pango are both compiled with "X"
- # use flag (see bug #231970)
- if use cairo; then
- if ( ! built_with_use x11-libs/cairo X ); then
- eerror "x11-libs/cairo needs to be built with USE=\"X\""
- die "Please rebuild x11-libs/cairo with USE=\"X\""
- fi
-
- if ( ! built_with_use x11-libs/pango X ); then
- eerror "x11-libs/pango needs to be built with USE=\"X\""
- die "Please rebuild x11-libs/pango with USE=\"X\""
- fi
- fi
-
filter-ldflags -Wl,-Bdirect -Bdirect
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-javareconf.patch
epatch "${FILESDIR}"/${PN}-2.7.1-test-fix.patch
}
@@ -80,7 +65,7 @@ src_test() {
R_HOME="" make check || die "Some of the tests failed"
}
-src_compile() {
+src_configure() {
# fix packages.html for doc (bug #205103)
# check in later versions if fixed
sed -i \
@@ -120,8 +105,10 @@ src_compile() {
$(use_with png libpng) \
$(use_with readline) \
$(use_with cairo) \
- $(use_with X x) \
- || die "econf failed"
+ $(use_with X x)
+}
+
+src_compile() {
emake || die "emake failed"
if use doc; then
export VARTEXFONTS="${T}/fonts"
diff --git a/dev-lang/R/R-2.8.0.ebuild b/dev-lang/R/R-2.8.0.ebuild
deleted file mode 100644
index 91020759c2e4..000000000000
--- a/dev-lang/R/R-2.8.0.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.8.0.ebuild,v 1.2 2008/10/31 13:05:36 markusle Exp $
-
-EAPI=2
-inherit eutils fortran flag-o-matic bash-completion versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="doc java jpeg lapack minimal nls png readline tk X cairo"
-
-# common depends
-CDEPEND="dev-lang/perl
- dev-libs/libpcre
- app-arch/bzip2
- virtual/blas
- virtual/ghostscript
- cairo? ( x11-libs/cairo[X] x11-libs/pango[X] )
- readline? ( sys-libs/readline )
- jpeg? ( media-libs/jpeg )
- png? ( media-libs/libpng )
- lapack? ( virtual/lapack )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? ( virtual/latex-base
- || ( dev-texlive/texlive-fontsrecommended
- app-text/tetex
- app-text/ptex ) )"
-
-RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/zip
- java? ( >=virtual/jre-1.5 )"
-
-R_HOME=/usr/$(get_libdir)/${PN}
-
-pkg_setup() {
- FORTRAN="gfortran ifc g77"
- fortran_pkg_setup
- export FFLAGS="${FFLAGS:--O2}"
- [[ ${FORTRANC} = gfortran || ${FORTRANC} = if* ]] && \
- export FCFLAGS="${FCFLAGS:-${FFLAGS}}"
- filter-ldflags -Wl,-Bdirect -Bdirect
-}
-
-src_prepare() {
-
- # fix packages.html for doc (bug #205103)
- # check in later versions if fixed
- sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/packageshtml.R \
- || die "sed failed"
-
- # fix Rscript
- sed -i \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_HOME}\"':" \
- src/unix/Makefile.in || die "sed unix Makefile failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-without-X.patch
-}
-
-src_configure() {
- econf \
- --disable-rpath \
- --enable-R-profiling \
- --enable-memory-profiling \
- --enable-R-shlib \
- --enable-linux-lfs \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir=/usr/share/doc/${PF} \
- rdocdir=/usr/share/doc/${PF} \
- $(use_enable nls) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with cairo) \
- $(use_with X x)
-}
-
-src_compile(){
- emake || die "emake failed"
- RMATH_V=0.0.0
- emake -j1 -C src/nmath/standalone \
- libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
- || die "emake math library failed"
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake info pdf || die "emake docs failed"
- fi
-}
-
-src_test() {
- # we need to unset R_HOME otherwise some of the diff based
- # tests fail due to warnings in the output
- R_HOME="" emake -j1 check || die "Some of the tests failed"
-}
-
-src_install() {
- # -j1 because creates various dirs sequentially (hit should be small)
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- fi
-
- emake -j1 \
- -C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${D}"/usr/$(get_libdir)/libRmath.so \
- "${D}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_HOME}/lib
- R_HOME=${R_HOME}
- EOF
- doenvd 99R || die "doenvd failed"
-
- dobashcompletion "${WORKDIR}"/R.bash_completion
-}
-
-pkg_config() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
-}
diff --git a/dev-lang/R/R-2.8.1.ebuild b/dev-lang/R/R-2.8.1.ebuild
index bb9e845bfaca..4f347178580e 100644
--- a/dev-lang/R/R-2.8.1.ebuild
+++ b/dev-lang/R/R-2.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.8.1.ebuild,v 1.1 2009/01/02 21:15:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.8.1.ebuild,v 1.2 2009/01/29 10:45:01 bicatali Exp $
EAPI=2
inherit eutils fortran flag-o-matic bash-completion versionator
@@ -22,7 +22,8 @@ CDEPEND="dev-lang/perl
app-arch/bzip2
virtual/blas
virtual/ghostscript
- cairo? ( x11-libs/cairo[X] x11-libs/pango[X] )
+ cairo? ( x11-libs/cairo[X]
+ || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
readline? ( sys-libs/readline )
jpeg? ( media-libs/jpeg )
png? ( media-libs/libpng )
diff --git a/dev-lang/R/files/R-2.8.0-without-X.patch b/dev-lang/R/files/R-2.8.0-without-X.patch
deleted file mode 100644
index 0fefc65083ef..000000000000
--- a/dev-lang/R/files/R-2.8.0-without-X.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-# missing ; in source code causes build failure when configured via
-# --without-X
-diff -Naur R-2.8.0/src/main/platform.c R-2.8.0.new/src/main/platform.c
---- R-2.8.0/src/main/platform.c 2008-10-07 22:05:05.000000000 -0400
-+++ R-2.8.0.new/src/main/platform.c 2008-10-31 08:44:10.000000000 -0400
-@@ -1654,7 +1654,7 @@
- # ifdef HAVE_X11
- int X11 = NA_LOGICAL;
- # else
-- int X11 = FALSE
-+ int X11 = FALSE;
- # endif
- #endif
-