summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-03-11 17:17:18 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-03-11 17:17:18 +0000
commit219d5f069d14b09b03a66fa44b3f50756339dae6 (patch)
treedeb05b8ad9b69577a83c7f373c2d983f2c33301d /dev-lang
parentDrop to ~mips due to unstable deps (diff)
downloadgentoo-2-219d5f069d14b09b03a66fa44b3f50756339dae6.tar.gz
gentoo-2-219d5f069d14b09b03a66fa44b3f50756339dae6.tar.bz2
gentoo-2-219d5f069d14b09b03a66fa44b3f50756339dae6.zip
clean up
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/ChangeLog6
-rw-r--r--dev-lang/erlang/erlang-12.2.0.ebuild170
-rw-r--r--dev-lang/erlang/files/erlang-12.2.0-binary-append.patch16
3 files changed, 5 insertions, 187 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index fe1b3d0d5dfb..703b50ec1248 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.106 2008/03/11 15:28:20 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.107 2008/03/11 17:17:18 opfer Exp $
+
+ 11 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
+ -files/erlang-12.2.0-binary-append.patch, -erlang-12.2.0.ebuild:
+ clean up
11 Mar 2008; Brent Baude <ranger@gentoo.org> erlang-12.2.1.ebuild:
stable ppc64, bug 212684
diff --git a/dev-lang/erlang/erlang-12.2.0.ebuild b/dev-lang/erlang/erlang-12.2.0.ebuild
deleted file mode 100644
index febf4b5645dc..000000000000
--- a/dev-lang/erlang/erlang-12.2.0.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.0.ebuild,v 1.11 2008/01/22 19:27:14 armin76 Exp $
-
-inherit elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: You need to adjust the version number in the last comment. If you need symlinks for
-# binaries please tell maintainers or open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50erlang-gentoo.el
-
-src_unpack() {
-
- unpack ${A}
- cd "${S}"
-
- # build failures should make the whole build fail
- # accepted by upstream for >12B-0
- epatch "${FILESDIR}"/${PN}-11.2.5-build.patch #184419
-
- # needed for amd64
- # accepted by upstream for >12B-0
- epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
-
- # needed for FreeBSD
- # accepted by upstream for >12B-0
- epatch "${FILESDIR}/${PN}-11.2.5-gethostbyname.patch"
-
- # binary append on runtime has failures
- # taken from upstream, will be included in > 12B-0
- epatch "${FILESDIR}/${P}-binary-append.patch"
-
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # make sure we only link ssl dynamically
- # will not be integrated by upstream for various reasons
- sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it!"
- ewarn
- fi
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable kpoll kernell-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header, has been reported upstream, should be fixed in R12
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of erlang's binaries,"
- elog "please open a bug and tell the maintainers."
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R12B"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/files/erlang-12.2.0-binary-append.patch b/dev-lang/erlang/files/erlang-12.2.0-binary-append.patch
deleted file mode 100644
index c98c8eb9f04b..000000000000
--- a/dev-lang/erlang/files/erlang-12.2.0-binary-append.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- lib/compiler/src/beam_bsm.erl.orig 2007-12-10 21:37:43.000000000 +0100
-+++ lib/compiler/src/beam_bsm.erl 2007-12-10 21:38:20.000000000 +0100
-@@ -269,9 +269,11 @@
- btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
- btb_reaches_match_2([{bs_init_bits,{f,0},_,_,_,_,Dst}|Is], Regs, D) ->
- btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
--btb_reaches_match_2([{bs_append,{f,0},_,_,_,_,_,_,Dst}|Is], Regs, D) ->
-+btb_reaches_match_2([{bs_append,{f,0},_,_,_,_,Src,_,Dst}=I|Is], Regs, D) ->
-+ btb_ensure_not_used([Src], I, Regs),
- btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
--btb_reaches_match_2([{bs_private_append,{f,0},_,_,_,_,Dst}|Is], Regs, D) ->
-+btb_reaches_match_2([{bs_private_append,{f,0},_,_,Src,_,Dst}=I|Is], Regs, D) ->
-+ btb_ensure_not_used([Src], I, Regs),
- btb_reaches_match_1(Is, btb_kill([Dst], Regs), D);
- btb_reaches_match_2([{bs_put_integer,{f,0},_,_,_,_}|Is], Regs, D) ->
- btb_reaches_match_1(Is, Regs, D);