summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-10-29 03:47:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-10-29 03:47:06 +0000
commit22094e78a59c6634252b4a46692f9d325edf7d36 (patch)
tree51c2567b4561f839bbb5ecaa004a23acb94d8dd1 /dev-lang
parentWhitespace, clean up inherit (diff)
downloadgentoo-2-22094e78a59c6634252b4a46692f9d325edf7d36.tar.gz
gentoo-2-22094e78a59c6634252b4a46692f9d325edf7d36.tar.bz2
gentoo-2-22094e78a59c6634252b4a46692f9d325edf7d36.zip
Fix cc detection #527108
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/opendylan/ChangeLog5
-rw-r--r--dev-lang/opendylan/opendylan-2013.2.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-lang/opendylan/ChangeLog b/dev-lang/opendylan/ChangeLog
index 4467428c9745..5abff873f3de 100644
--- a/dev-lang/opendylan/ChangeLog
+++ b/dev-lang/opendylan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/opendylan
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/ChangeLog,v 1.17 2014/06/23 08:41:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/ChangeLog,v 1.18 2014/10/29 03:47:06 patrick Exp $
+
+ 29 Oct 2014; Patrick Lauer <patrick@gentoo.org> opendylan-2013.2.ebuild:
+ Fix cc detection #527108
23 Jun 2014; Patrick Lauer <patrick@gentoo.org> opendylan-2013.2.ebuild:
Fix dependencies #514630
diff --git a/dev-lang/opendylan/opendylan-2013.2.ebuild b/dev-lang/opendylan/opendylan-2013.2.ebuild
index a4555bcf1c4c..e43418dc1a74 100644
--- a/dev-lang/opendylan/opendylan-2013.2.ebuild
+++ b/dev-lang/opendylan/opendylan-2013.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2013.2.ebuild,v 1.3 2014/06/23 08:41:34 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2013.2.ebuild,v 1.4 2014/10/29 03:47:06 patrick Exp $
EAPI=4
-inherit autotools
+inherit autotools toolchain-funcs
RESTRICT="test"
@@ -50,6 +50,8 @@ NAUGHTY_HEADERS=(
S="${WORKDIR}/${PN}"
src_prepare() {
+ # configure autodetects clang and prefers it, #527108
+ sed -i -e 's/clang//' configure.ac || die
mkdir -p build-aux
elibtoolize && eaclocal || die "Fail"
automake --foreign --add-missing # this one dies wrongfully
@@ -76,6 +78,7 @@ src_configure() {
else
PATH=/opt/opendylan/bin:$PATH
fi
+
if use amd64; then
econf --prefix=/opt/opendylan || die
else