summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-09 16:17:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-09 16:17:40 +0000
commit2ce8799fd7e2d449478cdaaa347396fa811907a9 (patch)
tree496110d955e75939b6fb651a2991c3392fbcce18 /dev-lang
parent+libaio-0.3.109-r3: Add multilib support (for oracle-instantclient-11 multilib). (diff)
downloadgentoo-2-2ce8799fd7e2d449478cdaaa347396fa811907a9.tar.gz
gentoo-2-2ce8799fd7e2d449478cdaaa347396fa811907a9.tar.bz2
gentoo-2-2ce8799fd7e2d449478cdaaa347396fa811907a9.zip
Added prebuild ppc64 binary (bug #394361).
(Portage version: 2.2.0_alpha90_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-7.0.4.ebuild8
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 1c7918dc6dda..5c9c48c4e2ed 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.212 2012/03/04 14:32:50 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.213 2012/03/09 16:17:40 slyfox Exp $
+
+ 09 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.0.4.ebuild:
+ Added prebuild ppc64 binary (bug #394361).
04 Mar 2012; Mark Wright <gienah@gentoo.org> ghc-7.4.1.ebuild:
Fix QA Notice: dobashcompletion: command not found
diff --git a/dev-lang/ghc/ghc-7.0.4.ebuild b/dev-lang/ghc/ghc-7.0.4.ebuild
index 3f8751599230..0c6b745c54ac 100644
--- a/dev-lang/ghc/ghc-7.0.4.ebuild
+++ b/dev-lang/ghc/ghc-7.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.0.4.ebuild,v 1.5 2012/03/04 05:49:54 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.0.4.ebuild,v 1.6 2012/03/09 16:17:40 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -44,7 +44,7 @@ arch_binaries="$arch_binaries arm? ( http://code.haskell.org/~slyfox/ghc-arm/ghc
arch_binaries="$arch_binaries amd64? ( http://code.haskell.org/~slyfox/ghc-amd64/ghc-bin-${PV}-amd64.tbz2 )"
#arch_binaries="$arch_binaries ia64? ( http://code.haskell.org/~slyfox/ghc-ia64/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
arch_binaries="$arch_binaries ppc? ( mirror://gentoo/ghc-bin-${PV}-ppc.tbz2 )"
-#arch_binaries="$arch_binaries ppc64? ( mirror://gentoo/ghc-bin-${PV}-ppc64.tbz2 )"
+arch_binaries="$arch_binaries ppc64? ( http://code.haskell.org/~slyfox/ghc-ppc64/ghc-bin-${PV}-ppc64.tbz2 )"
arch_binaries="$arch_binaries sparc? ( http://code.haskell.org/~slyfox/ghc-sparc/ghc-bin-${PV}-sparc.tbz2 )"
arch_binaries="$arch_binaries x86? ( http://code.haskell.org/~slyfox/ghc-x86/ghc-bin-${PV}-x86.tbz2 )"
@@ -64,6 +64,9 @@ yet_binary() {
amd64)
return 0
;;
+ ppc64)
+ return 0
+ ;;
sparc)
return 0
;;
@@ -89,7 +92,6 @@ IUSE="doc ghcbootstrap llvm"
IUSE+=" binary" # don't forget about me later!
RDEPEND="
- !dev-lang/ghc-bin
!kernel_Darwin? ( >=sys-devel/gcc-2.95.3 )
kernel_linux? ( >=sys-devel/binutils-2.17 )
kernel_SunOS? ( >=sys-devel/binutils-2.17 )