summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Snelham <zeypher@gentoo.org>2006-11-14 21:45:10 +0000
committerMatthew Snelham <zeypher@gentoo.org>2006-11-14 21:45:10 +0000
commit30615561361678953a89d48c0319dd31c34ad829 (patch)
tree034838f070f4de7cb273c7814d176fe1503e98a5 /dev-lang
parentKeywording ~amd64. (diff)
downloadgentoo-2-30615561361678953a89d48c0319dd31c34ad829.tar.gz
gentoo-2-30615561361678953a89d48c0319dd31c34ad829.tar.bz2
gentoo-2-30615561361678953a89d48c0319dd31c34ad829.zip
Version bump. Added pkg_nofetch, closes #66514
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/icc/ChangeLog8
-rw-r--r--dev-lang/icc/files/9.1.044/05icc-ifc7
-rw-r--r--dev-lang/icc/files/9.1.044/icc10
-rw-r--r--dev-lang/icc/files/9.1.044/icpc10
-rw-r--r--dev-lang/icc/files/digest-icc-9.1.0443
-rw-r--r--dev-lang/icc/icc-9.1.044.ebuild136
6 files changed, 173 insertions, 1 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index 5eb4b0bde7d2..b2d264316cf9 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/icc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.33 2006/08/28 09:14:45 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.34 2006/11/14 21:45:09 zeypher Exp $
+
+*icc-9.1.044 (14 Nov 2006)
+
+ 14 Nov 2006; <zeypher@gentoo.org> +files/9.1.044/05icc-ifc,
+ +files/9.1.044/icc, +files/9.1.044/icpc, +icc-9.1.044.ebuild:
+ Version bump. Added pkg_nofetch, closes #66514
*icc-9.1.042 (28 Aug 2006)
diff --git a/dev-lang/icc/files/9.1.044/05icc-ifc b/dev-lang/icc/files/9.1.044/05icc-ifc
new file mode 100644
index 000000000000..838b25165f4e
--- /dev/null
+++ b/dev-lang/icc/files/9.1.044/05icc-ifc
@@ -0,0 +1,7 @@
+IA32ROOT=/opt/intel/compiler91
+INTEL_FLEXLM_LICENSE=/opt/intel/compiler91/licenses
+LDPATH=/opt/intel/compiler91/lib
+MANPATH=/opt/intel/compiler91/man
+PATH=/opt/intel/compiler91/bin
+ROOTPATH=/opt/intel/compiler91/bin
+
diff --git a/dev-lang/icc/files/9.1.044/icc b/dev-lang/icc/files/9.1.044/icc
new file mode 100644
index 000000000000..c9cfd8d38086
--- /dev/null
+++ b/dev-lang/icc/files/9.1.044/icc
@@ -0,0 +1,10 @@
+#! /bin/sh
+#
+# Gentoo-specific wrapper script for the Intel C/C++ compilers
+#
+# Maintainer: Karl Trygve Kalleberg <karltk@gentoo.org>
+#
+
+export INTEL_LICENSE_FILE="/opt/intel/compiler91/licenses"
+export LD_LIBRARY_PATH="/opt/intel/compiler91/lib"
+/opt/intel/compiler91/bin/iccbin $*
diff --git a/dev-lang/icc/files/9.1.044/icpc b/dev-lang/icc/files/9.1.044/icpc
new file mode 100644
index 000000000000..728e244c585d
--- /dev/null
+++ b/dev-lang/icc/files/9.1.044/icpc
@@ -0,0 +1,10 @@
+#! /bin/sh
+#
+# Gentoo-specific wrapper script for Intel C/C++ compiler suite
+#
+# Maintainer: Karl Trygve Kalleberg <karltk@gentoo.org>
+#
+
+export INTEL_LICENSE_FILE="/opt/intel/compiler91/licenses"
+export LD_LIBRARY_PATH="/opt/intel/compiler91/lib"
+/opt/intel/compiler91/bin/icpcbin $*
diff --git a/dev-lang/icc/files/digest-icc-9.1.044 b/dev-lang/icc/files/digest-icc-9.1.044
new file mode 100644
index 000000000000..2a093d144b1e
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-9.1.044
@@ -0,0 +1,3 @@
+MD5 8a9df589a573cf975b17a53236238e4b l_cc_c_9.1.044.tar.gz 292700142
+RMD160 8895b76bf238bebb843c545e5cf9912e70b8ea87 l_cc_c_9.1.044.tar.gz 292700142
+SHA256 88f0b141e8fdf32022d094403f12950f3f8f82678535043b6edb0dfba94c0a3f l_cc_c_9.1.044.tar.gz 292700142
diff --git a/dev-lang/icc/icc-9.1.044.ebuild b/dev-lang/icc/icc-9.1.044.ebuild
new file mode 100644
index 000000000000..1d98a858afbd
--- /dev/null
+++ b/dev-lang/icc/icc-9.1.044.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-9.1.044.ebuild,v 1.1 2006/11/14 21:45:09 zeypher Exp $
+
+inherit rpm versionator
+
+MAJOR=$(get_major_version ${PV})
+MINOR=$(get_version_component_range 2 ${PV})
+
+DESCRIPTION="Intel C++ Compiler - Intel's optimized compiler for Linux"
+SRC_URI="l_cc_c_${PV}.tar.gz"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+LICENSE="icc-9.0"
+RDEPEND=">=sys-libs/glibc-2.2.5"
+SLOT="${MAJOR}.${MINOR}"
+MMV="${MAJOR}.${MINOR}"
+KEYWORDS="~amd64 ~x86 ~ia64"
+IUSE=""
+RESTRICT="nostrip fetch"
+S="${WORKDIR}/l_cc_c_${PV}"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from "
+ einfo "${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S} || die
+
+ # The tarball contains rpms for multiple arches, and a lot of
+ # auxiliary rpms common across arches. We must throw away
+ # the arch we're not.
+ case ${ARCH} in
+ amd64)
+ rm -f data/intel-*.{i386,ia64}.rpm
+ ;;
+ ia64)
+ rm -f data/intel-*.{em64t,i386}.rpm
+ ;;
+ x86)
+ rm -f data/intel-*.{em64t,ia64}.rpm
+ ;;
+ esac
+
+ for x in *.rpm
+ do
+ # WORKDIR must be set properly for rpm_unpack()
+ rpm_unpack ${S}/data/${x}
+ done
+
+}
+
+src_compile() {
+ instdir=/opt/intel/compiler${MMV//.}
+
+ for x in opt/intel/*/*/bin/* ; do
+ sed "s|<INSTALLDIR>|${instdir}|g" -i $x
+ done
+
+ # == SRC_BASE
+ eval `grep "^[ ]*PACKAGEID=" ${S}/install.sh`
+
+ # From UNTAG_SUPPORT() in 'install.sh'
+ SUPPORTFILE=${S}/opt/intel/cc*/${MMV}*/doc/csupport
+ if [ -f ${SUPPORTFILE} ]
+ then
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<installpackageid\>@${PACKAGEID}@g ${SUPPORTFILE} > ${SUPPORTFILE}.abs
+ mv ${SUPPORTFILE}.abs ${SUPPORTFILE}
+ chmod 644 ${SUPPORTFILE}
+ fi
+
+ # From UNTAG_SUPPORT_IDB() in 'install.sh'
+ SUPPORTFILE=${S}/opt/intel/idb*/${MMV}*/doc/idbsupport
+ if [ -f ${SUPPORTFILE} ]
+ then
+ einfo "Untagging: ${SUPPORTFILE}"
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@${PACKAGEID}@g ${SUPPORTFILE} > ${SUPPORTFILE}.abs
+ mv ${SUPPORTFILE}.abs ${SUPPORTFILE}
+ chmod 644 ${SUPPORTFILE}
+ fi
+
+ # These should not be executable
+ find "${S}"/opt/intel/cc*/${MMV}*/{doc,man,include} -type f -exec chmod -x "{}" ";"
+ find "${S}"/opt/intel/cc*/${MMV}*/lib -name \*.a -exec chmod -x "{}" ";"
+ find "${S}"/opt/intel/idb*/${MMV}*/{doc,man} -type f -exec chmod -x "{}" ";"
+}
+
+src_install () {
+ instdir=/opt/intel/compiler${MMV//.}
+ dodoc ${S}/licenses/lgpltext
+ dodoc ${S}/clicense
+ dodir ${instdir}
+ cp -pPR opt/intel/cc*/${MMV}*/* ${D}/${instdir}
+ cp -pPR opt/intel/idb*/${MMV}*/* ${D}/${instdir}
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc || die
+ exeinto ${instdir}/bin
+ doexe ${FILESDIR}/${PVR}/icc || die
+ doexe ${FILESDIR}/${PVR}/icpc || die
+}
+
+pkg_postinst () {
+ instdir=/opt/intel/compiler${MMV//.}
+
+ einfo "http://www.intel.com/software/products/compilers/clin/noncom.htm"
+ einfo "From the above url you can get a free, non-commercial"
+ einfo "license to use the Intel C++ Compiler emailed to you."
+ einfo "You cannot run icc without this license file."
+ einfo "Read the website for more information on this license."
+ einfo
+ einfo "Documentation can be found in ${instdir}/doc/"
+ einfo
+ einfo "You will need to place your license in ${instdir}/licenses/"
+ einfo
+
+ ewarn
+ ewarn "Packages compiled with versions of icc older than 8.0 will need"
+ ewarn "to be recompiled. Until you do that, old packages will"
+ ewarn "work if you edit /etc/ld.so.conf and change '${instdir}'"
+ ewarn "to '/opt/intel/compiler70' and run 'ldconfig.' Note that this edit"
+ ewarn "won't persist and will require you to re-edit after each"
+ ewarn "package you re-install."
+ ewarn "BEFORE COMPILING IMPORTANT APPLICATIONS THAT YOUR"
+ ewarn "SYSTEM DEPENDS ON, READ THE WARNING ABOVE."
+ ewarn "THIS COULD RENDER YOUR SYSTEM UNUSABLE."
+ ewarn "THIS IS A PROBLEM WITH INTEL'S SOFTWARE, _NOT_"
+ ewarn "WITH GENTOO."
+
+ ewarn "If 'icc' breaks, use 'iccbin' instead and report a bug."
+ ewarn "Please use 'source /etc/profile' prior to merging any icc-enabled"
+ ewarn "ebuilds."
+}