summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2007-04-22 01:08:13 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2007-04-22 01:08:13 +0000
commit42adb2ca3e866908945a2f8735c8ade2249cbe1d (patch)
tree3b3fb57604ab6e36745bda1ba40e68ca5cc6aeb2 /dev-lang
parentManual Manifest commit. (diff)
downloadgentoo-2-42adb2ca3e866908945a2f8735c8ade2249cbe1d.tar.gz
gentoo-2-42adb2ca3e866908945a2f8735c8ade2249cbe1d.tar.bz2
gentoo-2-42adb2ca3e866908945a2f8735c8ade2249cbe1d.zip
Remove macho object format tests in dev-lang/yasm-0.6.0 until fixed upstream. See bug #174020.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yasm/ChangeLog6
-rw-r--r--dev-lang/yasm/yasm-0.6.0.ebuild12
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index 10355bf2b41a..77f675b95331 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/yasm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.12 2007/03/20 01:10:46 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.13 2007/04/22 01:08:13 kugelfang Exp $
+
+ 22 Apr 2007; Danny van Dyk <kugelfang@gentoo.org> yasm-0.6.0.ebuild:
+ Remove macho object format tests in dev-lang/yasm-0.6.0 until fixed
+ upstream. See bug #174020.
*yasm-0.6.0 (20 Mar 2007)
diff --git a/dev-lang/yasm/yasm-0.6.0.ebuild b/dev-lang/yasm/yasm-0.6.0.ebuild
index a171f19b4dd7..146c8a148740 100644
--- a/dev-lang/yasm/yasm-0.6.0.ebuild
+++ b/dev-lang/yasm/yasm-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.6.0.ebuild,v 1.1 2007/03/20 01:10:46 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-0.6.0.ebuild,v 1.2 2007/04/22 01:08:13 kugelfang Exp $
inherit versionator
@@ -16,6 +16,16 @@ IUSE="nls"
RDEPEND="nls? ( virtual/libintl )"
DEPEND="nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Remove macho tests (gas{32,64},nasm{32,64}) until fixed upstream.
+ # Necessary to pass test phase on at least amd64 with gcc-4.1.2.
+ sed -i \
+ -e '/modules\/objfmts\/macho\/tests\/.*\/.*macho.*_test.sh/d' \
+ Makefile.in
+}
+
src_compile() {
econf $(use_enable nls) || die "econf failed"
emake || die "emake failed"