summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Jones <carpaski@gentoo.org>2002-09-08 08:12:25 +0000
committerNicholas Jones <carpaski@gentoo.org>2002-09-08 08:12:25 +0000
commit4772a37e74bef89c8fe3402428fa47caf8a1424a (patch)
tree05d6f92f06eb2072873d4831bd3af10cd31620b4 /dev-lang
parentdev-lang/python-2.2.1-r4 to fix bug 7641 (diff)
downloadgentoo-2-4772a37e74bef89c8fe3402428fa47caf8a1424a.tar.gz
gentoo-2-4772a37e74bef89c8fe3402428fa47caf8a1424a.tar.bz2
gentoo-2-4772a37e74bef89c8fe3402428fa47caf8a1424a.zip
Bug fix for bug #7641
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/files/digest-python-2.2.1-r41
-rw-r--r--dev-lang/python/python-2.2.1-r4.ebuild91
3 files changed, 98 insertions, 1 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 8368c842869e..c73b830e11e2 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.13 2002/09/03 03:21:04 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.14 2002/09/08 08:12:25 carpaski Exp $
+
+*python-2.2.1-r4 (7 Sep 2002)
+ 7 Sep 2002; Nicholas Jones <carpaski@gentoo.org> python-2.2.1-r4.ebuild
+ Fix for bug #7641 -- Fixes the OPT flags in Makefile so that gcc
+ isn't confused by conflicting build types of i386 and user set.
*python-2.2.1-r3 (2 Sep 2002)
2 Sep 2002; Jon Nelson <jnelson@gentoo.org> python-2.2.1-r3.ebuild
diff --git a/dev-lang/python/files/digest-python-2.2.1-r4 b/dev-lang/python/files/digest-python-2.2.1-r4
new file mode 100644
index 000000000000..ea99f8857c06
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.2.1-r4
@@ -0,0 +1 @@
+MD5 e7012d611602b62e36073c2fd02396a3 Python-2.2.1.tgz 6535104
diff --git a/dev-lang/python/python-2.2.1-r4.ebuild b/dev-lang/python/python-2.2.1-r4.ebuild
new file mode 100644
index 000000000000..8ff7a9028602
--- /dev/null
+++ b/dev-lang/python/python-2.2.1-r4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.1-r4.ebuild,v 1.1 2002/09/08 08:12:25 carpaski Exp $
+
+PYVER_MAJOR="`echo ${PV} | cut -d '.' -f 1`"
+PYVER_MINOR="`echo ${PV} | cut -d '.' -f 2`"
+PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
+S=${WORKDIR}/Python-${PV}
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz"
+
+HOMEPAGE="http://www.python.org"
+LICENSE="PSF-2.2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ berkdb? ( >=sys-libs/db-3 )
+ tcltk? ( >=dev-lang/tk-8.0 )"
+if [ -z "`use build`" -a -z "`use bootstrap`" ]; then
+ DEPEND="$DEPEND dev-libs/expat"
+fi
+RDEPEND="$DEPEND dev-python/python-fchksum"
+
+# The dev-python/python-fchksum RDEPEND is needed to that this python provides
+# the functionality expected from previous pythons.
+
+PROVIDE="virtual/python"
+
+SLOT="2.2"
+
+inherit flag-o-matic
+
+src_compile() {
+ filter-flags -malign-double
+ export OPT="$CFLAGS"
+
+ # adjust makefile to install pydoc into ${D} correctly
+ t=${S}/Makefile.pre.in
+ cp $t $t.orig || die
+ sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
+
+ local myopts
+ #if we are creating a new build image, we remove the dependency on g++
+ if [ "`use build`" -a ! "`use bootstrap`" ]
+ then
+ myopts="--with-cxx=no"
+ fi
+
+ econf --with-fpectl \
+ --infodir='${prefix}'/share/info \
+ --mandir='${prefix}'/share/man \
+ $myopts || die
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+ dodir /usr
+ make install prefix=${D}/usr || die
+ rm "${D}/usr/bin/python"
+ dosym python${PYVER_MAJOR} /usr/bin/python
+ dosym python${PYVER_MAJOR}.${PYVER_MINOR} /usr/bin/python${PYVER_MAJOR}
+ dodoc README
+
+ # install our own custom python-config
+ exeinto /usr/bin
+ newexe ${FILESDIR}/python-config-${PV} python-config
+
+ # seems like the build do not install Makefile.pre.in anymore
+ # it probably shouldn't - use DistUtils, people!
+ insinto /usr/lib/python${PYVER}/config
+ doins ${S}/Makefile.pre.in
+
+ # While we're working on the config stuff... Let's fix the OPT var
+ # so that it doesn't have any opts listed in it. Prevents the problem
+ # with compiling things with conflicting opts later.
+ mv \
+ ${D}/usr/lib/python${PYVER}/config/Makefile \
+ ${D}/usr/lib/python${PYVER}/config/Makefile.orig
+ sed 's:^OPT=.*:OPT=-NDEBUG:' \
+ < ${D}/usr/lib/python${PYVER}/config/Makefile.orig \
+ > ${D}/usr/lib/python${PYVER}/config/Makefile
+
+ # If USE tcltk lets install idle
+ # Need to script the python version in the path
+ if use tcltk; then
+ mkdir "${D}/usr/lib/python${PYVER}/tools"
+ mv "${S}/Tools/idle" "${D}/usr/lib/python${PYVER}/tools/"
+ dosym /usr/lib/python${PYVER}/tools/idle/idle.py /usr/bin/idle.py
+ fi
+}