summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-11-14 18:27:03 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-11-14 18:27:03 +0000
commit51852b004ce858f7ae2d4b0302234be95eb1ca0d (patch)
tree58cda96f6b2de63a7277efcbc2e8947332d4c9af /dev-lang
parentalpha/ia64 stable (bug #338652) (diff)
downloadgentoo-2-51852b004ce858f7ae2d4b0302234be95eb1ca0d.tar.gz
gentoo-2-51852b004ce858f7ae2d4b0302234be95eb1ca0d.tar.bz2
gentoo-2-51852b004ce858f7ae2d4b0302234be95eb1ca0d.zip
Version bump. Improvements to the .gir reader, bug fixes and bindings updates.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/vala/ChangeLog8
-rw-r--r--dev-lang/vala/vala-0.11.2.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-lang/vala/ChangeLog b/dev-lang/vala/ChangeLog
index 4d80d712b0aa..826d72466baa 100644
--- a/dev-lang/vala/ChangeLog
+++ b/dev-lang/vala/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/vala
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.30 2010/10/27 20:59:13 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.31 2010/11/14 18:27:03 eva Exp $
+
+*vala-0.11.2 (14 Nov 2010)
+
+ 14 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org> +vala-0.11.2.ebuild:
+ Version bump. Improvements to the .gir reader, bug fixes and bindings
+ updates.
*vala-0.11.1 (27 Oct 2010)
diff --git a/dev-lang/vala/vala-0.11.2.ebuild b/dev-lang/vala/vala-0.11.2.ebuild
new file mode 100644
index 000000000000..8bab3e3bbab5
--- /dev/null
+++ b/dev-lang/vala/vala-0.11.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.11.2.ebuild,v 1.1 2010/11/14 18:27:03 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Vala - Compiler for the GObject type system"
+HOMEPAGE="http://live.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.12"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test +vapigen coverage"
+
+RDEPEND=">=dev-libs/glib-2.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ || ( sys-devel/bison dev-util/byacc dev-util/yacc )
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-unversioned
+ $(use_enable vapigen)
+ $(use_enable coverage)"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+ if use coverage && has ccache ${FEATURES}; then
+ ewarn "USE=coverage does not work well with ccache; valac and libvala"
+ ewarn "built with ccache and USE=coverage create temporary files inside"
+ ewarn "CCACHE_DIR and mess with ccache's working, as well as causing"
+ ewarn "sandbox violations when used to compile other packages."
+ ewarn "It is STRONGLY recommended that you disable one of them."
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+ mv "${ED}"/usr/share/aclocal/vala.m4 \
+ "${ED}"/usr/share/aclocal/vala-${SLOT/./-}.m4 || die "failed to move vala m4 macro"
+ find "${ED}" -name "*.la" -delete || die "la file removal failed"
+}