summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2010-07-25 17:16:24 +0000
committerNed Ludd <solar@gentoo.org>2010-07-25 17:16:24 +0000
commit597f80ae76da957acfa16997b6901bb8575f852c (patch)
treea25d6980a8882b09f54122171b50b5b558358738 /dev-lang
parentia64/s390/sh/sparc stable wrt #326251 (diff)
downloadgentoo-2-597f80ae76da957acfa16997b6901bb8575f852c.tar.gz
gentoo-2-597f80ae76da957acfa16997b6901bb8575f852c.tar.bz2
gentoo-2-597f80ae76da957acfa16997b6901bb8575f852c.zip
- The Modules/_ctypes/malloc_closure.c misuses a mmap() call trying to set a mem segment to rwx when it does not need it. Bug 329499
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.6.4-r1.ebuild5
-rw-r--r--dev-lang/python/python-2.6.5-r2.ebuild5
-rw-r--r--dev-lang/python/python-2.6.5-r3.ebuild5
-rw-r--r--dev-lang/python/python-2.7.ebuild5
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild4
-rw-r--r--dev-lang/python/python-3.1.2-r4.ebuild4
7 files changed, 29 insertions, 7 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 240b14f0580f..437115557650 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.482 2010/07/22 16:34:47 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.483 2010/07/25 17:16:24 solar Exp $
+
+ 25 Jul 2010; <solar@gentoo.org> python-2.6.4-r1.ebuild,
+ python-2.6.5-r2.ebuild, python-2.6.5-r3.ebuild, python-2.7.ebuild,
+ python-3.1.2-r3.ebuild, python-3.1.2-r4.ebuild:
+ - The Modules/_ctypes/malloc_closure.c misuses a mmap() call trying to set
+ a mem segment to rwx when it does not need it. Bug 329499
22 Jul 2010; Markus Meier <maekke@gentoo.org> python-2.6.5-r2.ebuild:
arm stable, bug #319723
diff --git a/dev-lang/python/python-2.6.4-r1.ebuild b/dev-lang/python/python-2.6.4-r1.ebuild
index 41d50d9f0cd9..39d69d0dc48d 100644
--- a/dev-lang/python/python-2.6.4-r1.ebuild
+++ b/dev-lang/python/python-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.12 2010/05/25 17:09:38 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.13 2010/07/25 17:16:24 solar Exp $
EAPI="2"
@@ -104,6 +104,9 @@ src_prepare() {
# that stdin is a tty for bug #248081.
sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
+ # python ctypes abuse mmap perms incorrectly. This breaks PaX
+ sed -i -e s/'PROT_READ | PROT_WRITE | PROT_EXEC'/'PROT_READ | PROT_WRITE'/g Modules/_ctypes/malloc_closure.c
+
eautoreconf
}
diff --git a/dev-lang/python/python-2.6.5-r2.ebuild b/dev-lang/python/python-2.6.5-r2.ebuild
index fa326a40dc3c..dec718b6d6d5 100644
--- a/dev-lang/python/python-2.6.5-r2.ebuild
+++ b/dev-lang/python/python-2.6.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.15 2010/07/22 16:34:47 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.16 2010/07/25 17:16:23 solar Exp $
EAPI="2"
@@ -102,6 +102,9 @@ src_prepare() {
# that stdin is a tty for bug #248081.
sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
+ # python ctypes abuse mmap perms incorrectly. This breaks PaX
+ sed -i -e s/'PROT_READ | PROT_WRITE | PROT_EXEC'/'PROT_READ | PROT_WRITE'/g Modules/_ctypes/malloc_closure.c
+
eautoreconf
}
diff --git a/dev-lang/python/python-2.6.5-r3.ebuild b/dev-lang/python/python-2.6.5-r3.ebuild
index 2d407ff49a85..598a6455610f 100644
--- a/dev-lang/python/python-2.6.5-r3.ebuild
+++ b/dev-lang/python/python-2.6.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r3.ebuild,v 1.1 2010/07/12 19:11:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r3.ebuild,v 1.2 2010/07/25 17:16:24 solar Exp $
EAPI="2"
@@ -102,6 +102,9 @@ src_prepare() {
# that stdin is a tty for bug #248081.
sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
+ # python ctypes abuse mmap perms incorrectly. This breaks PaX
+ sed -i -e s/'PROT_READ | PROT_WRITE | PROT_EXEC'/'PROT_READ | PROT_WRITE'/g Modules/_ctypes/malloc_closure.c
+
eautoreconf
}
diff --git a/dev-lang/python/python-2.7.ebuild b/dev-lang/python/python-2.7.ebuild
index dc4096ce9648..27f30f2e6773 100644
--- a/dev-lang/python/python-2.7.ebuild
+++ b/dev-lang/python/python-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.ebuild,v 1.2 2010/07/10 13:06:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.ebuild,v 1.3 2010/07/25 17:16:24 solar Exp $
EAPI="2"
@@ -107,6 +107,9 @@ src_prepare() {
# Support versions of Autoconf other than 2.65.
sed -e "/version_required(2\.65)/d" -i configure.in || die "sed failed"
+
+ # python ctypes abuse mmap perms incorrectly. This breaks PaX
+ sed -i -e s/'PROT_READ | PROT_WRITE | PROT_EXEC'/'PROT_READ | PROT_WRITE'/g Modules/_ctypes/malloc_closure.c
}
src_configure() {
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index 5882103fd5c2..d4ee894f626c 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.14 2010/07/18 12:42:52 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.15 2010/07/25 17:16:24 solar Exp $
EAPI="3"
@@ -89,6 +89,8 @@ src_prepare() {
# that stdin is a tty for bug #248081.
sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" -i Lib/test/test_file.py || die "sed failed"
+ # python ctypes abuse mmap perms incorrectly. This breaks PaX
+ sed -i -e s/'PROT_READ | PROT_WRITE | PROT_EXEC'/'PROT_READ | PROT_WRITE'/g Modules/_ctypes/malloc_closure.c
eautoreconf
}
diff --git a/dev-lang/python/python-3.1.2-r4.ebuild b/dev-lang/python/python-3.1.2-r4.ebuild
index 192922b9abad..a8e372e93fb4 100644
--- a/dev-lang/python/python-3.1.2-r4.ebuild
+++ b/dev-lang/python/python-3.1.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r4.ebuild,v 1.3 2010/07/17 22:56:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r4.ebuild,v 1.4 2010/07/25 17:16:23 solar Exp $
EAPI="3"
@@ -95,6 +95,8 @@ src_prepare() {
# Fix parallel installation (bug #328009).
sed -e "s/^sharedinstall:/& sharedmods/" -i Makefile.pre.in || die "sed failed"
+ # python ctypes abuse mmap perms incorrectly. This breaks PaX
+ sed -i -e s/'PROT_READ | PROT_WRITE | PROT_EXEC'/'PROT_READ | PROT_WRITE'/g Modules/_ctypes/malloc_closure.c
eautoreconf
}