summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-12 19:31:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-12 19:31:03 +0000
commit62712526ded90b7ed82db6a2b499349beb8547b2 (patch)
tree031685c5f17e4be75b7df4d0503eef60691822f5 /dev-lang
parentDrop ia64 keyword (diff)
downloadgentoo-2-62712526ded90b7ed82db6a2b499349beb8547b2.tar.gz
gentoo-2-62712526ded90b7ed82db6a2b499349beb8547b2.tar.bz2
gentoo-2-62712526ded90b7ed82db6a2b499349beb8547b2.zip
work around parallel-build issues and use the upstream makefiles for more (bug #284535)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nasm/ChangeLog6
-rw-r--r--dev-lang/nasm/nasm-2.07.ebuild13
2 files changed, 10 insertions, 9 deletions
diff --git a/dev-lang/nasm/ChangeLog b/dev-lang/nasm/ChangeLog
index 302f245a7af5..410cb2d829b9 100644
--- a/dev-lang/nasm/ChangeLog
+++ b/dev-lang/nasm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/nasm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.59 2009/08/14 20:35:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/ChangeLog,v 1.60 2009/09/12 19:31:03 mr_bones_ Exp $
+
+ 12 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org> nasm-2.07.ebuild:
+ work around parallel-build issues and use the upstream makefiles for more
+ (bug #284535)
14 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org> -nasm-2.04.ebuild,
-nasm-2.05.01.ebuild:
diff --git a/dev-lang/nasm/nasm-2.07.ebuild b/dev-lang/nasm/nasm-2.07.ebuild
index a4bfe3222299..aeff8d8a0c04 100644
--- a/dev-lang/nasm/nasm-2.07.ebuild
+++ b/dev-lang/nasm/nasm-2.07.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.07.ebuild,v 1.2 2009/08/14 20:33:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.07.ebuild,v 1.3 2009/09/12 19:31:03 mr_bones_ Exp $
EAPI=2
inherit autotools eutils toolchain-funcs flag-o-matic
@@ -26,18 +26,15 @@ src_configure() {
}
src_compile() {
- emake all || die "emake failed"
- emake rdf || die "emake failed"
+ emake nasmlib.o || die
+ emake all || die
if use doc ; then
- emake doc || die "emake failed"
+ emake doc || die
fi
}
src_install() {
- dobin nasm ndisasm rdoff/{ldrdf,rdf2bin,rdf2ihx,rdfdump,rdflib,rdx} \
- || die "dobin failed"
- dosym /usr/bin/rdf2bin /usr/bin/rdf2com
- doman nasm.1 ndisasm.1
+ emake INSTALLROOT="${D}" install install_rdf || die
dodoc AUTHORS CHANGES ChangeLog README TODO
if use doc ; then
doinfo doc/info/*