summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2004-08-21 19:04:41 +0000
committerChris White <chriswhite@gentoo.org>2004-08-21 19:04:41 +0000
commit6e5d31d02040f0f7f276ba3f59ac15c7a2ba4706 (patch)
treed8e3eb28fa0f6f8bd0f784fdc2dba01805fd2c04 /dev-lang
parent60844 (Manifest recommit) (diff)
downloadgentoo-2-6e5d31d02040f0f7f276ba3f59ac15c7a2ba4706.tar.gz
gentoo-2-6e5d31d02040f0f7f276ba3f59ac15c7a2ba4706.tar.bz2
gentoo-2-6e5d31d02040f0f7f276ba3f59ac15c7a2ba4706.zip
<fpc-source> I don't like anything above -j1. <ChrisWhite> why me! Fixing some parallel make borkage.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/fpc-source/ChangeLog6
-rw-r--r--dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-lang/fpc-source/ChangeLog b/dev-lang/fpc-source/ChangeLog
index b98cbad2ccfd..4659ede727e8 100644
--- a/dev-lang/fpc-source/ChangeLog
+++ b/dev-lang/fpc-source/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/fpc-source
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-source/ChangeLog,v 1.2 2004/08/21 18:18:46 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-source/ChangeLog,v 1.3 2004/08/21 19:04:41 chriswhite Exp $
+
+ 22 Aug 2004; Chris White <chriswhite@gentoo.org>
+ fpc-source-1.9.5_pre20040820.ebuild:
+ Changed to emake -j1 since the makefile apparently doesn't like parallel makes.
22 Aug 2004; Chris White <chriswhite@gentoo.org>
fpc-source-1.9.5_pre20040820.ebuild:
diff --git a/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild b/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild
index c350ed6b7dda..86441f786b44 100644
--- a/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild
+++ b/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild,v 1.2 2004/08/21 18:18:46 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-source/fpc-source-1.9.5_pre20040820.ebuild,v 1.3 2004/08/21 19:04:41 chriswhite Exp $
inherit eutils
@@ -21,7 +21,8 @@ src_compile() {
cd ${S}
einfo "Building the fpc compiler and units"
- emake \
+ # have to use -j1 as it doesn't seem to like -j2+
+ emake -j1 \
build \
OS_TARGET=linux \
PP=${S}/ppc386 \
@@ -32,7 +33,7 @@ src_compile() {
src_install() {
einfo "Installing the fpc compiler and units"
- emake \
+ emake -j1 \
install \
OS_TARGET=linux \
PP=${S}/ppc386 \