summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-28 06:06:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-28 06:06:49 +0000
commit712f5c74a28a9af402670952c0d9b14fd7a1c968 (patch)
tree4aab4117b1391a8056c7661fd9eeb1e91986884a /dev-lang
parentdont use $CC (diff)
downloadgentoo-2-712f5c74a28a9af402670952c0d9b14fd7a1c968.tar.gz
gentoo-2-712f5c74a28a9af402670952c0d9b14fd7a1c968.tar.bz2
gentoo-2-712f5c74a28a9af402670952c0d9b14fd7a1c968.zip
dont use $CC
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog5
-rw-r--r--dev-lang/perl/perl-5.8.2-r1.ebuild32
-rw-r--r--dev-lang/perl/perl-5.8.3.ebuild32
-rw-r--r--dev-lang/tolua/tolua-5.0.ebuild10
4 files changed, 38 insertions, 41 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 3bf5a905827b..a0184dc3ca77 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.56 2004/02/27 20:35:59 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.57 2004/04/28 06:06:08 vapier Exp $
+
+ 28 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Clean up `use` syntax and remove ${CC} usage.
27 Feb 2004; Michael Cummings <mcummings@gentoo.org> perl-5.6.1-r10.ebuild,
perl-5.6.1-r11.ebuild, perl-5.6.1-r12.ebuild:
diff --git a/dev-lang/perl/perl-5.8.2-r1.ebuild b/dev-lang/perl/perl-5.8.2-r1.ebuild
index c531d174d8c3..fbcd0359bfca 100644
--- a/dev-lang/perl/perl-5.8.2-r1.ebuild
+++ b/dev-lang/perl/perl-5.8.2-r1.ebuild
@@ -1,13 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.9 2004/02/19 22:31:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.10 2004/04/28 06:06:08 vapier Exp $
-inherit eutils flag-o-matic
-
-# Perl has problems compiling with -Os in your flags
-replace-flags "-Os" "-O2"
-# This flag makes compiling crash in interesting ways
-filter-flags -malign-double
+inherit eutils flag-o-matic gcc
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
@@ -41,7 +36,7 @@ RDEPEND="berkdb? ( sys-libs/db )
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -72,7 +67,6 @@ pkg_setup() {
}
src_unpack() {
-
unpack ${A}
# Get -lpthread linked before -lc. This is needed
@@ -103,11 +97,15 @@ src_unpack() {
}
src_compile() {
+ # Perl has problems compiling with -Os in your flags
+ replace-flags "-Os" "-O2"
+ # This flag makes compiling crash in interesting ways
+ filter-flags -malign-double
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -117,11 +115,11 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db"
@@ -139,23 +137,23 @@ src_compile() {
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc`" ]
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64`" ]
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use alpha`" -a "${CC}" == "ccc" ]
+ if use alpha && "$(gcc-getCC)" == "ccc"
then
ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
myconf="${myconf} -Ui_db -Ui_ndbm"
@@ -320,5 +318,3 @@ pkg_postinst() {
eerror ""
eerror ""
}
-
-
diff --git a/dev-lang/perl/perl-5.8.3.ebuild b/dev-lang/perl/perl-5.8.3.ebuild
index 274673e8440d..db7d5dd0bb6b 100644
--- a/dev-lang/perl/perl-5.8.3.ebuild
+++ b/dev-lang/perl/perl-5.8.3.ebuild
@@ -1,13 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.3.ebuild,v 1.3 2004/04/24 08:33:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.3.ebuild,v 1.4 2004/04/28 06:06:08 vapier Exp $
-inherit eutils flag-o-matic
-
-# Perl has problems compiling with -Os in your flags
-replace-flags "-Os" "-O2"
-# This flag makes compiling crash in interesting ways
-filter-flags -malign-double
+inherit eutils flag-o-matic gcc
# The slot of this binary compat version of libperl.so
PERLSLOT="1"
@@ -41,7 +36,7 @@ RDEPEND="berkdb? ( sys-libs/db )
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -72,7 +67,6 @@ pkg_setup() {
}
src_unpack() {
-
unpack ${A}
# Get -lpthread linked before -lc. This is needed
@@ -103,11 +97,15 @@ src_unpack() {
}
src_compile() {
+ # Perl has problems compiling with -Os in your flags
+ replace-flags "-Os" "-O2"
+ # This flag makes compiling crash in interesting ways
+ filter-flags -malign-double
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -117,11 +115,11 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db"
@@ -139,23 +137,23 @@ src_compile() {
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use alpha`" -a "${CC}" == "ccc" ]
+ if use alpha && "$(gcc-getCC)" == "ccc"
then
ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
myconf="${myconf} -Ui_db -Ui_ndbm"
@@ -320,5 +318,3 @@ pkg_postinst() {
eerror ""
eerror ""
}
-
-
diff --git a/dev-lang/tolua/tolua-5.0.ebuild b/dev-lang/tolua/tolua-5.0.ebuild
index dfc53eb2511e..b066995a9101 100644
--- a/dev-lang/tolua/tolua-5.0.ebuild
+++ b/dev-lang/tolua/tolua-5.0.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/tolua-5.0.ebuild,v 1.4 2004/04/19 02:05:56 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tolua/tolua-5.0.ebuild,v 1.5 2004/04/28 06:06:49 vapier Exp $
+
+inherit gcc
DESCRIPTION="a tool that simplifies the integration of C/C++ code with Lua"
HOMEPAGE="http://www.tecgraf.puc-rio.br/~celes/tolua/"
SRC_URI="ftp://ftp.tecgraf.puc-rio.br/pub/users/celes/tolua/${P}.tar.gz"
-KEYWORDS="x86 ~sparc"
LICENSE="as-is"
SLOT="0"
+KEYWORDS="x86 ~sparc"
IUSE=""
DEPEND=">=sys-apps/sed-4"
@@ -18,7 +20,7 @@ src_unpack() {
cd ${S}
sed -i \
- -e "/^CC=/ s/=.*/=${CC}/" \
+ -e "/^CC=/ s/=.*/=$(gcc-getCC)/" \
-e "/^LUA=/ s:=.*:=/usr:" \
-e 's/^\(LIB=.*\)/\1 -ldl/' \
-e "s:-O2:${CFLAGS}:" config || \
@@ -33,7 +35,7 @@ src_compile() {
}
src_install() {
- dobin bin/tolua
+ dobin bin/tolua || die
dolib.a lib/libtolua.a
insinto /usr/include
doins include/tolua.h