summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-09-07 02:48:43 +0000
committerJason Wever <weeve@gentoo.org>2003-09-07 02:48:43 +0000
commit73bd8aaaea20e4a75e51462a0fb0cca8f8502b6a (patch)
treef8726bec0382b2ae94e7a61945e092a369317378 /dev-lang
parentrepoman: whitespace cleanup (diff)
downloadgentoo-2-73bd8aaaea20e4a75e51462a0fb0cca8f8502b6a.tar.gz
gentoo-2-73bd8aaaea20e4a75e51462a0fb0cca8f8502b6a.tar.bz2
gentoo-2-73bd8aaaea20e4a75e51462a0fb0cca8f8502b6a.zip
Added patch and myconf fix to fix bug #23767.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/Manifest9
-rw-r--r--dev-lang/ocaml/files/ocaml-3.06-sparc-configure.patch39
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r1.ebuild11
-rw-r--r--dev-lang/ocaml/ocaml-3.06.ebuild12
5 files changed, 70 insertions, 7 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 3cc3fea86aa8..a045b9075b55 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.11 2003/05/02 08:34:39 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.12 2003/09/07 02:48:39 weeve Exp $
+
+ 06 Sep 2003; Jason Wever <weeve@gentoo.org> ocaml-3.06-r1.ebuild,
+ ocaml-3.06.ebuild, files/ocaml-3.06-sparc-configure.patch:
+ Added patch and myconf fix to fix bug #23767.
01 May 2003; George Shapovalov <george@gentoo.org> ocaml-3.06-r1.ebuild :
updated the ebuild to incorporate the fix for tk-8.4 necessary for lablgl.
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index b8cd74f2d131..ca2318d52adf 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,6 +1,7 @@
-MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
+MD5 df34ec69afe7048abef85c1452ff1c44 ChangeLog 2860
+MD5 223d025c1d6b20eb13cbe6d6b1fa990b ocaml-3.06-r1.ebuild 1445
+MD5 e85fd8053cc693729f0740b2ac855a44 ocaml-3.06.ebuild 1377
MD5 30ac0d14e37ff0be57927d84e4e7e1c6 files/digest-ocaml-3.06 197
+MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
MD5 4df214d6cd74b3c5955d868879dd6cc7 files/ocaml-3.06-tcltk-8.4compat-patch.bz2 639
-MD5 de02ce5864fa2bb31dd85e3c3d834f9d ocaml-3.06-r1.ebuild 1204
-MD5 5fc405dd9f814bb8d792aefc0d54bb1d ocaml-3.06.ebuild 1134
-MD5 44738768a9de3beed1e8944054a23578 ChangeLog 2683
+MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
diff --git a/dev-lang/ocaml/files/ocaml-3.06-sparc-configure.patch b/dev-lang/ocaml/files/ocaml-3.06-sparc-configure.patch
new file mode 100644
index 000000000000..096b5bd8ca13
--- /dev/null
+++ b/dev-lang/ocaml/files/ocaml-3.06-sparc-configure.patch
@@ -0,0 +1,39 @@
+--- ocaml/configure 2003/01/09 12:01:51 1.183
++++ ocaml/configure 2003/03/10 17:04:00 1.184
+@@ -391,17 +391,25 @@ esac
+
+ # Determine alignment constraints
+
+-sh ./runtest dblalign.c
+-case $? in
+- 0) echo "Doubles can be word-aligned."
+- echo "#undef ARCH_ALIGN_DOUBLE" >> m.h;;
+- 1) echo "Doubles must be doubleword-aligned."
+- echo "#define ARCH_ALIGN_DOUBLE" >> m.h;;
+- *) echo "Something went wrong during alignment determination for doubles."
+- echo "I'm going to assume this architecture has alignment constraints over doubles."
+- echo "That's a safe bet: Objective Caml will work even if"
+- echo "this architecture has actually no alignment constraints."
+- echo "#define ARCH_ALIGN_DOUBLE" >> m.h;;
++case "$host" in
++ sparc-*-*)
++ # On Sparc V9 with certain versions of gcc, determination of double
++ # alignment is not reliable (PR#1521), hence force it
++ echo "Doubles must be doubleword-aligned."
++ echo "#define ARCH_ALIGN_DOUBLE" >> m.h;;
++ *)
++ sh ./runtest dblalign.c
++ case $? in
++ 0) echo "Doubles can be word-aligned."
++ echo "#undef ARCH_ALIGN_DOUBLE" >> m.h;;
++ 1) echo "Doubles must be doubleword-aligned."
++ echo "#define ARCH_ALIGN_DOUBLE" >> m.h;;
++ *) echo "Something went wrong during alignment determination for doubles."
++ echo "I'm going to assume this architecture has alignment constraints over doubles."
++ echo "That's a safe bet: Objective Caml will work even if"
++ echo "this architecture has actually no alignment constraints."
++ echo "#define ARCH_ALIGN_DOUBLE" >> m.h;;
++ esac;;
+ esac
+
+ if $int64_native; then
diff --git a/dev-lang/ocaml/ocaml-3.06-r1.ebuild b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
index d760475e22e0..c9a12424b3f7 100644
--- a/dev-lang/ocaml/ocaml-3.06-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r1.ebuild,v 1.2 2003/08/05 16:21:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r1.ebuild,v 1.3 2003/09/07 02:48:39 weeve Exp $
inherit flag-o-matic eutils
filter-flags "-fstack-protector"
@@ -23,6 +23,15 @@ src_compile() {
epatch ${FILESDIR}/ocaml-3.06-tcltk-8.4compat-patch.bz2
+ # Fix for bug #23767
+ if [ "${ARCH}" = "sparc" ]
+ then
+ # We need a patch and to make sure it builds
+ # for the right host type
+ epatch ${FILESDIR}/ocaml-3.06-sparc-configure.patch
+ myconf="${myconfg} -host sparc-unknown-linux-gnu"
+ fi
+
./configure -prefix /usr \
-bindir /usr/bin \
-libdir /usr/lib/ocaml \
diff --git a/dev-lang/ocaml/ocaml-3.06.ebuild b/dev-lang/ocaml/ocaml-3.06.ebuild
index ab35ff84fb00..f09c14cf0adc 100644
--- a/dev-lang/ocaml/ocaml-3.06.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.9 2003/08/05 16:21:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.10 2003/09/07 02:48:39 weeve Exp $
inherit flag-o-matic
filter-flags "-fstack-protector"
@@ -21,6 +21,16 @@ src_compile() {
local myconf
use tcltk || myconf="-no-tk"
+ # Fix for bug #23767
+ if [ "${ARCH}" = "sparc" ]
+ then
+ # We need a patch and to make sure it builds
+ # for the right host type
+ epatch ${FILESDIR}/ocaml-3.06-sparc-configure.patch
+ myconf="${myconfg} -host sparc-unknown-linux-gnu"
+ fi
+
+
./configure -prefix /usr \
-bindir /usr/bin \
-libdir /usr/lib/ocaml \