summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-08 09:26:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-08 09:26:19 +0000
commit992cb8e32745b47fdc6865cd9635b99a421ce9bf (patch)
treee753c17757b1c7c10ab130491b2df1028e8b6384 /dev-lang
parentBump (diff)
downloadgentoo-2-992cb8e32745b47fdc6865cd9635b99a421ce9bf.tar.gz
gentoo-2-992cb8e32745b47fdc6865cd9635b99a421ce9bf.tar.bz2
gentoo-2-992cb8e32745b47fdc6865cd9635b99a421ce9bf.zip
Make repoman more happy
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/opendylan/ChangeLog6
-rw-r--r--dev-lang/opendylan/opendylan-2011.1-r1.ebuild8
-rw-r--r--dev-lang/opendylan/opendylan-2012.1.ebuild10
-rw-r--r--dev-lang/opendylan/opendylan-9999.ebuild14
4 files changed, 22 insertions, 16 deletions
diff --git a/dev-lang/opendylan/ChangeLog b/dev-lang/opendylan/ChangeLog
index dbdf3350aed3..0e156133b36a 100644
--- a/dev-lang/opendylan/ChangeLog
+++ b/dev-lang/opendylan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/opendylan
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/ChangeLog,v 1.7 2013/02/08 09:21:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/ChangeLog,v 1.8 2013/02/08 09:26:19 patrick Exp $
+
+ 08 Feb 2013; Patrick Lauer <patrick@gentoo.org> opendylan-2011.1-r1.ebuild,
+ opendylan-2012.1.ebuild, opendylan-9999.ebuild:
+ Make repoman more happy
*opendylan-2012.1 (08 Feb 2013)
diff --git a/dev-lang/opendylan/opendylan-2011.1-r1.ebuild b/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
index 2d3e3cd3acc1..30f3a3939c98 100644
--- a/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
+++ b/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2011.1-r1.ebuild,v 1.6 2013/02/08 09:21:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2011.1-r1.ebuild,v 1.7 2013/02/08 09:26:19 patrick Exp $
EAPI=4
inherit autotools
@@ -75,8 +75,8 @@ src_configure() {
econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
fi
if use x86; then
- # Includedir, pointing at something wrong
- sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
+ # Includedir, pointing at something wrong
+ sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mmdw.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mpsplan.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
sed -i -e 's~$(MPS_LIB)/mpsplan.a~/usr/lib/mpsplan.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
@@ -93,7 +93,7 @@ src_install() {
ulimit -s 32000 # this is naughty build system
# because of Makefile weirdness it rebuilds quite a bit here
# upstream has been notified
- emake -j1 DESTDIR=${D} install
+ emake -j1 DESTDIR="${D}" install
mkdir -p "${D}/etc/env.d/opendylan/"
echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
}
diff --git a/dev-lang/opendylan/opendylan-2012.1.ebuild b/dev-lang/opendylan/opendylan-2012.1.ebuild
index 38185a5dfdf3..d265e0f649a4 100644
--- a/dev-lang/opendylan/opendylan-2012.1.ebuild
+++ b/dev-lang/opendylan/opendylan-2012.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2012.1.ebuild,v 1.1 2013/02/08 09:21:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2012.1.ebuild,v 1.2 2013/02/08 09:26:19 patrick Exp $
EAPI=4
inherit autotools
@@ -77,8 +77,8 @@ src_configure() {
econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
fi
if use x86; then
- # Includedir, pointing at something wrong
- sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
+ # Includedir, pointing at something wrong
+ sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mmdw.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mpsplan.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
sed -i -e 's~$(MPS_LIB)/mpsplan.a~/usr/lib/mpsplan.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
@@ -88,14 +88,14 @@ src_configure() {
src_compile() {
ulimit -s 32000 # this is naughty build system
- emake DESTDIR=${D} -j1 3-stage-bootstrap || die
+ emake -j1 3-stage-bootstrap || die
}
src_install() {
ulimit -s 32000 # this is naughty build system
# because of Makefile weirdness it rebuilds quite a bit here
# upstream has been notified
- emake -j1 DESTDIR=${D} install
+ emake -j1 DESTDIR="${D}" install
mkdir -p "${D}/etc/env.d/opendylan/"
echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
}
diff --git a/dev-lang/opendylan/opendylan-9999.ebuild b/dev-lang/opendylan/opendylan-9999.ebuild
index 07070f49a355..5cb5fbd4a035 100644
--- a/dev-lang/opendylan/opendylan-9999.ebuild
+++ b/dev-lang/opendylan/opendylan-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-9999.ebuild,v 1.3 2012/08/22 03:42:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-9999.ebuild,v 1.4 2013/02/08 09:26:19 patrick Exp $
EAPI=4
inherit autotools git-2
@@ -32,10 +32,12 @@ src_prepare() {
}
src_configure() {
- if has_version =dev-lang/opendylan-bin-2011.1; then
+ if has_version =dev-lang/opendylan-bin-2012.1; then
+ PATH=/opt/opendylan-2012.1/bin/:$PATH
+ elif has_version =dev-lang/opendylan-bin-2011.1; then
PATH=/opt/opendylan-2011.1/bin/:$PATH
- else
- PATH=/opt/opendylan/bin/:$PATH
+ else
+ PATH=/opt/opendylan/bin/:$PATH
fi
econf --prefix=/opt/opendylan || die
}
@@ -49,7 +51,7 @@ src_install() {
ulimit -s 32000 # this is naughty build system
# because of Makefile weirdness it rebuilds quite a bit here
# upstream has been notified
- emake -j1 DESTDIR=${D} install
+ emake -j1 DESTDIR="${D}" install
mkdir -p "${D}/etc/env.d/opendylan/"
echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/opendylan" || die "Failed to add env settings"
}