summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-20 23:33:08 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-20 23:33:08 +0000
commit9b1ad467e6ee92a6b2a2525b03061c0e039732ff (patch)
tree3b8076c17f73d00a586721ebaf9085125f54eb3f /dev-lang
parentstable x86; bug 167315 (diff)
downloadgentoo-2-9b1ad467e6ee92a6b2a2525b03061c0e039732ff.tar.gz
gentoo-2-9b1ad467e6ee92a6b2a2525b03061c0e039732ff.tar.bz2
gentoo-2-9b1ad467e6ee92a6b2a2525b03061c0e039732ff.zip
version bump which needs fewer patches and fixes, as reported by Christopher Covington <covracer@gmail.com> in bug 167335
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/ChangeLog9
-rw-r--r--dev-lang/erlang/erlang-11.2.3.ebuild156
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.39
-rw-r--r--dev-lang/erlang/files/erl_process_dump_R11B-3.patch24
4 files changed, 197 insertions, 1 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 8353a27f052b..3838d362e759 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.54 2007/01/31 14:28:59 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.55 2007/02/20 23:33:08 opfer Exp $
+
+*erlang-11.2.3 (20 Feb 2007)
+
+ 20 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+ +files/erl_process_dump_R11B-3.patch, +erlang-11.2.3.ebuild:
+ version bump which needs fewer patches and fixes, as reported by Christopher
+ Covington <covracer@gmail.com> in bug 167335
31 Jan 2007; Marius Mauch <genone@gentoo.org> erlang-11.2.1.ebuild,
erlang-11.2.2-r1.ebuild:
diff --git a/dev-lang/erlang/erlang-11.2.3.ebuild b/dev-lang/erlang/erlang-11.2.3.ebuild
new file mode 100644
index 000000000000..f81ce4764ee1
--- /dev/null
+++ b/dev-lang/erlang/erlang-11.2.3.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.3.ebuild,v 1.1 2007/02/20 23:33:08 opfer Exp $
+
+inherit elisp-common eutils flag-o-matic multilib versionator
+
+# NOTE: When bumping you need to adjust the *_VER strings in
+# src_install() to honour newer versions in the package (they
+# are maintained separately upstream). You even need to adjust the version number
+# in the last comment.
+# If you need symlinks for binaries please tell maintainers or open up a bug
+# to let it be created.
+
+# erlang uses a really weird versioning scheme which caused quite a few problems
+# already. Thus we do a slight modification converting all letters to digits to
+# make it more sane (see e.g. #26420)
+
+# the next line selects the right source.
+MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
+
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+ doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+ http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+# Not yet available for 11.2.3
+# http://developer.sipphone.com/ejabberd/erlang_epoll_patch/otp_src_${MY_PV}_epoll.patch"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc emacs hipe java odbc ssl tk"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ emacs? ( virtual/emacs )
+ java? ( >=virtual/jdk-1.2 )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ tk? ( dev-lang/tk )"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+ ## fix compilation on hardened systems, see bug #154338
+ filter-flags "-fstack-protector"
+ filter-flags "-fstack-protector-all"
+
+ unpack ${A}
+ cd "${S}"
+ use odbc || sed -i 's: odbc : :' lib/Makefile
+# epatch "${DISTDIR}"/otp_src_${MY_PV}_epoll.patch
+ epatch "${FILESDIR}/erl_process_dump_R11B-3.patch"
+
+ if use hipe; then
+ ewarn
+ ewarn "You enabled High performance Erlang. Be aware that this extension"
+ ewarn "can break the compilation in many ways, especially on hardened systems."
+ ewarn "Don't cry, don't file bugs, just disable it!"
+ ewarn
+ fi
+}
+
+src_compile() {
+ use java || export JAVAC=false
+
+ econf \
+ --enable-threads \
+ $(use_enable hipe) \
+ $(use_with ssl) \
+ || die "econf failed"
+ make || die "emake failed"
+
+ if use emacs ; then
+ pushd lib/tools/emacs
+ elisp-compile *.el
+ popd
+ fi
+}
+
+extract_version() {
+ sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
+}
+
+src_install() {
+ local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+ local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
+ local ERL_ERTS_VER=$(extract_version erts VSN)
+
+ make INSTALL_PREFIX="${D}" install || die
+ dodoc AUTHORS EPLICENCE README
+
+ dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
+ dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
+ dosym ${ERL_LIBDIR}/bin/ecc /usr/bin/ecc
+ dosym ${ERL_LIBDIR}/bin/elink /usr/bin/elink
+ dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
+ dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
+ dosym \
+ ${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call \
+ /usr/bin/erl_call
+ dosym ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam /usr/bin/beam
+
+ ## Remove ${D} from the following files
+ dosed ${ERL_LIBDIR}/bin/erl
+ dosed ${ERL_LIBDIR}/bin/start
+ cd ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}
+ grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-${ERL_ERTS_VER} | xargs sed -i -e "s:${D}::g"
+
+ ## Clean up the no longer needed files
+ rm "${D}"/${ERL_LIBDIR}/Install
+
+ if use doc ; then
+ for i in "${WORKDIR}"/man/man* ; do
+ dodir /usr/share/${i##${WORKDIR}}erl
+ done
+ for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+ # Avoid namespace collisions
+ local newfile=${file}erl
+ cp ${file} ${newfile}
+ # Man page processing tools expect a capitalized "SEE ALSO" section
+ # header
+ sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${newfile}
+ # doman sucks so we can't use it
+ cp ${newfile} "${D}"/usr/share/man/man${newfile##*.}/
+ done
+ dohtml -A README,erl,hrl,c,h,kwc,info -r \
+ "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+ fi
+
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install erlang lib/tools/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ elog
+ elog "If you need a symlink to one of erlang's binaries,"
+ elog "please open a bug and tell the maintainers."
+ elog
+ elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-3"
+ elog
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.3 b/dev-lang/erlang/files/digest-erlang-11.2.3
new file mode 100644
index 000000000000..ac72be2ef9bb
--- /dev/null
+++ b/dev-lang/erlang/files/digest-erlang-11.2.3
@@ -0,0 +1,9 @@
+MD5 85bc43e52fa5066577ef412c80848dc0 otp_doc_html_R11B-3.tar.gz 4852262
+RMD160 ed61cb47f1632b5e627a213beaa17652da5ab99c otp_doc_html_R11B-3.tar.gz 4852262
+SHA256 01f1625b4d004b2b30c298d12e286ddbf512d316207fb8859ca598f98c553fb2 otp_doc_html_R11B-3.tar.gz 4852262
+MD5 645ef1ded84b470e9c05a4757dce88cf otp_doc_man_R11B-3.tar.gz 694238
+RMD160 d0f016d2388fad5721280b07634fd49c115b0153 otp_doc_man_R11B-3.tar.gz 694238
+SHA256 ec3ff0f2979ba91d485b37a232ad7d2186829f2948a9f7adcd6067890e55f928 otp_doc_man_R11B-3.tar.gz 694238
+MD5 2806e5a2f26cb1b20f3ea1a6f3ec0276 otp_src_R11B-3.tar.gz 11420612
+RMD160 1ba0cc072d6f33e5f12149ae36e24438a9d70199 otp_src_R11B-3.tar.gz 11420612
+SHA256 7024ca196a5e4a2d80363de1af78051b36de47833e848b812656d552baa5dde2 otp_src_R11B-3.tar.gz 11420612
diff --git a/dev-lang/erlang/files/erl_process_dump_R11B-3.patch b/dev-lang/erlang/files/erl_process_dump_R11B-3.patch
new file mode 100644
index 000000000000..2b1b44b3ee4e
--- /dev/null
+++ b/dev-lang/erlang/files/erl_process_dump_R11B-3.patch
@@ -0,0 +1,24 @@
+--- erts/emulator/beam/erl_process_dump.c.orig 2007-02-19 22:20:55.000000000 +0100
++++ erts/emulator/beam/erl_process_dump.c 2007-02-19 22:13:34.000000000 +0100
+@@ -399,9 +399,11 @@
+ static void
+ dump_externally(int to, void *to_arg, Eterm term)
+ {
+- byte sbuf[1024]; /* encode and hope for the best ... */
+- byte* s;
+- byte* p;
++ byte *sbuf, *s, *p;
++ unsigned size;
++
++ size = encode_size_struct(term, TERM_TO_BINARY_DFLAGS);
++ sbuf = (byte *) erts_alloc(ERTS_ALC_T_TMP, size);
+
+ s = p = sbuf;
+ erts_to_external_format(NULL, term, &p, NULL, NULL);
+@@ -409,4 +411,6 @@
+ while (s < p) {
+ erts_print(to, to_arg, "%02X", *s++);
+ }
++
++ erts_free(ERTS_ALC_T_TMP, (void *) sbuf);
+ }