summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-09-17 19:16:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-09-17 19:16:49 +0000
commitaa63c8d386819fc54a43918c1c8f8823db8ef1d0 (patch)
tree8b87c363b3ffec32ec7b2a0d57054173aa22cf8b /dev-lang
parentKeyword ~arm (diff)
downloadgentoo-2-aa63c8d386819fc54a43918c1c8f8823db8ef1d0.tar.gz
gentoo-2-aa63c8d386819fc54a43918c1c8f8823db8ef1d0.tar.bz2
gentoo-2-aa63c8d386819fc54a43918c1c8f8823db8ef1d0.zip
Fix shared library symlink. Bug #485064
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jimtcl/ChangeLog8
-rw-r--r--dev-lang/jimtcl/jimtcl-0.74-r1.ebuild (renamed from dev-lang/jimtcl/jimtcl-0.74.ebuild)6
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild8
3 files changed, 17 insertions, 5 deletions
diff --git a/dev-lang/jimtcl/ChangeLog b/dev-lang/jimtcl/ChangeLog
index 08f95e14650b..0827e4fb3975 100644
--- a/dev-lang/jimtcl/ChangeLog
+++ b/dev-lang/jimtcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/jimtcl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.10 2013/08/28 11:16:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.11 2013/09/17 19:16:49 hwoarang Exp $
+
+*jimtcl-0.74-r1 (17 Sep 2013)
+
+ 17 Sep 2013; Markos Chandras <hwoarang@gentoo.org> +jimtcl-0.74-r1.ebuild,
+ -jimtcl-0.74.ebuild, jimtcl-9999.ebuild:
+ Fix shared library symlink. Bug #485064
28 Aug 2013; Agostino Sarubbo <ago@gentoo.org> jimtcl-0.73.ebuild:
Stable for x86, wrt bug #479834
diff --git a/dev-lang/jimtcl/jimtcl-0.74.ebuild b/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
index f087e3861717..7377dc88fbda 100644
--- a/dev-lang/jimtcl/jimtcl-0.74.ebuild
+++ b/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.74.ebuild,v 1.1 2013/09/13 23:45:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild,v 1.1 2013/09/17 19:16:49 hwoarang Exp $
EAPI="5"
+inherit multilib
+
DESCRIPTION="Small footprint implementation of Tcl programming language"
HOMEPAGE="http://jim.tcl.tk"
SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
@@ -34,6 +36,8 @@ src_install() {
dolib.a libjim.a
} || {
dolib.so libjim.so.${PV}
+ dosym /usr/$(get_libdir)/libjim.so.${PV} \
+ /usr/$(get_libdir)/libjim.so
}
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index 3c35403c57ef..f73fa4ac23f1 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.7 2013/09/13 23:51:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.8 2013/09/17 19:16:49 hwoarang Exp $
EAPI="4"
-inherit git-2
+inherit multilib git-2
DESCRIPTION="Small footprint implementation of Tcl programming language"
HOMEPAGE="http://jim.tcl.tk"
@@ -33,6 +33,8 @@ src_install() {
dolib.a libjim.a
} || {
dolib.so libjim.so*
+ dosym /usr/$(get_libdir)/libjim.so* \
+ /usr/$(get_libdir)/libjim.so
}
insinto /usr/include
doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h