summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-29 20:31:34 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-29 20:31:34 +0000
commitc9d4fb79ec6497e661f100e53c7bb530e1f5b472 (patch)
tree2b232628b76206a22a5fba0adc7135a5616343bb /dev-lang
parentInherit systemd (#478670 by Alphat-PC) (diff)
downloadgentoo-2-c9d4fb79ec6497e661f100e53c7bb530e1f5b472.tar.gz
gentoo-2-c9d4fb79ec6497e661f100e53c7bb530e1f5b472.tar.bz2
gentoo-2-c9d4fb79ec6497e661f100e53c7bb530e1f5b472.zip
version bump
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/fpc-ide/ChangeLog7
-rw-r--r--dev-lang/fpc-ide/fpc-ide-2.6.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-lang/fpc-ide/ChangeLog b/dev-lang/fpc-ide/ChangeLog
index ee94c2d080a9..ca315e0273c8 100644
--- a/dev-lang/fpc-ide/ChangeLog
+++ b/dev-lang/fpc-ide/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/fpc-ide
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/ChangeLog,v 1.18 2013/02/02 08:25:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/ChangeLog,v 1.19 2013/07/29 20:31:33 hasufell Exp $
+
+*fpc-ide-2.6.2 (29 Jul 2013)
+
+ 29 Jul 2013; Julian Ospald <hasufell@gentoo.org> +fpc-ide-2.6.2.ebuild:
+ version bump
*fpc-ide-2.6.0 (02 Feb 2013)
diff --git a/dev-lang/fpc-ide/fpc-ide-2.6.2.ebuild b/dev-lang/fpc-ide/fpc-ide-2.6.2.ebuild
new file mode 100644
index 000000000000..263e84762062
--- /dev/null
+++ b/dev-lang/fpc-ide/fpc-ide-2.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc-ide/fpc-ide-2.6.2.ebuild,v 1.1 2013/07/29 20:31:34 hasufell Exp $
+
+EAPI=5
+
+
+HOMEPAGE="http://www.freepascal.org/"
+DESCRIPTION="Free Pascal Compiler Integrated Development Environment"
+SRC_URI="mirror://sourceforge/freepascal/fpcbuild-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="~dev-lang/fpc-${PV}"
+RDEPEND="${DEPEND}"
+
+# test gives compile errors, was not updated with fpc changes
+RESTRICT="test"
+
+S=${WORKDIR}/fpcbuild-${PV}/fpcsrc/ide
+
+src_prepare() {
+ find "${WORKDIR}" -name Makefile -exec sed -i -e 's/ -Xs / /g' {} + || die
+
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set}; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+ sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
+ fi
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ emake -j1 INSTALL_PREFIX="${D}"usr install || die "make install failed"
+}
+
+pkg_postinst() {
+ einfo "To read the documentation, enable the doc USE flag for dev-lang/fpc,"
+ einfo "and add /usr/share/doc/fpc-${PV}/fpctoc.htx to the Help Files list."
+}