summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-08-18 21:58:15 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-08-18 21:58:15 +0000
commitd060426a60991328052ffbca2aef1e49f04291b6 (patch)
treee80ee27f9b9f2c02f12cd70845f16e870ff74829 /dev-lang
parentClosing #60417 and #60758 (Manifest recommit) (diff)
downloadgentoo-2-d060426a60991328052ffbca2aef1e49f04291b6.tar.gz
gentoo-2-d060426a60991328052ffbca2aef1e49f04291b6.tar.bz2
gentoo-2-d060426a60991328052ffbca2aef1e49f04291b6.zip
*** empty log message ***
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog5
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.8.ebuild15
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index fb45762fe119..d9c34b50faeb 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.2 2004/07/16 09:43:58 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.3 2004/08/18 21:58:15 mkennedy Exp $
+
+ 18 Aug 2004; <mkennedy@gentoo.org> gnu-smalltalk-2.1.8.ebuild:
+ Fixed problem with configuration parameters when tcltk is not in USE
16 Jul 2004; David Holm <dholm@gentoo.org> gnu-smalltalk-2.1.8.ebuild:
Added to ~ppc.
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.8.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.8.ebuild
index 943bf401761a..a01874d7ca4d 100644
--- a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.8.ebuild
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.8.ebuild,v 1.2 2004/07/16 09:43:58 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.1.8.ebuild,v 1.3 2004/08/18 21:58:15 mkennedy Exp $
inherit elisp-common flag-o-matic eutils gcc
@@ -31,15 +31,24 @@ src_unpack() {
}
src_compile() {
+ local myconf=""
+
+ if use tclk; then
+ myconf="
+ `use_with tcltk tcl=/usr/lib` \
+ `use_with tcltk tk=/usr/lib`"
+ fi
+
replace-flags '-O3' '-O2'
+
econf \
`use_with emacs emacs` \
`use_with readline readline` \
- `use_with tcltk tcl=/usr/lib` \
- `use_with tcltk tk=/usr/lib` \
`use_with gmp gmp` \
`use_enable gtk gtk` \
+ ${myconf} \
|| die
+
emake || die "emake failed"
}