summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-07-14 18:08:36 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-07-14 18:08:36 +0000
commitd90328bf90c5ea5e015683217458f44a68c6e25e (patch)
tree6fecbc5268fd0aaf7bc5f224106e0fd1a8580029 /dev-lang
parentRemove 'app-admin/gkrellm ntlm' from package.use.mask now that libntlm is key... (diff)
downloadgentoo-2-d90328bf90c5ea5e015683217458f44a68c6e25e.tar.gz
gentoo-2-d90328bf90c5ea5e015683217458f44a68c6e25e.tar.bz2
gentoo-2-d90328bf90c5ea5e015683217458f44a68c6e25e.zip
Unbreak live ebuild (spell EGIT_REPO_URI properly).
(Portage version: 2.1.10.4/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jimtcl/ChangeLog6
-rw-r--r--dev-lang/jimtcl/files/jimtcl-9999-more-autobits.patch23
-rw-r--r--dev-lang/jimtcl/jimtcl-9999.ebuild10
3 files changed, 35 insertions, 4 deletions
diff --git a/dev-lang/jimtcl/ChangeLog b/dev-lang/jimtcl/ChangeLog
index 753cbb148b43..a54087303527 100644
--- a/dev-lang/jimtcl/ChangeLog
+++ b/dev-lang/jimtcl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/jimtcl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.1 2011/03/17 02:21:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.2 2011/07/14 18:08:36 slyfox Exp $
+
+ 14 Jul 2011; Sergei Trofimovich <slyfox@gentoo.org> jimtcl-9999.ebuild,
+ +files/jimtcl-9999-more-autobits.patch:
+ Unbreak live ebuild (spell EGIT_REPO_URI properly).
*jimtcl-9999 (17 Mar 2011)
*jimtcl-0.70_pre20110317 (17 Mar 2011)
diff --git a/dev-lang/jimtcl/files/jimtcl-9999-more-autobits.patch b/dev-lang/jimtcl/files/jimtcl-9999-more-autobits.patch
new file mode 100644
index 000000000000..f8cd00fe52c9
--- /dev/null
+++ b/dev-lang/jimtcl/files/jimtcl-9999-more-autobits.patch
@@ -0,0 +1,23 @@
+jimtcl's ./configure reimplementtaion dislikes --datadir / --libdir
+
+./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --with-jim-shared --with-jim-ext=nvp
+Host System...x86_64-pc-linux-gnu
+Build System...x86_64-pc-linux-gnu
+C compiler... x86_64-pc-linux-gnu-gcc -g -O2
+C++ compiler... x86_64-pc-linux-gnu-c++ -g -O2
+Checking for stdlib.h...ok
+Error: Unknown option --datadir
+Try: 'configure --help' for options
+diff --git a/autosetup/system.tcl b/autosetup/system.tcl
+index 3a2221a..7e534f1 100644
+--- a/autosetup/system.tcl
++++ b/autosetup/system.tcl
+@@ -25,6 +25,8 @@ module-options {
+ libexecdir:
+ sysconfdir:
+ localstatedir:
++ datadir:
++ libdir:
+
+ maintainer-mode=0
+ dependency-tracking=0
diff --git a/dev-lang/jimtcl/jimtcl-9999.ebuild b/dev-lang/jimtcl/jimtcl-9999.ebuild
index f544846cea27..ba99aa5fe18f 100644
--- a/dev-lang/jimtcl/jimtcl-9999.ebuild
+++ b/dev-lang/jimtcl/jimtcl-9999.ebuild
@@ -1,20 +1,24 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.1 2011/03/17 02:21:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-9999.ebuild,v 1.2 2011/07/14 18:08:36 slyfox Exp $
EAPI="2"
-inherit git
+inherit eutils git-2
DESCRIPTION="Small footprint implementation of Tcl programming language"
HOMEPAGE="http://jim.berlios.de/"
-EGIT_REPO="http://repo.or.cz/r/jimtcl.git"
+EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS=""
IUSE="static-libs"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-more-autobits.patch"
+}
+
src_configure() {
! use static-libs && myconf=--with-jim-shared
econf ${myconf} \