summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-20 07:50:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-20 07:50:32 +0000
commite1f3f01c95eba3bfbeb12d6bc370c4d326ccb632 (patch)
tree8f0de5e54ffdec1d35d7b571801f94330020cb3e /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-e1f3f01c95eba3bfbeb12d6bc370c4d326ccb632.tar.gz
gentoo-2-e1f3f01c95eba3bfbeb12d6bc370c4d326ccb632.tar.bz2
gentoo-2-e1f3f01c95eba3bfbeb12d6bc370c4d326ccb632.zip
Version bump. Bindings updates.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/vala/ChangeLog7
-rw-r--r--dev-lang/vala/vala-0.18.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-lang/vala/ChangeLog b/dev-lang/vala/ChangeLog
index 4312da427075..a9086b27ba09 100644
--- a/dev-lang/vala/ChangeLog
+++ b/dev-lang/vala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/vala
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.126 2012/10/30 17:27:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.127 2012/11/20 07:50:32 eva Exp $
+
+*vala-0.18.1 (20 Nov 2012)
+
+ 20 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> +vala-0.18.1.ebuild:
+ Version bump. Bindings updates.
30 Oct 2012; Jeroen Roovers <jer@gentoo.org> vala-0.18.0.ebuild:
Stable for HPPA (bug #438374).
diff --git a/dev-lang/vala/vala-0.18.1.ebuild b/dev-lang/vala/vala-0.18.1.ebuild
new file mode 100644
index 000000000000..8bfebf5d3a97
--- /dev/null
+++ b/dev-lang/vala/vala-0.18.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.18.1.ebuild,v 1.1 2012/11/20 07:50:32 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Vala - Compiler for the GObject type system"
+HOMEPAGE="http://live.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.18"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
+IUSE="test +vapigen"
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=dev-libs/vala-common-${PV}"
+DEPEND="${RDEPEND}
+ !${CATEGORY}/${PN}:0
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-unversioned
+ $(use_enable vapigen)"
+}