summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-20 03:55:37 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-20 03:55:37 +0000
commit206fd4fa88348c0b077bb3ffd1787729aa357d2a (patch)
treef0f144cf998a985c5a8d39e7392c03ec4a334f64 /dev-libs/DirectFB
parentStable for HPPA (bug #170747). (diff)
downloadgentoo-2-206fd4fa88348c0b077bb3ffd1787729aa357d2a.tar.gz
gentoo-2-206fd4fa88348c0b077bb3ffd1787729aa357d2a.tar.bz2
gentoo-2-206fd4fa88348c0b077bb3ffd1787729aa357d2a.zip
Version bump #171469 by Michele Noberasco.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/ChangeLog8
-rw-r--r--dev-libs/DirectFB/DirectFB-1.0.0.ebuild118
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch30
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-1.0.03
4 files changed, 158 insertions, 1 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index bd74a09972c9..e8d75fa177f0 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/DirectFB
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.62 2007/03/03 22:25:43 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.63 2007/03/20 03:55:37 vapier Exp $
+
+*DirectFB-1.0.0 (20 Mar 2007)
+
+ 20 Mar 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/DirectFB-1.0.0-headers.patch, +DirectFB-1.0.0.ebuild:
+ Version bump #171469 by Michele Noberasco.
03 Mar 2007; Marius Mauch <genone@gentoo.org> DirectFB-0.9.22.ebuild,
DirectFB-0.9.24.ebuild, DirectFB-0.9.25.1.ebuild:
diff --git a/dev-libs/DirectFB/DirectFB-1.0.0.ebuild b/dev-libs/DirectFB/DirectFB-1.0.0.ebuild
new file mode 100644
index 000000000000..8ca35ed1ede6
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-1.0.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.0.0.ebuild,v 1.1 2007/03/20 03:55:37 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic nsc nvidia radeon savage sis315 tdfx unichrome"
+IUSE_INPUT_DEVICES="dbox2remote elo-input gunze h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch none permount ps2mouse serialmouse sonypijogdial wm97xx"
+
+DESCRIPTION="Thin library on top of the Linux framebuffer devices"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~sh -sparc ~x86"
+IUSE="debug fbcon fusion gif jpeg mmx png sdl sse sysfs truetype v4l v4l2 zlib"
+
+# fusion? ( dev-libs/linux-fusion )
+DEPEND="sdl? ( media-libs/libsdl )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ sysfs? ( sys-fs/sysfsutils )
+ zlib? ( sys-libs/zlib )
+ truetype? ( >=media-libs/freetype-2.0.1 )"
+
+pkg_setup() {
+ if [[ -z ${VIDEO_CARDS} ]] ; then
+ ewarn "All video drivers will be built since you did not specify"
+ ewarn "via the VIDEO_CARDS variable what video card you use."
+ ewarn "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
+ echo
+ fi
+ if [[ -z ${INPUT_DEVICES} ]] ; then
+ ewarn "All input drivers will be built since you did not specify"
+ ewarn "via the INPUT_DEVICES variable which input drivers to use."
+ ewarn "DirectFB supports: ${IUSE_INPUT_DEVICES} all none"
+ echo
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.9.24-CFLAGS.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+}
+
+src_compile() {
+ local vidcards card input inputdrivers
+ for card in ${VIDEO_CARDS} ; do
+ has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
+ #use video_cards_${card} && vidcards="${vidcards},${card}"
+ done
+ [[ -z ${vidcards} ]] \
+ && vidcards="all" \
+ || vidcards=${vidcards:1}
+ for input in ${INPUT_DEVICES} ; do
+ has ${input} ${IUSE_INPUT_DEVICES} && inputdrivers="${inputdrivers},${input}"
+ #use input_devics_${input} && inputdrivers="${inputdrivers},${input}"
+ done
+ [[ -z ${inputdrivers} ]] \
+ && inputdrivers="all" \
+ || inputdrivers=${inputdrivers:1}
+
+ local sdlconf="--disable-sdl"
+ if use sdl ; then
+ # since SDL can link against DirectFB and trigger a
+ # dependency loop, only link against SDL if it isn't
+ # broken #61592
+ echo 'int main(){}' > sdl-test.c
+ $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
+ && sdlconf="--enable-sdl" \
+ || ewarn "Disabling SDL since libSDL.so is broken"
+ fi
+
+ econf \
+ --enable-static \
+ $(use_enable fbcon fbdev) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable gif) \
+ $(use_enable truetype freetype) \
+ $(use_enable fusion multi) \
+ $(use_enable debug) \
+ $(use_enable sysfs) \
+ $(use_enable zlib) \
+ $(use_enable v4l video4linux) \
+ $(use_enable v4l2 video4linux2) \
+ ${sdlconf} \
+ --with-gfxdrivers="${vidcards}" \
+ --with-inputdrivers="${inputdrivers}" \
+ --disable-vnc \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
+ dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ ewarn "Each DirectFB update in the 0.9.xx series"
+ ewarn "breaks DirectFB related applications."
+ ewarn "Please run \"revdep-rebuild\" which can be"
+ ewarn "found by emerging the package 'gentoolkit'."
+ ewarn
+ ewarn "If you have an ALPS touchpad, then you might"
+ ewarn "get your mouse unexpectedly set in absolute"
+ ewarn "mode in all DirectFB applications."
+ ewarn "This can be fixed by removing linuxinput from"
+ ewarn "INPUT_DEVICES."
+}
diff --git a/dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch b/dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch
new file mode 100644
index 000000000000..df9ef99353d3
--- /dev/null
+++ b/dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch
@@ -0,0 +1,30 @@
+Don't rely on the kernel to tell us what the cpu target is ... we'll just
+use the default values all the time instead.
+
+http://bugs.gentoo.org/152614
+
+--- lib/direct/ppcasm_memcpy_cachable.S
++++ lib/direct/ppcasm_memcpy_cachable.S
+@@ -34,8 +34,6 @@
+
+ #define __ASSEMBLY__
+
+-#include <linux/config.h>
+-
+ #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
+ #define L1_CACHE_LINE_SIZE 16
+ #define LG_L1_CACHE_LINE_SIZE 4
+
+Don't pollute the namespace with define hacks, just use the real deal.
+
+--- include/dfb_types.h
++++ include/dfb_types.h
+@@ -60,6 +60,8 @@
+
+ #endif
+
++#include <asm/types.h>
++#define DIRECTFB_NO_CRUFT
+ #ifndef DIRECTFB_NO_CRUFT
+ #define __u8 u8
+ #define __u16 u16
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-1.0.0 b/dev-libs/DirectFB/files/digest-DirectFB-1.0.0
new file mode 100644
index 000000000000..ed76353cb152
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-1.0.0
@@ -0,0 +1,3 @@
+MD5 ad746c49dc89ba6f99df71b17bbb1dc8 DirectFB-1.0.0.tar.gz 2432000
+RMD160 43e8b73f2a751e8dcb240e6b6c4c34055c5337c0 DirectFB-1.0.0.tar.gz 2432000
+SHA256 125941749103c08a5263f2ace01aac1533420d2ff6741d2bdde79689e5d02a05 DirectFB-1.0.0.tar.gz 2432000