summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-09 14:40:50 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-09 14:40:50 +0000
commit3494c7a1e41d7b3b8ff02bd3ba774c01ce5b693d (patch)
treef9b914f396a4cfd7aece76f7afd275056c84212c /dev-libs/apr-util
parentAdd support for eapi 4 (diff)
downloadgentoo-2-3494c7a1e41d7b3b8ff02bd3ba774c01ce5b693d.tar.gz
gentoo-2-3494c7a1e41d7b3b8ff02bd3ba774c01ce5b693d.tar.bz2
gentoo-2-3494c7a1e41d7b3b8ff02bd3ba774c01ce5b693d.zip
Drop the sqlite2 useflag, keep only sqlite3 around.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog5
-rw-r--r--dev-libs/apr-util/apr-util-1.3.12.ebuild30
2 files changed, 20 insertions, 15 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 361d537ff988..1bddad6e7667 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.163 2011/07/29 20:43:44 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.164 2011/09/09 14:40:50 scarabeus Exp $
+
+ 09 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> apr-util-1.3.12.ebuild:
+ Drop the sqlite2 useflag, keep only sqlite3 around.
*apr-util-1.3.12 (29 Jul 2011)
diff --git a/dev-libs/apr-util/apr-util-1.3.12.ebuild b/dev-libs/apr-util/apr-util-1.3.12.ebuild
index 41bc6a6c7b2a..79789c6123e3 100644
--- a/dev-libs/apr-util/apr-util-1.3.12.ebuild
+++ b/dev-libs/apr-util/apr-util-1.3.12.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.12.ebuild,v 1.1 2011/07/29 20:43:44 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.12.ebuild,v 1.2 2011/09/09 14:40:50 scarabeus Exp $
-EAPI="3"
+EAPI=4
# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
# APR_PV="${PV}"
-APR_PV="1.4.4"
+APR_PV="1.4.5"
inherit autotools db-use eutils libtool multilib
@@ -17,7 +17,7 @@ SRC_URI="mirror://apache/apr/${P}.tar.bz2"
LICENSE="Apache-2.0"
SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="berkdb doc freetds gdbm ldap mysql odbc postgres sqlite sqlite3"
+IUSE="berkdb doc freetds gdbm ldap mysql odbc postgres sqlite"
RESTRICT="test"
RDEPEND="dev-libs/expat
@@ -29,11 +29,12 @@ RDEPEND="dev-libs/expat
mysql? ( =virtual/mysql-5* )
odbc? ( dev-db/unixODBC )
postgres? ( dev-db/postgresql-base )
- sqlite? ( dev-db/sqlite:0 )
- sqlite3? ( dev-db/sqlite:3 )"
+ sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+DOCS=( CHANGES NOTICE README )
+
src_prepare() {
epatch "${FILESDIR}/${P}-bdb-5.2.patch"
eautoreconf
@@ -54,17 +55,18 @@ src_configure() {
myconf+=" --without-berkeley-db"
fi
- econf --datadir=/usr/share/apr-util-1 \
+ econf \
+ --datadir=/usr/share/apr-util-1 \
--with-apr=/usr \
--with-expat=/usr \
+ --without-sqlite2 \
$(use_with freetds) \
$(use_with gdbm) \
$(use_with ldap) \
$(use_with mysql) \
$(use_with odbc) \
$(use_with postgres pgsql) \
- $(use_with sqlite sqlite2) \
- $(use_with sqlite3) \
+ $(use_with sqlite sqlite3) \
${myconf}
}
@@ -77,12 +79,12 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
- find "${ED}" -name "*.la" -print0 | xargs -0 rm -f
- find "${ED}usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -print0 | xargs -0 rm -f
+ # --disable-static does not work
+ find "${ED}" -name "*.a" -exec rm -f {} +
- dodoc CHANGES NOTICE README
+ find "${ED}" -name '*.la' -exec rm -f {} +
if use doc; then
dohtml -r docs/dox/html/* || die "dohtml failed"
@@ -90,5 +92,5 @@ src_install() {
# This file is only used on AIX systems, which Gentoo is not,
# and causes collisions between the SLOTs, so remove it.
- rm -f "${D}usr/$(get_libdir)/aprutil.exp"
+ rm -f "${ED}usr/$(get_libdir)/aprutil.exp"
}